Lexi Help
Die neuesten Themen
» Private Nachrichten
von inde Gestern um 22:32

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde Gestern um 22:24

» Ad Ware im Forum?
von inde Gestern um 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank Gestern um 16:57

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Sa 24 Sep 2016 - 11:29

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

» Design vergrößern. Probleme mit Design.
von Minka02 Mo 19 Sep 2016 - 17:42

Partner
free forum

[Wahlschalter] Header/Logo wechselt nicht.

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Traiceheart am Mi 12 Jun 2013 - 12:51

Hallo Smile

Ich habe im Moment ein kleines Problem.

Bei meinem Wahlschalter wechselt das Logo/Header nicht.

ich habe ein eigenes CSS,das wäre dieses hier:
http://www.fileden.com/files/2013/5/23/3446448/logoschneerudel.css

In einigen Thread habe ich gelesen das man den echten Header maskieren soll und somit in das CSS eintragen soll.

Nur wenn ich mein Header maskiere taucht er nicht mehr auf und wenn ich den Wahlschalter benutze dann kommt auch beim Schneerudel kein neuer Header,der Platz bleibt leer.

Kann mir da jemand weiter helfen?

Lg Traice Wink

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Günther am Mi 12 Jun 2013 - 21:58

Hallo,

das ist richtig: Du maskierst das Logo in der Bilderverwaltung und trägst es stattdessen in die Wechselstyle-Stylesheets sowie in das Stylesheet des Originalstyles ein.
Dazu hast du auch den richtigen CSS-Code in Verwendung.

Der Fehler liegt aber in deinem Wechselschalter-Script. Dort, wo du das Stylesheet einbindem möchtest, hast du einen Fehler erzeugt:
Code:
else if (type == 'wert2')
{
document.write('<link rel="stylesheet" type="text/css"http://www.fileden.com/files/2013/5/23/3446448/logoschneerudel.css">');
}
Siehst du ihn? Smile

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Traiceheart am Do 13 Jun 2013 - 9:22

Sicher, jetzt wo dus sagst seh ichs Smile
Der Fehler lag hier:

else if (type == 'wert2')
{
document.write('<link rel="stylesheet" type="text/css" href="http://www.fileden.com/files/2013/5/23/3446448/logoschneerudel.css">');
}

Nur ich habe zwar nun das Problem gelöst aber wenn ich das bild maskiere wir das hauptlogo im originalstyle nicht angezeigt Sad
Die URL des Forums ist aber im Originalstyle drinne.

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Günther am Do 13 Jun 2013 - 10:37

@Günther schrieb:Du maskierst das Logo in der Bilderverwaltung und trägst es stattdessen in die Wechselstyle-Stylesheets sowie in das Stylesheet des Originalstyles ein.
Hast du das gemacht?

Wenn ja, dann lasse dein Forum bitte auch in diesem Zustand, damit ich es mir ansehen kann. Du machst die Änderung immer wieder rückgängig, sodass ich im Forum gar nicht sehen kann, wie weit du gekommen bist. Wink

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Traiceheart am Do 13 Jun 2013 - 18:23

Aber Zuckerpuppe hat doch geschrieben:
@Zuckerpuppe schrieb:Wenn ihr euren originalen, persönlichen Style, der vor dem Einbau des Wahlschalters im Forum installiert ist, behalten wollt, müsst ihr das folgendermaßen in das Script einsetzen:

Code:
<option value="Wert1">ORGINALSTYLE </option>


Code:
if (type == 'wert1')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://www.URL DES FORUMS/">');
}

und ich habe ja auch die URL des Forums eingefügt?!

oder muss ich das gesamte CSS des originalforums dort einfügen als CSS datei?

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Günther am Do 13 Jun 2013 - 18:28

Das ist ja auch alles okay gewesen, was du bisher gemacht hast. Es hat soweit alles funktioniert und dein letztes Problem war noch:
Nur ich habe zwar nun das Problem gelöst aber wenn ich das bild maskiere wir das hauptlogo im originalstyle nicht angezeigt
Die Lösung lautet: Genauso, wie du das Logo im Wechselstyle-CSS angegeben hast...
Code:
#i_logo {
  background-image: ...
  height:
  width: ...
}
... musst du es auch im Stylesheet des Originalstyles unter
AB -> Anzeige -> Bilder & Farben -> Farben -> Reiter "CSS Stylesheet"
angeben. Verstehst du? Smile

Du fügst diesen CSS-Code für das Logo also nicht nur in die Stylesheets ein, die du auf fileden uploadest und in den Wahlschalter einsetzt, sondern auch im Forum selbst unter
AB -> Anzeige -> Bilder & Farben -> Farben -> Reiter "CSS Stylesheet".
Nur dann wird im Originalstyle + in den Wechselstyles ein Logo angezeigt.

Alles klar? Smile

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Traiceheart am Sa 15 Jun 2013 - 15:40

Achsoooo jetzt habe Ich es verstanden <3 
Vielen Dank für deine Hilfe Wink

Lg,
Traice

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [Wahlschalter] Header/Logo wechselt nicht.

Beitrag von Günther am Sa 15 Jun 2013 - 18:49

Bitte. Smile
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten