Lexi Help
Die neuesten Themen
» Themen fixieren
von Ray Heute um 5:54

» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 19:18

» [Update] Neues Theme der mobilen Version V2
von Tierfreund-97 Gestern um 17:05

» Begriff : "merken"
von Ray Gestern um 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Gestern um 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

Partner
free forum

[phpBB2] Chat mit Button öffnen

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Chat mit Button öffnen

Beitrag von ♥~Sarah~♥ am Fr 31 Mai 2013 - 11:12

Hi ^^

Ich hatte diese Code im Template stehen, um den Chat über einen Button zu öffnen.

Code:
<TABLE style="Z-INDEX: 10000; POSITION: fixed; BOTTOM: 10px; LEFT: 0px">
<TBODY>
<TR>
<TD><IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="../chatbox/index.forum?" frameBorder=0 marginWidth=0 scrolling=no></IFRAME></TD>
<TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png')?'block':'none';this.src=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png')?'http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png':'http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png';" src="http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png"></TD></TR></TBODY></TABLE>

Da hat auch alles wunderbar funktioniert, nur stand auf dem Button Close um zu öffnen und open um zu schließen, und ich wollte es anders rum haben. Also habe ich die Grafiken ausgetauscht und zwar so.

Code:
<TABLE style="Z-INDEX: 10000; POSITION: fixed; BOTTOM: 10px; LEFT: 0px">
<TBODY>
<TR>
<TD><IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="../chatbox/index.forum?" frameBorder=0 marginWidth=0 scrolling=no></IFRAME></TD>
<TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png')?'block':'none';this.src=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png')? 'http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png': 'http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png';" src="http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png"></TD></TR></TBODY></TABLE>

Jetzt sieht man aber überhaupt keinen Button mehr. Woran kann das liegen?

EDIT: Ich habe den alten jetzt nochmal rein gemacht, jetzt funktioniert der auch nicht mehr =/

Link zum Forum: http://sekai.get-forum.com


Zuletzt von ♥~Sarah~♥ am Fr 31 Mai 2013 - 11:58 bearbeitet, insgesamt 1 mal bearbeitet

♥~Sarah~♥
Neuling
Neuling

Beiträge : 47
Anmeldedatum : 30.06.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von #Frank am Fr 31 Mai 2013 - 11:27

Kann es sein, das du hinter dieser Zeile nach dem Fragezeichen jenen Zeilenumbruch eingesetzt hast?
Code:
(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png')?
Oder ist das nur in deinem Code so umgebrochen wurden.
Du kannst auch noch mal nach Themen dazu suchen, weil wir inzwischen auch schon bessere und einfachere Lösungen haben, die sehr gut Funktionieren. Es gibt auch eine Lösung, bei der diese Box auch bei Seitenwechsel offen bleibt.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von ♥~Sarah~♥ am Fr 31 Mai 2013 - 11:39

Das ist jetzt nur im code hier so umgebrochen. In den Templates habe ich keine umbrüche gemacht. Ich war eigentlich zufrieden mit dem code. Und es hatte ja auch geklappt, bis vorhin noch. xD

♥~Sarah~♥
Neuling
Neuling

Beiträge : 47
Anmeldedatum : 30.06.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von #Frank am Fr 31 Mai 2013 - 11:43

So auf anhieb sehe ich kein Fehler.
Ich muss mir das nochmal am Rechner ansehen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von ♥~Sarah~♥ am Fr 31 Mai 2013 - 11:48

okay danke für deine mühe ^^

♥~Sarah~♥
Neuling
Neuling

Beiträge : 47
Anmeldedatum : 30.06.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von #Frank am Fr 31 Mai 2013 - 11:50

o.k. ich habe in deinem zweiten Code zwei Leerzeichen gefunden, die dort nicht hin gehören.
Diese habe ich nun entfernt.
Bitte setze diese Gesamten Code mal bei dir ein:
Code:
<TABLE style="Z-INDEX: 10000; POSITION: fixed; BOTTOM: 10px; LEFT: 0px">
    <TBODY>
    <TR>
    <TD><IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="../chatbox/index.forum?" frameBorder=0 marginWidth=0 scrolling=no></IFRAME></TD>
    <TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png')?'block':'none';this.src=(this.src=='http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png')?'http://i79.servimg.com/u/f79/13/49/40/91/chatcl10.png':'http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png';" src="http://i79.servimg.com/u/f79/13/49/40/91/chatop10.png"></TD></TR></TBODY></TABLE>
Ich denke das es dann wieder funktioniert.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von ♥~Sarah~♥ am Fr 31 Mai 2013 - 11:58

Es funktioniert. An dem Code war aber doch nichts falsch =/ Es hatte nämlich ebend wieder nicht funktioniert und dann habe ich mir gedacht, da ich ja nur das mit dem chat in dem template eingebaut hatte, setze ich es einfach mal komplett zurück mit dem roten x und jetzt ist mir aufgefallen, dass ich /script (oder so) was über dem code stehen muss, mit gelöscht hatte, als ich die codes ausgewechselt habe. =( tut mir leis. Danke danke danke für die mühe *blume geb* =D

♥~Sarah~♥
Neuling
Neuling

Beiträge : 47
Anmeldedatum : 30.06.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Chat mit Button öffnen

Beitrag von #Frank am Fr 31 Mai 2013 - 12:05

Gut, das konnte ich natürlich nicht sehen. Aber nicht desto trotz waren in deinem zweiten Code von oben zwei Leerzeichen zu viel. Und das war in der Funktion die für das Einsetzen der richtigen Grafik zuständig ist.
Wenn hier auch nur ein Leerzeichen zu viel ist, oder auch nur ein Semikolon fehlt, dann funktioniert das ganze nicht mehr.

Da es nun aber wieder läuft und du einen anderen Fehler gemacht hattest, schließen wir das hier jetzt hier.

closed



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten