Lexi Help
Partner
www.forumieren.com

Wahlschalter Problem

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Wahlschalter Problem

Beitrag von libbiosa am Fr 16 Jul 2010 - 14:45

Hallo,
Ich bins mal wieder^^ Ich habe heute nach Anleitung den Wahlschalter versucht ins Forum einzubauen. Aber irgendetwas mache ich falsch. Das Problem ist, dass wenn ich den Code in meine Forumsbeschreibung einfüge, der Wahlschalter nicht angezeigt wird.

Ich glaube ja das ich die html Seite "falsch gemacht" habe.
Hier ist sie. http://legend-storys.forumieren.de/Wahlschalter-h3.htm

und hier der Code:
Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Wechsel den Style </option><option value="wert1">Blauer Style</option>
<option value="wert2"> Roter Style </option></select>';


if (type == 'wert1')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://legend-storys.forumieren.de/forum.htm/">');
}

if (type == 'wert2')
{
   document.write('<link rel="stylesheet" type="text/css" href="
http://legend-storys.forumieren.de/158848-ltr.css">');
}



function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}




Auf der Startseite habe ich diesen Code eingefügt.
Code:
<div id=sugar></div><script type=text/javascript src=http://legend-storys.forumieren.de/Wahlschalter-h3.htm></script>


Hoffe das ihr mir helfen könnt. Ich verwende einen hitskin Style. Diesen findet ihr hier:
http://demo.nicetheme.com/index.htm?theme_id=158848

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am Sa 17 Jul 2010 - 0:41

Hallo Smile

was ich so auf Anhieb sehe, ist das erste Wort in deiner HTML-Seite...dort steht hallo und ich denke, dass du das versehentlich dort hast stehen lassen.
Nimm das mal bitte raus und versuche es noch einmal, dann müsste es klappen Wink

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 14:10

Hallo ! Nein, das hatte ich als Test reingeschrieben, um zu sehen, ob überhaupt was angezeigt wird^^ Es klappt ohne Hallo genauso schlecht. Razz

Ich habe es trotzdem mal rausgenommen.
Also einmal ohne Hallo
http://legend-storys.forumieren.de/page_html.forum?mode=preview

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 14:48

setz das mal so ein, dann funzt das auch Very Happy

Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Wechsel den Style </option><option value="wert1"> Blauer Style </option><option value="wert2"> Roter Style </option></select>';



if (type == 'wert1')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://legend-storys.forumieren.de/forum.htm/">');
}
else if (type == 'wert2')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://legend-storys.forumieren.de/158848-ltr.css">');
}



function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}


Zuletzt von Zuckerpuppe am So 18 Jul 2010 - 17:30 bearbeitet, insgesamt 1 mal bearbeitet

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 15:00

Sorry, vielleicht bin ich auch zu blöd darfür. Aber es klappt nicht. Ich habe beides eingefügt (code auf html seite, code auf startseite), aber auf der startseite wird nichts angezeigt. Die html Seite ansich sieht so aus:


Naja, wie schon gesagt. Da kann etwas nicht stimmen. Oder sollte die so aussehen?

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 16:31

dass die HTML-Ansicht so aussieht, ist völlig normal Wink

wenn du meine HTML-Seite so übernommen hast, wie ich es oben gepostet hab, dann kann es nur noch an den Templates liegen.
Wie ich sehe, ist in deinem Forum einiges über die Templates verändert worden...unter anderem "overall_header_new"

kannst du mal testweise dieses Template rauslöschen? (natürlich vorher die Änderungen irgendwo abspeichern, damit du sie gleich wieder einsetzen kannst) und dann mal schauen, ob der Wahlschalter angezeigt wird... Smile


Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 17:00

Eig.eine sehr gute Idee ! Leider klappt es immernoch nicht. Es könnte natürlich auch an einem anderen Template liegen.. Ich muss das mal alles testen ...

Edit//:

Ok jetzt bin ich wirklich überfragt. Es kann ja schließlich nur am index_body oder am overall_header_new liegen, aber als ich die auch ersetzt hatte, war immernoch keine veränderung zu sehen. Neutral


Zuletzt von libbiosa am So 18 Jul 2010 - 17:09 bearbeitet, insgesamt 1 mal bearbeitet

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 17:07

dann setze doch mal probeweise den Wahlschalter in ein Portalmodul..
dann siehst du ja auch, ob es funktioniert und es kann nur an einem Template liegen Wink

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 17:13

Aha. Als Modul klappt es auch nicht. Meine Forumsversion ist Punbb. Klappt das dort nicht??

Ich habe den Hitskin Style erst vor ein paar Tagen erstellt. Kann es sein das er so neu ist das es nicht funktioniert? Aber dann müsste der Wahlschalter wenigstens angezeigt werden...

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 17:27

hm...hast du das genau so eingesetzt?
Code:
<div id=sugar> </div> <script type=text/javascript src=http://legend-storys.forumieren.de/Wahlschalter-h3.htm></script>

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 17:38

Ja habe ich.
- Templates scheinen ok zu sein
- den Code gebe ich auch richtig ein.
> Es kann nur nach an den Codes an sich liegen...

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 17:47

an dem Script und der HTML-Seite kann es keinesfalls liegen, denn ich habe beides testweise in meinen PunBB-Testforum eingesetzt und es funktioniert sowohl im Modul, als auch über der Navigation scratch

es kann nur an einem Template liegen...und es kann eigentlich nur das Template "overall_header_new" sein, denn dort wird es ja über den Adminbereich eingesetzt...

hast du mal versucht, das Script direkt in ein Template einzusetzen? Setz das mal probeweise ins Template "overall_header_new" direkt hier hinter (ist zwar optisch nicht schön, aber ist ja nur zum Testen Wink )

Code:
<!-- BEGIN switch_desc -->
                  <p id="pun-desc">{switch_desc.SITE_DESCRIPTION}</p>
                  <!-- END switch_desc -->
               </div>
               <div id="pun-head">
                  <div id="pun-navlinks">
                     <ul class="clearfix">
                        <li>{GENERATED_NAV_BAR}</li>
                     </ul>
                  </div>
               </div>

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am So 18 Jul 2010 - 18:02

Klappt immernoch nicht. Mad
Aber ich geh jetzt erstmal offline, was essen. Danke für deine Bemühungen. Very Happy

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am So 18 Jul 2010 - 18:05

darf ich mir das mal vor Ort ansehen? Wenn du das möchtest, dann schick mir mal per PN deine Zugangsdaten (muss die vom Gründer haben, damit ich die Templates sehen kann)
Änder das Passwort und wenn ich fertig bin, dann änder es wieder um Wink


edit/ 18:15h - ich sehe, dass du nun offline bist...daher geh ich auch mal off und schau mir das dann morgen früh an, wenn du magst Smile

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von Zuckerpuppe am Mo 19 Jul 2010 - 9:23

Moin libbiosa Smile

dein Wechselschalter ist drin...hättest du das Script, das ich hier gepostet habe, einfach nur kopiert und eingesetzt, dann hätten wir uns viel Mühe sparen können Wink
Dort lag nämlich der Fehler...bei dir fehlten die Leerzeichen, daher konnte das nicht funktionieren.

@Zuckerpuppe schrieb:setz das mal so ein, dann funzt das auch Very Happy

Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Wechsel den Style </option><option value="wert1"> Blauer Style </option><option value="wert2"> Roter Style </option></select>';



if (type == 'wert1')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://legend-storys.forumieren.de/forum.htm/">');
}
else if (type == 'wert2')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://legend-storys.forumieren.de/158848-ltr.css">');
}



function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}


darauf bin ich aber erst gekommen, als ich alle Templates und das CSS komplett entfernt hatte (hab aber alles wieder eingesetzt)...weil ich angenommen habe, dass du mein gepostetes Script auch 1:1 eingesetzt hast Cool

nuja, jedenfalls klappt es nun und du kannst das Passwort wieder ändern Wink

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter Problem

Beitrag von libbiosa am Mo 19 Jul 2010 - 14:20

Oh,das habe ich nicht ? notknowing
Da habe ich wohl viel Arbeit, um nichts gemacht^^ Sorry
Danke für deine Hilfe, dann werde ich mal das Passwort ändern gehen .. top

libbiosa
Lehrling
Lehrling

Weiblich Beiträge : 103
Anmeldedatum : 17.11.09

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten