Lexi Help
Partner
www.forumieren.com

[phpBB2] Link lässt sich nicht anklicken

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Link lässt sich nicht anklicken

Beitrag von JeCel am Mo 23 Dez 2013 - 11:33

Hallo,
ich habe ein Problem in diesem Forum: http://magicschool.forumieren.net/
Im Portal habe ich ein Modul eingefügt klickt man nun auf den 2 Reiter Team sieht man da halt ein Team-Mitglied(Mich)
unter dem Bild habe ich den Link Kontakt hinzugefügt mit dem dirket zum schreiben einer neuen Nachricht weitergeleitet wird.
Doch aus irgendeinem Grund ist dieser nicht anklickbar  scratch 
Weiß jemand wieso?
Danke im Vorraus^^

Edit: Mir ist gerade auch noch aufgefallen das wenn der Team Reiter aufgeklappt ist das der Link zum Administrations-Bereich auch nicht geht


Zuletzt von JeCel am Mo 23 Dez 2013 - 17:32 bearbeitet, insgesamt 1 mal bearbeitet

JeCel
Lehrling
Lehrling

Weiblich Beiträge : 81
Anmeldedatum : 19.02.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von #Frank am Mo 23 Dez 2013 - 16:12

Du hast in deiner Tabelle ja eine Div Clas eingesetzt. Diese hast du aber mit Zahlreichen Atributen versehen. Unter anderem auch mit einem Border, einem Hintergrund und einer Schriftfarbe.
Wen du so was schon einsetzt kannst du deine Formatirungen auch im CSS einsetzen. Dann wird es übersichtlicher.
Du hast als Link das hier eingesetzt:
Code:
http://magicschool.forumieren.net/privmsg?mode=post&u=1
Meiner Meinung nach ist das nicht richtig. Wenn ich es richtig in Erinnerung habe, dann muss der Link so aussehen:
Code:
http://magicschool.forumieren.net/msg.forum?mode=post&u=1
Versuch den mal bitte so einzusetzen.
Wenn der Link dann immer noch nicht funktioniert, dann nimm ihn mal Testweise aus der Div Class raus. Das heißt du entfernst mal bitte die Div Class aus der Tabellen Zelle.

Edit: Versuch bitte noch mal, den Link so einsetzen:
Code:
<a href="../msg.forum?mode=post&u=1">Kontakt</a>
Da wir uns innerhalb eines Script befinden, kann es sein, das der mit der vollen Adresse nicht funktioniert.
Ich habe den so bei mir in meiner Testtabelle eingesetzt, und da klappt es einwandfrei.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von JeCel am Mo 23 Dez 2013 - 16:48

Ich habe es jetzt auf beide Weisen ausprobiert aber es geht immer noch nicht :/

JeCel
Lehrling
Lehrling

Weiblich Beiträge : 81
Anmeldedatum : 19.02.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von #Frank am Mo 23 Dez 2013 - 16:53

Sag mal, kann es sein, das du vor dem http einige Leerzeichen hast?
Also so:
<a href="   http://...">Kontakt</a>
und nicht so:
<a href="http://...">Kontakt</a>

Ich denke das ich da vier Leerzeichen sehe. Kann das sein?



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von JeCel am Mo 23 Dez 2013 - 16:55

Nein,
ich hab da jetzt kein Leerzeichen entdecken können...

JeCel
Lehrling
Lehrling

Weiblich Beiträge : 81
Anmeldedatum : 19.02.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von #Frank am Mo 23 Dez 2013 - 16:58

Kannst du mir mal die Admin Zugangsdaten per PN senden?
Irgendwas stimmt doch da nicht.
Ich würde mir dein Code gerne mal selber ansehen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von JeCel am Mo 23 Dez 2013 - 17:05

Ok,
PN ist raus und bitte nicht wegen der E-Mail wundern.
Verwechsle immer die bUttons.

Ich hoffe das lohnt sich auch wirklich nicht das wieder so ein total kleiner Anfänger-Fehler ist :/

Danke für die Hilfe Smile

EDIT:
Mir fällt gerade auf das der Link nur an einer bestimmten Stelle des Wortes funktioniert undzwar ganz am Anfang

JeCel
Lehrling
Lehrling

Weiblich Beiträge : 81
Anmeldedatum : 19.02.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von #Frank am Mo 23 Dez 2013 - 17:29

Das mit dem Beginn, ist ja Interessant, und du hast recht.
Und das hat mich auf den richtigen Weg gebracht.
Du hattest in dieser Zeile:
<div id="blend" style="width: 150px; height: 150px;">
das hier drin stehen:
<div id="blend" style="width: 600px; height: 250px;">
Und das ist der rund dafür gewesen, das der Link mit der blend Class überdeckt wurde.
Ich habe das nun ausgebessert und das den Massen der Grafik angepasst und nun klappt es auch Wink

Und auch der Link den ich eingesetzt habe, funktioniert so wie er ist.
Der Link ist nun auch auf der dritten Seite und dort kannst du ihn wieder weg nehmen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von JeCel am Mo 23 Dez 2013 - 17:32

Wow, vielen Danke Very Happy
Darauf wäre ich jetzt nicht gekommen
Viele, Vielen Dank
ich setzt dann mal das Erledigt-Icon

JeCel
Lehrling
Lehrling

Weiblich Beiträge : 81
Anmeldedatum : 19.02.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Link lässt sich nicht anklicken

Beitrag von #Frank am Mo 23 Dez 2013 - 17:34

Du kannst nun wieder deine Div Class in deinen Tabellenzeile einsetzen.
Ich habe mich auch wieder aus geloggt.
Und ja, das mit den Massen der der blend class ist mir erst aufgefallen, als du sagtest, das der erste Buchstabe anzuklicken geht.

closed



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten