Lexi Help
Die neuesten Themen
» [Update] Neues Theme der mobilen Version V2
von Forumbot Gestern um 19:32

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Gestern um 11:29

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

» Design vergrößern. Probleme mit Design.
von Minka02 Mo 19 Sep 2016 - 17:42

» Logo für Minka02 (Kampfkatzen-rgp.forumieren.net)
von inde Mo 19 Sep 2016 - 16:09

» Wo kann man einen Avatar als User iner Seite hochladen?
von inde Mo 19 Sep 2016 - 14:25

» FC Liverpool Forum
von inde Mo 19 Sep 2016 - 12:00

Partner
free forum

Navigationsleiste und modul kaputt im IE

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Admin bearbeitet Navigationsleiste und modul kaputt im IE

Beitrag von Dr.med.Wurst am Mo 1 Dez 2008 - 18:54

Hallo ,

Wie hier schonmal kurz angerissen ,ist meine Navy im IE verzerrt .

Am css wurde bisher nichts verändert .

Heute erst aufgefallen ,ist wohl aber seit 2 Wochen ,

(ich benutze sowas (IE) nicht )

Dr.med.Wurst
Kaiser
Kaiser

Männlich Beiträge : 2091
Hinweis : CS5 ,DW ,FL und InDesiGn--> keinen bock auf Pn's ;-)...
Anmeldedatum : 24.11.08

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Alex am Mo 1 Dez 2008 - 18:59

Hallo Smile

Was verstehst du denn unter "verzerrt" ?

Denn bei mir sieht die im FF2 und 3, IE 6,7 und 8, Opera und Safari überall gleich aus.....

Die Schrift hängt überall zu tief bzw. der Hintergrund zu hoch.

Meinst du das damit?






LG,
Alex Cool

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Dr.med.Wurst am Mo 1 Dez 2008 - 19:06

mom


navy-->

zumall die Navy (siehe FF) ja halb Transparent ist !

Modul-->

Dr.med.Wurst
Kaiser
Kaiser

Männlich Beiträge : 2091
Hinweis : CS5 ,DW ,FL und InDesiGn--> keinen bock auf Pn's ;-)...
Anmeldedatum : 24.11.08

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Alex am Mo 1 Dez 2008 - 19:14

Na das mit dem Partner-Modul ist klar.

Wenn über HTML keine max-Breite definiert ist, sondern nur über CSS, dann juckt das einige IE-Versionen wenig Wink

Die schaffen dann den Raum, der für Grafiken benötigt wird, egal, was da im Weg ist, und setzen alle nebeneinander.

--> Da muss also zwischen die Grafiken ein Zeilenumbruch <br> rein, dann ist das behoben.

Des weiteren (Navileiste) kennen einige Browser (auch der IE in manchen Versionen) transparente png nicht und dann gibts schwarze oder weisse Flecken, anstatt Transparenz.

--> In jedem Fall also bei sowas gif verwenden. Smile



Was stimmt denn sonst noch mit der Navbar konkret nicht (Bitte in Worten Wink )

LG,
Alex Cool

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Dr.med.Wurst am Mo 1 Dez 2008 - 19:33

Also Modul -->hät ich selber drauf kommen müssen,ja. thx nochmals.

Die Navy ,Klebt direkt (da durch das sie nicht #transp ist) auf der Startseitennachricht .

Und zwischen FaQ und Miglieder ist 2px breit, platz .

Dr.med.Wurst
Kaiser
Kaiser

Männlich Beiträge : 2091
Hinweis : CS5 ,DW ,FL und InDesiGn--> keinen bock auf Pn's ;-)...
Anmeldedatum : 24.11.08

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Alex am Mo 1 Dez 2008 - 19:45

Naja, muss mal halt bissele Platz schaffen unten...

Einmal ins CSS-Feld unten rein:

Code:
a.mainmenu, a.mainmenu:hover {
        padding-bottom: 10px;
        }

kannst natürlich auch weniger oder mehr px nehmen.


Rechts neben dem FAQ-Feld sitzt ein transparentes 1px-gif als Ersatz für den Suchen-Button. Das sorgt natürlich für mehr Abstand zwischen diesen Buttons.

--> Falls du den Suchen-Button nicht brauchst, dann diesen Menüpunkt an den Rand der Leiste verschieben, denn das 1-px-Gif kannst du nicht rausnehmen, da dann der Alternativtext ("Suchen") an dieser Stelle erscheint.





LG,
Alex Cool

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Dr.med.Wurst am Mo 1 Dez 2008 - 20:05

Hab es jetzt bis 800px hochgeschraubt -->keine Funktion ( den nachtrag im CSS. ) ist zwar nicht mein Fachgebiet ,aber ich peil sowas eigentlich, Mad .




p.s. :Hab mich grad mal mit IE duch meine Favoriten gekämpft ,es ist schrecklich. der Zerschießt massen an Foren und die Leute Peilen das gar nicht .


Edit: muss erstmal schluss machen ! Nicht wundern

Dr.med.Wurst
Kaiser
Kaiser

Männlich Beiträge : 2091
Hinweis : CS5 ,DW ,FL und InDesiGn--> keinen bock auf Pn's ;-)...
Anmeldedatum : 24.11.08

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Alex am Mo 1 Dez 2008 - 21:04

Jo,

offenbar gabs da ein Update mit einer Änderung, denn in meinen Foren mit eigenem CSS funktioniert das, aber bei deinem in der Tat wirklich nicht :-(

So gerne ich auch mit CSS arbeite, ist das aber dann eher ein Fall für eine HTML-Lösung, denn ich weiß noch nicht, was da eigentlich konkret verändert wurde.

--> Adminbereich/Anzeige/Templates/Allgemeines

und dort auf den Namen des Templates "overall_header_new" klicken.

Im Template dann in den folgenden Bereich das rote einfügen:

<div id="page-body">
<div id="{ID_CONTENT_CONTAINER}"{CLASS_CONTENT_CONTAINER}>
<table cellpadding="0" cellspacing="0" width="100%" class="three-col"><tbody>


<!-- Modifikation by Alex: Abstand unterhalb der Navbar -->
<tr>
<td colspan="3" height="20" width="100%"><img src="{SPACER}" height="20" width="1"></td>
</tr>
<!-- Ende Modifikation -->

<tr>
<td valign="top" width="{C1SIZE}">
<div id="{ID_LEFT}">
<!-- BEGIN giefmod_index1 -->

Danach "Absenden" klicken und das Template im folgenden Fenster durch Klick auf das grüne Plus aktivieren.

Das fügt einfach unterhalb der Navbar eine weitere Tabellenzeile ein, die in der Höhe verstellt werden kann (height-Attribut). Das spacer-Image sorgt dafür, dass die Tabellenzelle auch bei schwierigen Browsern nicht kollabieren kann.

--> Bei Änderungen der Höhe immer beide "height"-Werte im Code ändern, sonst verändert sich nichts Wink



LG,
Alex Cool

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Admin bearbeitet Re: Navigationsleiste und modul kaputt im IE

Beitrag von Dr.med.Wurst am Di 2 Dez 2008 - 20:10

cheers
Danke, hat einwandfrei geklappt ,außer das Zwischen -->

(<tbody> und <!--Modif. ) keine Leerzeichen sein Durften, aber ohne ging es .

Dankeschön

MFG Herr Wurst





Dr.med.Wurst
Kaiser
Kaiser

Männlich Beiträge : 2091
Hinweis : CS5 ,DW ,FL und InDesiGn--> keinen bock auf Pn's ;-)...
Anmeldedatum : 24.11.08

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten