Lexi Help
Partner
www.forumieren.com

overall_header_new

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

overall_header_new

Beitrag von Rene1986 am Mi 16 Jul 2008 - 12:00

Hallo leute!

Und zwar habe ich ein Proplem möchte gerne in dier Abteilung(overall_header_new) der Templates etwas verändern, und zwar das das Forumlogo und die menüzeile zusammenhängen aber es ist noch immer ein kleiner abstand dazwischen ich komm nicht drauf kann mir jemand helfen?
Geht das überhaupt?

Also hier mein beispiel:

---------------------------(Banner)
--><--(freie stelle)
-------------------------(Menüleiste)

Wie bekomme ich diese freie Stelle weg?


Füge mal den Skript hier ein:


Code:
<P>
</P>
<P> </P>
<P> </P>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{S_CONTENT_DIRECTION}" lang="{L_LANG}">
<head>
<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}">
{META}
<title>{PAGE_TITLE}</title>
{T_HEAD_STYLESHEET}
{CSS}
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript"><!--
window.open('{U_PRIVATEMSGS_POPUP}', '_faprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');
//-->
</script>
<!-- END switch_enable_pm_popup -->
<!-- BEGIN switch_report_popup -->
<script language="Javascript" type="text/javascript">
<!--
   report = window.open('{switch_report_popup.U_REPORT_POPUP}', '_phpbbreport', 'HEIGHT={switch_report_popup.S_HEIGHT},resizable=yes,scrollbars=no,WIDTH={switch_report_popup.S_WIDTH}');
   report.focus();
//-->
</script>
<!-- END switch_report_popup -->
{GREETING_POPUP}
<script type="text/javascript" src="/{JS_DIR}/{L_LANG}.js"></script>
<style type="text/css">
<!-- BEGIN hitskin_preview -->
#hitskin_preview {
margin: 0; padding: 0;
position: fixed;
top: 0; left: 0;
width: 100%;
height: 65px;
background: url('http://illiweb.com/fa/hitskin/hitskin_bar.png') repeat-x left -15px;
color: #fff;
}

* html #hitskin_preview { /* Fix for IE6m since it doesn't implement fixed positionning */
   position: absolute;
   top:expression(eval(document.compatMode && document.compatMode=='CSS1Compat') ? documentElement.scrollTop : document.body.scrollTop);
   z-index: 2;
   background: transparent url('http://illiweb.com/fa/hitskin/hitskin_bar-ie6.gif') repeat-x left -15px;
}

* html { /* Gunlaug's Speed fix for the above positionning fix. Sorry for the fix for the fix */
 background: #fff url(foo) fixed;
 }


#hitskin_preview h1 {
   float: left;
   margin: 3px 0 0 0;
   padding: 0 0 0 10px;
   font: italic normal 25px Arial,sans serif;
   color: #fff;
}
#hitskin_preview h1 img {
   vertical-align: middle;
}
#hitskin_preview em {
   color: #7CBA2C;
   font-weight: bold;
}
#hitskin_preview a {
color: #fff;
}
#hitskin_preview a:hover {
text-decoration: underline;
}

#hitskin_preview .content {
   text-align: right;
}

#hitskin_preview .content p {
   margin: 4px 1em 0px 1em;
   font-size: 13px;
   line-height: 1.8em;
   color: #fff;
   font-weight: bold;
}
#hitskin_preview .content p span {
   font-weight: normal;
   font-size: 0.8em;
}
body {
   margin-top: 40px !important;
}
{hitskin_preview.HITSKIN_RTL_CSS}
<!-- END hitskin_preview -->
</style>
</head>
<body background="{T_BODY_BACKGROUND}" bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">
<!-- BEGIN hitskin_preview -->
<div id="hitskin_preview" style="display: block;">
   <h1><img src="http://illiweb.com/fa/hitskin/hitskin_logo.png" alt="" /> Hit<em>skin</em>.com</h1>
   <div class="content">
      <p>
         {hitskin_preview.L_THEME_SITE_PREVIEW}
         <br />
         <span>{hitskin_preview.U_INSTALL_THEME}<a href="http://{hitskin_preview.U_RETURN_THEME}">{hitskin_preview.L_RETURN_THEME}</a></span>
<!-- END hitskin_preview -->
<a name="top"></a>
{JAVASCRIPT}
<center>
<table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0">
<tr>
<td class="bodyline">
<table width="100%" cellspacing="0" cellpadding="0" border="0"><tr>
<!-- BEGIN switch_logo_left -->
<td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
<td align="center" width="100%" valign="middle"><span class="maintitle">{SITENAME}</span><br /><span class="gen">{SITE_DESCRIPTION}<br>  </span></td>
<!-- END switch_logo_left -->

<!-- BEGIN switch_logo_center -->
<td align="center" width="100%" valign="middle"><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a><br />
<span class="maintitle">{SITENAME}</span><br /><span class="gen">{SITE_DESCRIPTION}</span></td>
<!-- END switch_logo_center -->

<!-- BEGIN switch_logo_right -->
<td align="center" width="100%" valign="middle"><span class="maintitle">{SITENAME}</span><br /><span class="gen">{SITE_DESCRIPTION}<br>  </span></td>
<td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
<!-- END switch_logo_right -->
<table cellspacing="0" cellpadding="0" border="0" align="{MENU_POSITION}">
<tr><td align="{MENU_POSITION}">
{GENERATED_NAV_BAR}
</td></tr></table><div style="clear: both;"></div></center>
<div id="page-body">
<div id="{ID_CONTENT_CONTAINER}"{CLASS_CONTENT_CONTAINER}>
<table cellpadding="0" cellspacing="0" width="100%" class="three-col">
<tbody>
<td valign="top" width="{C1SIZE}">
   <div id="left">
      <!-- BEGIN giefmod_index1 -->
      {giefmod_index1.MODVAR}
      <!-- BEGIN saut -->   
      <div style="height:{SPACE_ROW}px"></div>
      <!-- END saut -->
      <!-- END giefmod_index1 -->
   </div>
</td>
<td valign="top" width="100%">
<br>
<br>
<br>
Scipte bitte unbedingt mit BB-Tag CODE versehen.

Rene1986
Neuling
Neuling

Männlich Beiträge : 45
Anmeldedatum : 02.07.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: overall_header_new

Beitrag von BraCay am Mi 16 Jul 2008 - 14:02

Ich denke mal dazu müsstest du die Variablen {SITENAME} und {SITE DESCRIPTION} entfernen, weil diese Leerenzeilen werden dadurch verursacht, weil du bei bei dem Forumnamen und bei der Beschreibung nichts stehen hast. Und wenn du diesen code entfernst kann möglicherweise ein Fehler im Admin-Panel auftreten.

oder du versuchst mal diese drei <br> tags zuentfernen, aber auf EIGENE GEFAHR!
Code:

<br>
<br>
<br>

EDIT: ich habe mal bei Forum name etwas einegfügt, und dieser eingefügte text hat genau den Platzhalter eingenommen, ergo, du musst die Variable forum name entfernen, damit diese freie stelle verschwindet.
Aber halte dich an die Tipps von Alex im daraufolgenden post.^^

ps: der hintergrund deines forums loggt die besucher eher weg als an, vllt solltest du die animation etwas langsamer erstellen.


Zuletzt von BraCay am Mi 16 Jul 2008 - 14:26 bearbeitet, insgesamt 1 mal bearbeitet

BraCay
Lehrling
Lehrling

Männlich Beiträge : 192
Anmeldedatum : 22.01.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: overall_header_new

Beitrag von Alex am Mi 16 Jul 2008 - 14:21

Hallo Smile

Template bei sowas immer vorher komplett kopieren und extra sichern, z.B. in Word oder einem text-Editor.

Sollte dabei etwas raus kommen, das nicht angezeigt werden kann, wird das Template automatisch auf den Urzustand zurückgesetzt und etwaige Änderungen sind verloren, wenn keine Sicherung erfolgt ist.









LG
Alex
Smile

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Benutzerprofil anzeigen

Nach oben Nach unten

Re: overall_header_new

Beitrag von Rene1986 am Mi 16 Jul 2008 - 15:02

aha danke


Zuletzt von Rene1986 am Mi 16 Jul 2008 - 15:27 bearbeitet, insgesamt 1 mal bearbeitet

Rene1986
Neuling
Neuling

Männlich Beiträge : 45
Anmeldedatum : 02.07.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: overall_header_new

Beitrag von Rene1986 am Mi 16 Jul 2008 - 15:13

DANKE DAS WAR ES:
{SITENAME} und {SITE DESCRIPTION}

Rene1986
Neuling
Neuling

Männlich Beiträge : 45
Anmeldedatum : 02.07.08

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten