Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind, loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Forenaustausch

Alle Anzeigen ansehen

Regeln und nützliche Hinweise
Lexi Help
Lexi Help
Schnelle
Hilfe
Klicke Hier
Die neuesten Themen
» Style löschen
von MSheppard Gestern um 19:24

» Bildlöschungen von servimg!
von Blocksberg Do 16 Nov 2017 - 19:36

» [phpBB2] Funktion 'Module einklappen', Bild erscheint nicht
von Nyan Do 16 Nov 2017 - 18:45

» [phpBB2] Komplettes Style durcheinander.. (CSS)
von Bigtuber Do 16 Nov 2017 - 13:23

» Https weg
von Fisch Di 14 Nov 2017 - 15:08

» Ansicht auf Avatar umstellen - Canesboard
von Keks Mo 13 Nov 2017 - 18:24

» Vernetzung mit dubiosen Seiten
von Ray Sa 11 Nov 2017 - 18:05

» [PunBB] Forentitel in Fettschrift bei Chrome
von Bigtuber Sa 11 Nov 2017 - 15:26

» [phpBB2] HTML Code zur Passworteingabe true/false hinzufügen
von Professor Sa 11 Nov 2017 - 12:07

» [Mitteilung] Abschied als Administrator im Forumieren-Support [inde]
von Broesel Do 9 Nov 2017 - 19:05

» [phpBB2] Titel des Forens in die Mitte schieben?
von Keks Mi 8 Nov 2017 - 17:03

» Domainname ändern und nicht verlängern
von goldhauch Mi 8 Nov 2017 - 9:43

» Moderatoren in Foren ausblenden
von Keks Di 7 Nov 2017 - 14:00

» Bitte um Übernahme des Gründeraccounts
von Carpe_Diem1985 Mo 6 Nov 2017 - 21:11

» Thema eines Authors übernehmen
von Emily Stein Mo 6 Nov 2017 - 16:00

» Hollywood Star Live
von Phoebe So 5 Nov 2017 - 20:22

www.forumieren.de

[phpBB2] Text-Ausrichtung funktioniert nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Text-Ausrichtung funktioniert nicht

Beitrag von SoulResonance am Mi 24 Aug 2016 - 18:22

Einen guten Abend euch allen!
Ich habe eine Frage bezüglich der Textpositionierung. Und zwar hätte ich dieser gerne vertikal-zentriert, allerdings funktioniert das irgendwie nicht, egal was ich verändere.

Hier einmal mein Template-Code index_box:
Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
 <tr>
 <td valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <span class="gensmall">{LAST_VISIT_DATE}<br />
 {CURRENT_TIME}<br />
 </span>
 <!-- END switch_user_logged_in -->
 <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
 </td>
 <td class="gensmall" align="right" valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
 <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
 <!-- END switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
 </td>
 </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
 <tr>
 <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th>
 </tr>
 <!-- END tablehead -->
 <!-- BEGIN cathead -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
 <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
 <h{catrow.cathead.LEVEL} class="hierarchy">
 <span class="cattitle">
 <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
 </span>
 </h{catrow.cathead.LEVEL}>
 </td>
 <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
 </tr>
 <!-- END cathead -->
 <!-- BEGIN forumrow -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
 <!-- END inc -->
 <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
 <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
 </td>
 <td colspan="{catrow.forumrow.INC_SPAN}" valign="top" height="90" width="100%">
 <h{catrow.forumrow.LEVEL} class="hierarchy">
 <span class="forumlink">
                                  <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
 </span>
 </h{catrow.forumrow.LEVEL}>
                  <div class="descriptionf"><div class="sorcha"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></div><span style="avery"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></span></div>
 </td>
 <td width="100px" height="90" valign="middle" align="center" class="envy">
                  Themen: <span class="gensmall">{catrow.forumrow.TOPICS}</span><br />Beiträge:<span class="gensmall">{catrow.forumrow.POSTS}</span>
 </td>
 </tr>
 <!-- END forumrow -->
 <!-- BEGIN catfoot -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
 <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
 </tr>
 <!-- END catfoot -->
 <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Und der dazugehörige CSS-Code:
Code:
.envy{
  width:90px;
  height:90px;
  border-radius:45px;
  font-family:Arial;
  font-size:10px;
  text-transform:uppercase;
  color:#787878;
  background-color:#fbfbfb;
  valign:middle;}

So sieht das ganze im Moment aus und die Seiten im Internet zu HTML und Co. helfen mir im Moment leider nicht weiter, weswegen ich hier auf Hilfe hoffe. Bin leider nicht die Hellste Leuchte, wenn es ums Coden geht ^^'


Liebe Grüße
Soul


Zuletzt von SoulResonance am Do 25 Aug 2016 - 13:19 bearbeitet; insgesamt 2-mal bearbeitet
avatar
SoulResonance
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 24.08.16
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Text-Ausrichtung funktioniert nicht

Beitrag von Keks am Mi 24 Aug 2016 - 21:28

Hallo,
verstehe ich das richtig das es nur rechts der Bereich: wo Themen & Beiträge stehen, diese mittig in den Kreis sollen?

Wenn ja einmal bitte hier belesen: CSS/Eigenschaften/Abstand/padding und CSS/Eigenschaften/Textausrichtung ...

Nicht aufgeben und weiter ausprobieren Wink

Edit: Ich hab gerade mir den Code mal genau angesehen, deine Css Angaben finde ich im Template nicht O.o, sicher das du dich da nicht bei dem Code vertan hast und eigentlich etwas anderes rein setzen wolltest?

Edit 2.: Es ist zu heiß zum denken heute, ich hab da noch einen Link den du dir ansehen kannst, das bringt dich einer Lösung näher: CSS display • Art der Darstellung. unter " table-cell" kommt erst das eigentlich interessante ... welches ich deinem Code so ergänzt habe:

Code:
.nowaxy{
  width:90px;
  height:90px;
  border-radius:45px;
  font-family:Arial;
  font-size:10px;
  text-transform:uppercase;
  color:#787878;
  background-color:#fbfbfb;
  display:table-cell;
  vertical-align:middle;}

Irgendwie ist das die Class die du angegeben hast, nicht die aus deinem Css im oberen Beitrag aber anders ließ sich der Bereich um den es geht nicht ansprechen.  

Bitte weiter ausführlich mit Css beschäftigen Wink  und schau dir dein Template noch einmal genauer an, dort ist ein kleiner "Fehler", ein Tipp von mir: Beschäftige dich noch einmal mit Tabellen (HTML).

So ich gehe nun mal schmelzen ... es ist ja viel zu warm hier ... bis morgen.
Der heutige konfuse Keks ^^
avatar
Keks
Moderator
Moderator

Weiblich Beiträge : 1057
Hinweis : Abwesend bis zum 22.11 wegen einer Erkältung
Anmeldedatum : 08.08.16
keine
Chrome ModernBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Text-Ausrichtung funktioniert nicht

Beitrag von SoulResonance am Do 25 Aug 2016 - 13:19

Einen wunderschönen, guten Tag und erst einmal Danke für die schnelle Hilfe!
Ich komme der Sache immerhin schon ein bisschen näher, nur das die Felder rund bleiben will noch nicht so ganz funktionieren, aber das finde ich schon raus... gestern war es wohl etwas zu heiß! Ich werde noch mal ein wenig rumprobieren und sollte es in einem Desaster enden, werde ich mich wohl noch mal melden müssen Very Happy also drückt mir die Daumen.

Liebe Grüße
Soul
avatar
SoulResonance
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 24.08.16
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Text-Ausrichtung funktioniert nicht

Beitrag von Keks am Do 25 Aug 2016 - 14:34

Bitte gerne Smile  und ja viel zu Heiß ^^ ich verschiebe das Denken, gedenke ich (anscheinend funktioniert es doch nicht wie gewollt) auf Montag! Da soll es endlich kühler werden. ^^

Viel Erfolg beim "herumdoktern" ^^


Dr.Keks
________________________________________________
Sprechzeiten:Mo. – Fr. 14.°° – 20.°°
Bereitschaft am WE:Sa. – So. 13.°° – 22.°°
Facharzt für alle Fälle:

Terminabsprachen nur in der Praxis, nicht per PN!

avatar
Keks
Moderator
Moderator

Weiblich Beiträge : 1057
Hinweis : Abwesend bis zum 22.11 wegen einer Erkältung
Anmeldedatum : 08.08.16
keine
Chrome ModernBB

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten