Lexi Help
Partner
www.forumieren.com

[phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Beitrag von lost_angel am Mi 29 Jun 2016 - 17:34

Hallo ihr,
ich bins mal wieder... *sorry* Embarassed

Aber ich hab da ein kleines Problem
Ich hab in meinem Testforum ein dunkles Hintergrundbild im Editor, im normalen Modus wird die SChriftfarbe auch korrekt weiß angezeigt.
Jetzt habe ich sie nach diesem Tutorial zum Anpassend des neuen Editors von Frank endlich auch die Schriftfarbe im  WYSIWJG Modus auf "weiß" umstellen können... allerdings verschwindet da das Hintergrundbild des Editors und der Hintergrund wird nur noch komplett schwarz angezeigt.

Ich habe schon alles mögliche durchprobiert, sowohl versucht im Javascript ein Hintergrundbild einzugeben wie auch im CSS... aber nichts half... kann aber auch sein, dass ich da was vergessen oder falsch eingetragen habe, dass es deshalb nicht angenommen wurde.

Folgende Codes verwende ich:
CSS-Codes:
Code:
/* Hintergrundbild im Editor */
    .sceditor-container iframe, .sceditor-container textarea {
      background-image: url("http://i35.servimg.com/u/f35/14/68/81/77/editor11.jpg") !important;
      background-position: top center !important;
      background-repeat: no-repeat !important;
      color:#ffffff  !important;
    }

/*WYSIWIG-Editor-Eingabefelder verändern*/
div.sceditor-dropdown input, div.sceditor-dropdown textarea {
background: none repeat scroll 0 0 #000000 !important; /*Hintergrund*/
border: 1px solid #000000 !important; /*Rahmen*/
color: #ffffff !important; /*Schriftfarbe*/
}

Javascript:
Code:
$(window).load(function () {
              $(".sceditor-container iframe").contents().find("head").append("<style>body,html,code:before,p,table{background-color:#000000!important;color:#ffffff!important;font-size:13px! important;}</style>")
            });

Wo könnte denn der Fehler liegen?
Es soll in beiden Modus-Varianten das Hintergrundbild zu sehen sein und die Schriftfarbe soll weiß sein.
Nehme ich aber das Javascript weg, dann bleibt zwar das Hintergrund, aber im WYSIWJG Modus ist dann die Schriftfarbe wieder schwarz und wie oben angemerkt mit Script ist die Schriftfarbe zwar weiß aber das Hintergrundbild fehlt. Sad

Würde mich freuen, wenn mir da jemand auf die Sprünge helfen kann.

Liebe Grüße und einen schönen Mittwoch-Abend!
eure Cara (lost angel)
XXX


Zuletzt von lost_angel am Do 30 Jun 2016 - 8:04 bearbeitet, insgesamt 1 mal bearbeitet

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Beitrag von lost_angel am Do 30 Jun 2016 - 8:03

Hey ihr,
sorry, dass ich euch "stören" musste... aber ich hab es jetzt irgendwie hinbekommen!
Hab im Javascrip einfach auf "gut Glück" den Code für die Hintergrundfarbe rausgenommen... probieren geht über studieren. Laughing
Und siehe da, Schrift blieb weiß und Hintergrund blieb auch, obwohl ich den WYSIWJG Modus eingeschalten hatte. Very Happy

Thema kann also geschlossen werden!
Danke aber trotzdem... manchmal scheint man echt den Wald vor lauter Bäumen nicht zu sehen. Embarassed

Liebe Grüße und einen schönen Donnerstag!
eure Cara (lost angel)
XXX

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten