Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Forenaustausch

Alle Anzeigen ansehen

Regeln und nützliche Hinweise
Lexi Help
Die neuesten Themen
» Schlüsselwörter Keywords Anzahl
von Mazacre Gestern um 16:56

» [#10397][phpBB3] Verschobene Werbung auf allen Seiten
von Bigtuber Gestern um 16:35

» [phpBB3] Standard für Beitragseingabe?
von Bigtuber Gestern um 16:26

» [#10418] meine Mailadresse ändern und Auswirkungen auf servimg
von Kellytime Gestern um 13:31

» Arcania - High-Fantasy-RPG
von Sheep007 Mi 26 Jul 2017 - 20:10

» [phpBB3] Profile mit mehreren Icons?
von inde Di 25 Jul 2017 - 19:39

» [#10378] Guthaben mit Paypal bezahlt und nach 2 Tagen nicht in der Guthabenverw
von inde Mo 24 Jul 2017 - 16:47

» World-of-Horses
von inde So 23 Jul 2017 - 16:56

» Yorkshire Terrier Forum
von inde So 23 Jul 2017 - 16:55

» Hundeforum unter hundis.frei-forum.com
von inde So 23 Jul 2017 - 16:53

» Das Raubtierreich - Das Haustier-Talk- und Fotografie-Forum
von Emily Stein So 23 Jul 2017 - 15:22

» Naruto - SnK
von Aiko-Chan So 23 Jul 2017 - 12:07

» Weimaraner-Forum "Der vielseitige Weimaraner"
von Emily Stein So 23 Jul 2017 - 1:57

» My-Ponyclub
von Emily Stein So 23 Jul 2017 - 1:54

» Pflanzen-Samentauschbörse
von Emily Stein So 23 Jul 2017 - 1:54

» [Warrior Cats] FlammenClan
von Emily Stein So 23 Jul 2017 - 1:44

www.forumieren.de

[phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Beitrag von lost_angel am Mi 29 Jun 2016 - 17:34

Hallo ihr,
ich bins mal wieder... *sorry* Embarassed

Aber ich hab da ein kleines Problem
Ich hab in meinem Testforum ein dunkles Hintergrundbild im Editor, im normalen Modus wird die SChriftfarbe auch korrekt weiß angezeigt.
Jetzt habe ich sie nach diesem Tutorial zum Anpassend des neuen Editors von Frank endlich auch die Schriftfarbe im  WYSIWJG Modus auf "weiß" umstellen können... allerdings verschwindet da das Hintergrundbild des Editors und der Hintergrund wird nur noch komplett schwarz angezeigt.

Ich habe schon alles mögliche durchprobiert, sowohl versucht im Javascript ein Hintergrundbild einzugeben wie auch im CSS... aber nichts half... kann aber auch sein, dass ich da was vergessen oder falsch eingetragen habe, dass es deshalb nicht angenommen wurde.

Folgende Codes verwende ich:
CSS-Codes:
Code:
/* Hintergrundbild im Editor */
    .sceditor-container iframe, .sceditor-container textarea {
      background-image: url("http://i35.servimg.com/u/f35/14/68/81/77/editor11.jpg") !important;
      background-position: top center !important;
      background-repeat: no-repeat !important;
      color:#ffffff  !important;
    }

/*WYSIWIG-Editor-Eingabefelder verändern*/
div.sceditor-dropdown input, div.sceditor-dropdown textarea {
background: none repeat scroll 0 0 #000000 !important; /*Hintergrund*/
border: 1px solid #000000 !important; /*Rahmen*/
color: #ffffff !important; /*Schriftfarbe*/
}

Javascript:
Code:
$(window).load(function () {
              $(".sceditor-container iframe").contents().find("head").append("<style>body,html,code:before,p,table{background-color:#000000!important;color:#ffffff!important;font-size:13px! important;}</style>")
            });

Wo könnte denn der Fehler liegen?
Es soll in beiden Modus-Varianten das Hintergrundbild zu sehen sein und die Schriftfarbe soll weiß sein.
Nehme ich aber das Javascript weg, dann bleibt zwar das Hintergrund, aber im WYSIWJG Modus ist dann die Schriftfarbe wieder schwarz und wie oben angemerkt mit Script ist die Schriftfarbe zwar weiß aber das Hintergrundbild fehlt. Sad

Würde mich freuen, wenn mir da jemand auf die Sprünge helfen kann.

Liebe Grüße und einen schönen Mittwoch-Abend!
eure Cara (lost angel)
XXX


Zuletzt von lost_angel am Do 30 Jun 2016 - 8:04 bearbeitet; insgesamt 1-mal bearbeitet
avatar
lost_angel
Premium User
Premium User

Weiblich Beiträge : 403
Anmeldedatum : 09.12.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Hintergrundbild des Editors im WYSIWJG Modus verschwindet

Beitrag von lost_angel am Do 30 Jun 2016 - 8:03

Hey ihr,
sorry, dass ich euch "stören" musste... aber ich hab es jetzt irgendwie hinbekommen!
Hab im Javascrip einfach auf "gut Glück" den Code für die Hintergrundfarbe rausgenommen... probieren geht über studieren. Laughing
Und siehe da, Schrift blieb weiß und Hintergrund blieb auch, obwohl ich den WYSIWJG Modus eingeschalten hatte. Very Happy

Thema kann also geschlossen werden!
Danke aber trotzdem... manchmal scheint man echt den Wald vor lauter Bäumen nicht zu sehen. Embarassed

Liebe Grüße und einen schönen Donnerstag!
eure Cara (lost angel)
XXX
avatar
lost_angel
Premium User
Premium User

Weiblich Beiträge : 403
Anmeldedatum : 09.12.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten