Lexi Help
Die neuesten Themen
» [Update] Neues Theme der mobilen Version V2
von Tierfreund-97 Gestern um 23:14

» Mobile Ansicht leider Fehlerhaft
von Br0adsw0rd Gestern um 19:31

» [phpBB2] Hintergrund festpinnen
von Fayé Gestern um 16:56

» Mein altes Forum zurückbekommen
von Bigtuber Do 29 Sep 2016 - 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

Partner
free forum

[phpBB2] Letzten 24h breite auf 100%geht nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Ruby Winchester am Mo 15 Feb 2016 - 13:52

Hallo,
Ich bräuchte mal bitte fachmännische Hilfe.
Es geht um die Wer war in den letzten  24h Online war abschnitt in der Wio.
In dem Tpl. steht folgendes:
<tr>
 <td colspan="6"><center><span id="members">{L_CONNECTED_MEMBERS}</span>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/Mitglieder die innerhalb der letzten 24 Stunden online waren/,"&nbsp;");</script>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/:/," ");</script></center><br><br></td>
</tr>

Im Quelltext allerdings steht das:
<tr><td class="row1"><span class="gensmall">Mitglieder die innerhalb der letzten 24 Stunden online waren: User</span></td></tr>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/Mitglieder die innerhalb der letzten 24 Stunden online waren/,"&nbsp;");</script>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/:/," ");</script>

Wie man also sieht greift das javascript an dieser stelle und nun brauch ich eine Lösung oder eine Möglichkeit das irgendwie zu umgehen oder irgendwas anderes weil die "Spalte" nur 50% der gesamt breite einnimmt und so langsam verzweifel ich hier -.-#

Vielen lieben Dank schon mal im voraus


Zuletzt von Ruby Winchester am Sa 19 März 2016 - 14:20 bearbeitet, insgesamt 1 mal bearbeitet

Ruby Winchester
Neuling
Neuling

Weiblich Beiträge : 23
Anmeldedatum : 29.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Ruby Winchester am Di 16 Feb 2016 - 10:34

Hab mal die Überschrift des Themas angepasst. Die vorige war denke ich nicht aussagekräftig worum es geht. Smile

Ruby Winchester
Neuling
Neuling

Weiblich Beiträge : 23
Anmeldedatum : 29.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Eule am Mi 17 Feb 2016 - 17:47

Hallo Ruby,

zum technischen Team gehöre ich wohl nicht, aber mir ist im Template etwas aufgefallen, das zumindest für mich keinen Sinn ergibt.

<tr>
<td colspan="6"><center><span id="members">{L_CONNECTED_MEMBERS}</span>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/Mitglieder die innerhalb der letzten 24 Stunden online waren/,"&nbsp;");</script>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/:/," ");</script></center><br><br></td>
</tr>

Edit: Ich habe mir die Struktur deines Forums eben noch mit Firebug angesehen.

Wenn du hier folgende Änderung vornimmst müsste es gehen:

<tr><td class="row1" colspan="6"><span class="gensmall">Mitglieder die innerhalb der letzten 24 Stunden online waren: User</span></td></tr>

Eule
Mod a.D.
Mod a.D.

Beiträge : 480
Anmeldedatum : 09.06.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Ruby Winchester am Mi 17 Feb 2016 - 18:37

Funktioniert leider nicht das es so vom tpl. nicht übernommen wird, das is ja das Problem.

Ruby Winchester
Neuling
Neuling

Weiblich Beiträge : 23
Anmeldedatum : 29.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Eule am Mi 17 Feb 2016 - 18:39

Auf Firebug hatte es bei mir funktioniert. Dann kann ich dir nur raten auf einen der Admins zu warten.

Eule
Mod a.D.
Mod a.D.

Beiträge : 480
Anmeldedatum : 09.06.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Ruby Winchester am Mi 17 Feb 2016 - 21:21

Es geht darum das im tpl. Kein row drin steht in dem <td> in fireburg geht es bei mir auch im tpl steht aber was anderes als in fireburg angezeigt wird.

Ruby Winchester
Neuling
Neuling

Weiblich Beiträge : 23
Anmeldedatum : 29.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Eule am Sa 20 Feb 2016 - 23:12

Kannst Du die betreffende Stelle oder etwas mehr hier mal zwischen zwei codetags posten?

Direkt in deinem Forum kann dir nur einer der Administratoren helfen.

Eule
Mod a.D.
Mod a.D.

Beiträge : 480
Anmeldedatum : 09.06.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Letzten 24h breite auf 100%geht nicht

Beitrag von Madeleine am So 21 Feb 2016 - 16:28

Hallo Eule,

ich kümmer mich um die Technik im besagten Forum ^^
Hier noch einmal der Code aus dem Tpl.:
Code:
<tr id="tabletitle">
       <td colspan="6">Wer war da?</td>
 </tr>
 <tr>
  [b]<td colspan="6">[/b]<center><span id="members">{L_CONNECTED_MEMBERS}</span>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/Mitglieder die innerhalb der letzten 24 Stunden online waren/,"&nbsp;");</script>
<script type="text/javascript">document.getElementById('members').innerHTML=document.getElementById('members').innerHTML.replace(/:/," ");</script></center><br><br></td>
</tr>

Hier der Code direkt aus dem Quellcode
Code:
<tr id="tabletitle"><td colspan="6">Wer war da?</td></tr>
<tr>[b]<td class="row1"><span class="gensmall">Mitglieder die innerhalb der letzten 24 Stunden online waren:[/b] Die User....</span></td></tr>

Alles was in den beiden Codes Fett markiert ist, ist eigentlich das Problem. Im Tpl. steht das was ausgegeben werden soll aber im Quellcode wird es eben nicht aus dem Tpl ausgelesen. Die Frage ist nun: Wieso wird es nicht ausgelesen und wie kann man das beheben?

Ps. Ich hab noch mal ne Screen gemacht wie man sieht sind die, die da waren nicht auf die komplette breite verteilt. Es wird nur in dieser Spalte die hälfte des gesamten Platzes genutzt.



EDIT:
Das Problem scheint gelöst zu sein und wurde als Erledigt markiert. Thema erledigt Deshalb wurde hier geschlossen.


Zuletzt von inde am Di 31 Mai 2016 - 15:57 bearbeitet, insgesamt 1 mal bearbeitet (Grund : EDIT:)

Madeleine
Lehrling
Lehrling

Weiblich Beiträge : 118
Hinweis : 1.Forum ist ein punBB
Anmeldedatum : 16.12.11

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten