Lexi Help
Die neuesten Themen
» [phpBB2] Schriftfarbe nicht vollständig
von Fayé Heute um 16:09

» [Wichtige Information] Meine Tätigkeit in diesem Support. Von #Frank
von #Frank Heute um 13:42

» [Update] Neues Theme der mobilen Version V2
von #Frank Heute um 13:03

» Mobile Ansicht leider Fehlerhaft
von Br0adsw0rd Gestern um 19:31

» [phpBB2] Hintergrund festpinnen
von Fayé Gestern um 16:56

» Mein altes Forum zurückbekommen
von Bigtuber Do 29 Sep 2016 - 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

Partner
free forum

Problem mit Accordion

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Problem mit Accordion

Beitrag von Yuzuki am Fr 18 Dez 2015 - 22:56

Hallo c:
ich hab da ein kleines Problem und zwar habe ich von einem anderen forum (leider ist der thread wo ich den code herhab irgendwie gelöscht worden desshalb kann ich kein link senden >.<) und naja ich kenn mich zwar einiger maßen mit html, css und co aus allerdings find ich den fehler einfach nicht xD das problem ist folgendes:
http://noragami-sekai.forumieren.com/t1-ihr-erstes-thema#2 (letzter beitrag) also es erfüllt zwar seinen zweck und fährt brav aus und zeigt den text allerdings möchte ich das alle balken gleich groß sind egal welcher tab gerade offen ist. ich hoffe mir kann jemand helfen q.q

Javascript:
Code:
$(document).ready(function(){
 
    activeItem = $("#accordion li:first");
    $(activeItem).addClass('active');
 
    $("#accordion li").hover(function(){
        $(activeItem).animate({width: "50px"}, {duration:300, queue:false});
        $(this).animate({width: "600px"}, {duration:300, queue:false});
        activeItem = this;
    });
 
});

CSS
Code:
#accordion {list-style: none;margin: 5px 0;padding: 0;height: 400px;overflow: hidden;background: #000000;width: 750px;}
#accordion li {float: left;border-left:0px;
  display: block;height: 400px;width: 50px;padding: 5px 0;overflow: hidden;text-decoration: none;font-size: 12px; line-height: 1.5em;}
#accordion li img {border: none;float: left;margin: -5px 5px 0 0;border-radius: 5px;-cr-border-radius: 5px; -webkit-border-radius: 5px; -o-border-radius: 5px;transition: all 0.4s ease-in-out 1s;}
#accordion li.active {width: 600px;}

HTML
Code:
<ul id="accordion">
                                                 
  <li>
                            <img src="http://oi61.tinypic.com/jqszcy.jpg" />ÜBERSCHRIFT HIER <br />     Text                                                  
  </li>
                                                 
  <li>
                            <img src="http://oi60.tinypic.com/taq7iw.jpg" />ÜBERSCHRIFT HIER <br />     Text                                                    
  </li>
                                                 
  <li>
                            <img src="http://oi60.tinypic.com/2v005t0.jpg" />
     <table>
        <tbody>
           <tr>
              <td>
                TEXT
              </td>
              <td>
              TEXT
              </td>
           </tr>
        </tbody>
     </table>
                         
  </li>
                                         
  <li>
                        <img src="http://oi62.tinypic.com/30satzd.jpg" />ÜBERSCHRIFT HIER <br />     Text                                                      
  </li>
</ul>

Yuzuki
Neuling
Neuling

Beiträge : 5
Anmeldedatum : 01.07.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Problem mit Accordion

Beitrag von Gunich am Mo 21 Dez 2015 - 13:45

Hallo Yuzuki

ich werde dir sagen wo das Problem zu finden ist. In deinem Code sind viele Zeilenumbrüche und Leerstellen enthalten. Und damit sind nicht die br Tags gemeint.
Wenn du HTML in den Beiträgen benutzt, empfiehlt es sich den Code ohne solche Freiräume, komplett aneinander zu schreiben und Zeilenumbrüche mit dem br Tag einzufügen. Dann kann es beim geposteten Beitrag nicht zu solchen Fehlern kommen. Dort werden nämlich alle Freiräume in das HTML Gerüst integriert, was zu seltsamen Abständen im fertigen Beitrag führt.
Versuch mal den Code so zu posten:
Code:
<ul id="accordion"><li><img src="http://oi61.tinypic.com/jqszcy.jpg" />ÜBERSCHRIFT HIER <br />Text</li><li><img src="http://oi60.tinypic.com/taq7iw.jpg" />ÜBERSCHRIFT HIER<br />Text</li><li><img src="http://oi60.tinypic.com/2v005t0.jpg" /><table><tbody><tr><td>TEXT</td><td>TEXT</td></tr></tbody></table></li><li><img src="http://oi62.tinypic.com/30satzd.jpg" />ÜBERSCHRIFT HIER <br />Text</li></ul>

Liebe Grüße
Gunich



EDIT:
Keine Rückmeldung mehr erhalten, das Problem scheint gelöst zu sein. Deshalb wurde hier geschlossen.
Sollte es noch Bedarf zu diesem Thema geben, dann bitte eine PN an den unten stehenden EDIT-Absender senden.


Zuletzt von inde am Sa 28 Mai 2016 - 20:09 bearbeitet, insgesamt 1 mal bearbeitet (Grund : EDIT:)

Gunich
Lehrling
Lehrling

Beiträge : 134
Anmeldedatum : 05.01.12

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten