Lexi Help
Partner
www.forumieren.com

[phpBB2]HTML-Code wird in Beitrag fehlerhaft dargestellt

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2]HTML-Code wird in Beitrag fehlerhaft dargestellt

Beitrag von Asliana am So 13 Dez 2015 - 1:04

Leider habe ich ein kleines Problemchen

Ich habe von einer meiner Mod einen Code bekommen, welcher leider in diesen Forum falsch dargestellt wird. Jedoch funktioniert es in einem anderen Forum einwandfrei… Ich habe mich schon durch einige Seite hier in der Suche gewühlt, aber keine der Lösungsansätzte hat etwas gebracht…
HTML ist aktiviert, ebenso auch im eigenen Profil. Andere Codes klappen auch.

Wenn man den Code hier eingibt, kann man sehen, wie der Code eigentlich aussehen sollte. Und das Bild zeigt, wie es im Forum angezeigt wird…




Hier der Code…

Code:
<style type="text/css">#plotbox{position: relative; width: 500px; height: 300px; border: 7px double rgba(247,247,247,0.8); box-sizing: border-box; overflow: hidden;} .plottext{position: absolute; top: 300px;  -webkit-transition: all 0.7s ease; transition: all 0.7s ease;  width: 487px; height: 290px; box-sizing: border-box; background: rgba(247, 247, 247, 0.8); padding: 10px; overflow: auto; text-align: justify; font-family: Verdana; font-size: 13px;} .plottext::-webkit-scrollbar{width: 5px; background: #f7f7f7;} .plottext::-webkit-scrollbar-thumb {background: #4B9699;} #plotbox:hover .plottext{position: absolute; top: 0px; -webkit-transition: all 0.7s ease; transition: all 0.7s ease; } .plottitel{margin-bottom: 10px; text-align: center; font-family:'Lobster Two'; font-size: 30px; color: #4B9699; text-shadow: 1px 0px 2px #222; border-bottom: 1px solid;}</style> <link href='https://fonts.googleapis.com/css?family=Lobster+Two:700' rel='stylesheet' type='text/css'><center><div id="plotbox" style="background: url('http://i68.servimg.com/u/f68/18/02/04/06/masken10.jpg');"><div class="plottext"><div class="plottitel">Maskenball Part 2</div>Lange ist der Maskenball noch nicht her, doch die Ereignisse liegen schwer auf den Schultern der Bewohner von Créatures de l’ombre. Dennoch blieben nicht alle so tatenlos, wie die meisten Menschen, manch einer versuchte dem Mord auf die Spur zu gehen… Azuka Ibori, die bekannte Wahrsagerin, konnte den Mord nicht vergessen und veranstaltete eine Party am Strand. Dabei hat sie jedoch gleich zwei Absichten: Neben dem Versuch die allgemeine Stimmung wieder etwas aufzubessern, möchte sie auch gleich die Gelegenheit nutzen, um eventuell den Schuldigen zu finden. </br>Doch sie ist nicht alleine mit dem Wunsch etwas in dieser Angelegenheit zu tun. Der Dämon Johannes van der Haas hat sich in die Jägeracademy eingelebt und möchte zusammen mit den jungen Jägern ebenfalls die Chance am Schopfe packen, um den Täter zu finden. Doch mit Sicherheit sind ihre Methoden weitaus weniger freundlich, als die der Wahrsagerin. Nun liegt es an dir, {USERNAME}, wie diese Feierlichkeit ausgehen wird.</div></div></center>


Ich bin dankbar für jede Hilfe!

Lg,
Asliana


Zuletzt von Asliana am Mi 16 Dez 2015 - 11:27 bearbeitet, insgesamt 1 mal bearbeitet

Asliana
Neuling
Neuling

Weiblich Beiträge : 9
Anmeldedatum : 01.06.09
Chrome

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2]HTML-Code wird in Beitrag fehlerhaft dargestellt

Beitrag von Asciugamano am Di 15 Dez 2015 - 11:35

Hallo Asliana,

der Übeltäter in diesem Falle nennt sich "Smiley" Wink
Der Code an sich ist korrekt, aber ein kleiner Teil des Codes wird in einen Smiley umgewandelt, weswegen er inkorrekt dargestellt wird. Du kannst dieses Problem ganz einfach lösen, indem du die Smileys für deinen Beitrag vor dem Absenden deaktivierst:
Rotes Kreuz unten:

Alternativ kannst du auch folgenden Part des Codes abändern, damit nicht mehr der Smiley interpretiert wird:
.plottext{position: absolute; top: 300px;  -webkit-transition: all 0.7s ease; transition: all 0.7s ease;  width: 487px; height: 290px; box-sizing: border-box; background: rgba(247, 247, 247, 0.Cool


Die Kombination Cool produziert . Wenn du also einen Abstand einfügst oder die Zahl abänderst, wird der Code auch funktionieren. (Die Cool-Kombination tritt in der .plottext-Klasse und auch in der #plottext-ID auf, du müsstest also zwei Stellen ändern.)

Liebe Grüße
Asciugamano

Asciugamano
Lehrling
Lehrling

Beiträge : 143
Anmeldedatum : 13.12.14

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2]HTML-Code wird in Beitrag fehlerhaft dargestellt

Beitrag von Asliana am Mi 16 Dez 2015 - 11:27

Och je, es kann so einfach sein… Vielen, vielen Dank!
Das ist an sich natürlich einfach… Gut, damit ist es erledigt!

Asliana
Neuling
Neuling

Weiblich Beiträge : 9
Anmeldedatum : 01.06.09
Chrome

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten