Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Regeln und nützliche Hinweise
Lexi Help
Die neuesten Themen
» Naruto - SnK
von Aiko-Chan Gestern um 16:41

» [Tutorial] Forenbanner in eine Diaschau verwandeln
von inde Gestern um 16:24

» [Tutorial] Ergebnisse der Umfragen optisch verändern
von inde Gestern um 11:44

» bestehendes Konto bei Forums Erstellung
von inde Sa 27 Mai 2017 - 20:14

» [phpBB3] Kostenloses Grafikprogramm für Windows 7 Ultimate 32bit gesucht
von inde Sa 27 Mai 2017 - 18:16

» Veröffentlichungen - Bilder in einer Zeile
von inde Sa 27 Mai 2017 - 16:15

» [phpBB3] Backup Rückgängig machen
von inde Fr 26 Mai 2017 - 12:29

» Natur und Wildlife Forum
von Stephan68 Do 25 Mai 2017 - 19:03

» [phpBB2] Charmed Bad Time
von Phoebe Do 25 Mai 2017 - 16:48

» [phpBB2] RPG-Forum Drachenkrieg
von Zocker96 Do 25 Mai 2017 - 14:14

» House Of The Rising Sun Rollenspiel-Forum
von Dr.Keks Do 25 Mai 2017 - 11:02

» Antwort landet im falschen Thema
von inde Do 25 Mai 2017 - 3:16

» [#9811] [phpBB2] Could not obtain rpg users infos
von inde Mi 24 Mai 2017 - 18:37

» [#9973] Abmeldeseite für User nicht aufrufbar
von inde Mi 24 Mai 2017 - 18:33

» [#9974] SSL plötzlich deaktiviert
von inde Mi 24 Mai 2017 - 18:30

» Header 714*264 für BVB134 (siamkatzenborussen.forumieren.com)
von inde Mi 24 Mai 2017 - 18:29

www.forumieren.de

[phpBB2] !important funktioniert nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] !important funktioniert nicht

Beitrag von Runningforever am Do 19 Nov 2015 - 20:56

hallo!

Ich habe ein problem, welches ich so schnell wie möglich gelöst haben wollte. Bloß hat sich das als komplizierter herausgestellt, als dass es eigentlich ist. Und zwar geht es mir um die Namen der Foren, die ich kleiner haben möchte bei der Forenanzeige (wenn das stimmt?). Ich habe die Forennamen per css und html bestimmt, damit sie auf der Startseite eben schön angezeigt werden. Wenn ich nun aber auf ein Forum klicke, werden die Kategorienbilder zwar klein angezeigt, die Forennamen jedoch nicht - die bleiben so. Ich habe es schon mit !important versucht, aber irgendwie funktioniert das nicht und lässt sich nicht überschreiben. Zur Veranschaulichung zeige ich euch nochmal ein Bild. Das Markierte hätte ich gerne kleiner:
Spoiler:

Versteht wer, was ich meine? Ich kann das schlecht erklären, aber hoffentlich wisst ihr wie ich mittels css die forennamen ändern kann.

Was auch gut wäre, wäre es den markierten Teil zu entfernen? Falls ihr mir vielleicht sagen könntet, welchen Teil ich da aus dem Template rauslöschen muss - habe das jetzt schon etwas probiert, aber ich finde die Stelle einfach nicht - wäre ich euch sehr, sehr dankbar!

lg
avatar
Runningforever
Neuling
Neuling

Beiträge : 11
Anmeldedatum : 20.04.15
keine
Chrome phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] !important funktioniert nicht

Beitrag von Asciugamano am Sa 21 Nov 2015 - 11:01

Hallo Runningforever,

du kannst dein Problem auf zwei verschiedene Arten lösen, welche ich dir nun beide aufzeigen werde:

1. Reines CSS. Wie ich mit Firebug erkennen kann, hast du für dein CSS das style-Attribut in einem div-Tag verwendet (entweder im Template selbst oder beim Eingeben des Forumtitels).
Das Style-Attribut (style="") ist für sowas eher nicht zu empfehlen, da er zum einen unübersichtlicher ist, Änderungen etwas aufwendiger werden, wenn man das CSS nicht alles in ein CSS-Stylesheet (Anzeige, Farben, CSS Stylesheet) packt und zum anderen hat ein style-Attribut innerhalb der HTML-Struktur immer höhere Priorität als externes CSS oder CSS, das mit dem style-Tag (<style type="text/css">) eingebunden wurde. !important würde ich übrigens aeusserst sparsam nutzen und wirklich nur dann, wenn es anders nicht geht, weil auch dann gerne mal die Ordnung verloren geht.

Jedenfalls  würde ich dich nun darum bitten, das style=" und alles, was darin ist, zu entfernen und stattdessen im Forum-CSS  einzubinden:
Code:
.forumlink {
CSS....
}
fuer das CSS auf der Indexseite und

Code:
.nav {
CSS...
}
für den gesamten markierten Bereich bei der Unterforenansicht. Wenn du in der Unterforenansicht den Startseitenlink nicht ansprechen willst, kannst du wahlweise auch
Code:
.nav h1 {
CSS...
}
verwenden, wodurch dann nur die Unterforenlinks angesprochen werden.

2. Die zweite Möglichkeit wäre eben, diese Links zu entfernen. Dazu fügst du im CSS-Stylesheet folgendes ein:
Code:
.nav {
display: none;
}

Ich hoffe, ich konnte dir helfen und falls etwas nicht klar sein sollte, einfach Bescheid geben!

Liebe Grüße
Asciugamano
avatar
Asciugamano
Lehrling
Lehrling

Beiträge : 147
Anmeldedatum : 13.12.14
keine
phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] !important funktioniert nicht

Beitrag von Runningforever am Mo 23 Nov 2015 - 20:16

Entschuldige, dass ich erst jetzt antworte!
Aber danke! Ich habe den Bereich, der mich gestört hat, mittels CSS entfernt - also die 2. Variante. Alles sieht aus wie ich es wollte. Genau das habe ich gesucht. Danke dir, du hast mir wirklich geholfen!

lg
avatar
Runningforever
Neuling
Neuling

Beiträge : 11
Anmeldedatum : 20.04.15
keine
Chrome phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten