Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Regeln und nützliche Hinweise
Lexi Help
Die neuesten Themen
» [phpBB2] Beiträge verschwinden, nachdem sie angeklickt wurde
von Emmy Petit Gestern um 21:34

» [Tuto] [alle Versionen] Funktion "diesen Code markieren"
von inde Gestern um 16:52

» Signal für Chat
von inde Mi 26 Apr 2017 - 23:43

» [phpBB2] "Ihre Sitzung ist abgelaufen".
von inde Mi 26 Apr 2017 - 23:41

» [ModernBB] Weiterleitung zur Startseite
von inde Mi 26 Apr 2017 - 19:57

» [phpBB2] Saol Eile : Welt der Mythen
von Sunshinex33 Mi 26 Apr 2017 - 3:12

» [ModernBB] Transparenz der Tabelle
von deafgopro Di 25 Apr 2017 - 15:47

» [ModernBB] Avatar - Profil auf die linke Seite
von deafgopro Mo 24 Apr 2017 - 21:52

» Benachrichtigungen
von inde Mo 24 Apr 2017 - 18:59

» [ModernBB] Profil Informationen im Forum - Farbe nicht veränderbar
von inde Mo 24 Apr 2017 - 15:54

» [#9712] Gründerwechsel nach Inaktivität des Gründers
von Bigtuber Mo 24 Apr 2017 - 14:09

» Sailor Moon Forum SMF
von Rika So 23 Apr 2017 - 12:09

» Natur und Wildlife Forum
von Stephan68 Sa 22 Apr 2017 - 19:44

» Gründerwechsel nach Inaktivität des Gründers
von Checvx Sa 22 Apr 2017 - 1:25

» Update der Facebook-Verbindung
von inde Fr 21 Apr 2017 - 18:07

» SPAM
von inde Fr 21 Apr 2017 - 17:53

www.forumieren.de

[phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 11:39

Ich warneulich im LexiHelp und suchte dort'M' ich fand auch dieKategorie die ich suche...Da war ein MouseOverEffekt-Code=ich habe ihn prepariert usw. Leider funktionierte er in meinem Forum nicht.Muss man ihn wirklich in AB>Anzeige>Farben>CSS Stylesheet?Wie prepariere ich den Code,damit er auch funktioniert? Very Happy
Code:
/*--hover-glitzer-beginn-*/
a:hover {
            POSITION: relative;  
            TOP: -1.0px; LEFT: 1.0px;}
a:hover {
            background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
            }
/*--hover-glitzer-end--*/

^
|
Code


Zuletzt von Silber am Do 1 Jan 2015 - 21:02 bearbeitet; insgesamt 2-mal bearbeitet
avatar
Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 11:43

Vergleich mal diesen Code hier aus der Beschreibung:
Code:
   /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Mit deinem Code:
Code:
   /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: -1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
                }
    /*--hover-glitzer-end--*/
Fällt dir irgendwas auf in der Zeile wo du dein Bild eingesetzt hast?

Ich habe mir gerade mal dein CSS angesehen. Dort scheint es einige Fehler zu geben und deshalb ist das wohl ungültig und wird somit nicht angewandt.
Bitte poste mal den gesamten Inhalt des Eingabefensters unter:
AB>Anzeige>Farben>CSS Stylesheet
hier in einer Code Box:
Code:
[code][/code]
Wir sollten uns das mal ansehen, damit wir da die Fehler raus bekommen.
So wie es aussieht, hast du einiges an Tipps hier aus dem Forum eingesetzt, aber die Codes immer falsch eingesetzt.
Ich denke das bei dir einige Zeichen fehlen und du eigentlich beim Absenden deiner Codes eine Fehlermeldung erhalten solltest.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 13:45

Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Stimmt,da kommt immer 'ne fehlermeldung ...
avatar
Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 14:01

@Silber schrieb:Stimmt,da kommt immer 'ne fehlermeldung ...

Siehst du, und genau deshalb solltest du mal den gesamten Inhalt des CSS Fensters hier posten.

Edit:

Du hast jetzt ja wieder das orginale CSS aus der beschreibung eingesetzt.
Du wolltest aber ein eigenes Bild einsetzen.
Schau dir das noch mal an:
Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Mit deinem Code:
Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: -1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
                }
    /*--hover-glitzer-end--*/

Der Fehler den ich meinte ist in dieser Zeile:

background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;

Richtig wäre:

background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif);

Siehst du den Unterschied? Du hast ein = Zeichen eingesetzt und die Klammern vergessen. Darum klappt das mit deiner Grafik auch nicht.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 14:17

Irgendwie verstehe ich dat nicht.Der Code klappt aber gehen auch andere Codes?Ich meine z.B.; Das Schatten hervortritt statt diesem Glitzer?
avatar
Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 14:25

Und du verstehst mich nicht:
...und genau deshalb solltest du mal den gesamten Inhalt des CSS Fensters hier posten.
es befinden sich fehler in deinen Codes und die möchte ich hier mal sehen um dir diese zu korrigieren.
Deshalb funktionieren einige Sachen nicht, die du eingesetzt hast.
Hast du mich jetzt verstanden?



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 15:30

Code:
}
{
background: none repeat scroll 0 0 transparent;
}

 
[href="/g1-Admins"]{
text-shadow: #FFFF00 0 0 6px;
}


a:hover {
color:#FFFFFF;
;
text-transform: uppercase;
text-decoration: none;
text-shadow: 3px 1px 3px #000000;}

a:link:focus, a:link:hover
{font-size: 10px;
    text-shadow: -1px 1px 10px #EDE0B9, 1px -1px 10px #C4A958;}
text-shadow: 3px 1px 3px #000000;

a:link:hover {
text-shadow: 0 0 0.7em #8B0000;
}


a:link {
    text-decoration: none;
    color: #32FA00;
    text-shadow: none;
    -webkit-transition: 500ms linear 0s;
    -moz-transition: 500ms linear 0s;
    -o-transition: 500ms linear 0s;
    transition: 500ms linear 0s;
    outline: 1 ;
}

a:link:hover, a:link:focus
{
    color: #000000;
    text-shadow: -1px 1px 8px #FFFFFF, 1px -1px 8px #FFFFFF;
}

/  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 2.0px; LEFT: 2.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/

So? ^^
avatar
Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 18:06

Ich habe dir nun mal die Fehler dort raus gemacht.
Bitte entferne alles aus dem CSS Fenster und setze das hier dafür ein:
Code:
   {
    background: none repeat scroll 0 0 transparent;
    }
    
    [href="/g1-Admins"]{
    text-shadow: #FFFF00 0 0 6px;
    }

    a:hover {
    color:#FFFFFF;
    text-transform: uppercase;
    text-decoration: none;
    text-shadow: 3px 1px 3px #000000;
    }

    a:link:focus, a:link:hover{
    font-size: 10px;
    text-shadow: -1px 1px 10px #EDE0B9, 1px -1px 10px #C4A958;
    }

    a:link:hover {
    text-shadow: 0 0 0.7em #8B0000;
    }

    a:link {
    text-decoration: none;
    color: #32FA00;
    text-shadow: none;
    -webkit-transition: 500ms linear 0s;
    -moz-transition: 500ms linear 0s;
    -o-transition: 500ms linear 0s;
    transition: 500ms linear 0s;
    outline: 1 ;
    }

    a:link:hover, a:link:focus{
    color: #000000;
    text-shadow: -1px 1px 8px #FFFFFF, 1px -1px 8px #FFFFFF;
    }

    /*--hover-glitzer-beginn-*/
    a:hover {
    position: relative;
    top: 2.0px; LEFT: 2.0px;
    }
    a:hover {
    background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif);
    }
    /*--hover-glitzer-end--*/
Du solltest dann nach dem absenden auch keine Fehlermeldung mehr erhalten.
Auch sollten dann alle weiteren Codes eingesetzt werden und ihre Wirkung zeigen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 20:34

Alle funktioniert optimal!
Hab in ein paar Threads hier und im HelpLexikon gestöbert und schon einen wunderschönen MouseOver Effekt gefunden.Das CSS-Stylesheet läuft jetzt übrigens sauber und wie geschmiert Very Happy
DANKE! :*
Thema erledigt
avatar
Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten