Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Mi 28 Sep 2016 - 13:34

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

[phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 11:39

Ich warneulich im LexiHelp und suchte dort'M' ich fand auch dieKategorie die ich suche...Da war ein MouseOverEffekt-Code=ich habe ihn prepariert usw. Leider funktionierte er in meinem Forum nicht.Muss man ihn wirklich in AB>Anzeige>Farben>CSS Stylesheet?Wie prepariere ich den Code,damit er auch funktioniert? Very Happy
Code:
/*--hover-glitzer-beginn-*/
a:hover {
            POSITION: relative;  
            TOP: -1.0px; LEFT: 1.0px;}
a:hover {
            background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
            }
/*--hover-glitzer-end--*/

^
|
Code


Zuletzt von Silber am Do 1 Jan 2015 - 21:02 bearbeitet, insgesamt 2 mal bearbeitet

Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 11:43

Vergleich mal diesen Code hier aus der Beschreibung:
Code:
   /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Mit deinem Code:
Code:
   /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: -1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
                }
    /*--hover-glitzer-end--*/
Fällt dir irgendwas auf in der Zeile wo du dein Bild eingesetzt hast?

Ich habe mir gerade mal dein CSS angesehen. Dort scheint es einige Fehler zu geben und deshalb ist das wohl ungültig und wird somit nicht angewandt.
Bitte poste mal den gesamten Inhalt des Eingabefensters unter:
AB>Anzeige>Farben>CSS Stylesheet
hier in einer Code Box:
Code:
[code][/code]
Wir sollten uns das mal ansehen, damit wir da die Fehler raus bekommen.
So wie es aussieht, hast du einiges an Tipps hier aus dem Forum eingesetzt, aber die Codes immer falsch eingesetzt.
Ich denke das bei dir einige Zeichen fehlen und du eigentlich beim Absenden deiner Codes eine Fehlermeldung erhalten solltest.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 13:45

Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Stimmt,da kommt immer 'ne fehlermeldung ...

Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 14:01

@Silber schrieb:Stimmt,da kommt immer 'ne fehlermeldung ...

Siehst du, und genau deshalb solltest du mal den gesamten Inhalt des CSS Fensters hier posten.

Edit:

Du hast jetzt ja wieder das orginale CSS aus der beschreibung eingesetzt.
Du wolltest aber ein eigenes Bild einsetzen.
Schau dir das noch mal an:
Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/
Mit deinem Code:
Code:
  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: -1.0px; LEFT: 1.0px;}
    a:hover {
                background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;
                }
    /*--hover-glitzer-end--*/

Der Fehler den ich meinte ist in dieser Zeile:

background-image:url=http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif;

Richtig wäre:

background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif);

Siehst du den Unterschied? Du hast ein = Zeichen eingesetzt und die Klammern vergessen. Darum klappt das mit deiner Grafik auch nicht.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 14:17

Irgendwie verstehe ich dat nicht.Der Code klappt aber gehen auch andere Codes?Ich meine z.B.; Das Schatten hervortritt statt diesem Glitzer?

Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 14:25

Und du verstehst mich nicht:
...und genau deshalb solltest du mal den gesamten Inhalt des CSS Fensters hier posten.
es befinden sich fehler in deinen Codes und die möchte ich hier mal sehen um dir diese zu korrigieren.
Deshalb funktionieren einige Sachen nicht, die du eingesetzt hast.
Hast du mich jetzt verstanden?



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 15:30

Code:
}
{
background: none repeat scroll 0 0 transparent;
}

 
[href="/g1-Admins"]{
text-shadow: #FFFF00 0 0 6px;
}


a:hover {
color:#FFFFFF;
;
text-transform: uppercase;
text-decoration: none;
text-shadow: 3px 1px 3px #000000;}

a:link:focus, a:link:hover
{font-size: 10px;
    text-shadow: -1px 1px 10px #EDE0B9, 1px -1px 10px #C4A958;}
text-shadow: 3px 1px 3px #000000;

a:link:hover {
text-shadow: 0 0 0.7em #8B0000;
}


a:link {
    text-decoration: none;
    color: #32FA00;
    text-shadow: none;
    -webkit-transition: 500ms linear 0s;
    -moz-transition: 500ms linear 0s;
    -o-transition: 500ms linear 0s;
    transition: 500ms linear 0s;
    outline: 1 ;
}

a:link:hover, a:link:focus
{
    color: #000000;
    text-shadow: -1px 1px 8px #FFFFFF, 1px -1px 8px #FFFFFF;
}

/  /*--hover-glitzer-beginn-*/
    a:hover {
                POSITION: relative;
                TOP: 2.0px; LEFT: 2.0px;}
    a:hover {
                background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/stern110.gif);
                }
    /*--hover-glitzer-end--*/

So? ^^

Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von #Frank am Do 1 Jan 2015 - 18:06

Ich habe dir nun mal die Fehler dort raus gemacht.
Bitte entferne alles aus dem CSS Fenster und setze das hier dafür ein:
Code:
   {
    background: none repeat scroll 0 0 transparent;
    }
    
    [href="/g1-Admins"]{
    text-shadow: #FFFF00 0 0 6px;
    }

    a:hover {
    color:#FFFFFF;
    text-transform: uppercase;
    text-decoration: none;
    text-shadow: 3px 1px 3px #000000;
    }

    a:link:focus, a:link:hover{
    font-size: 10px;
    text-shadow: -1px 1px 10px #EDE0B9, 1px -1px 10px #C4A958;
    }

    a:link:hover {
    text-shadow: 0 0 0.7em #8B0000;
    }

    a:link {
    text-decoration: none;
    color: #32FA00;
    text-shadow: none;
    -webkit-transition: 500ms linear 0s;
    -moz-transition: 500ms linear 0s;
    -o-transition: 500ms linear 0s;
    transition: 500ms linear 0s;
    outline: 1 ;
    }

    a:link:hover, a:link:focus{
    color: #000000;
    text-shadow: -1px 1px 8px #FFFFFF, 1px -1px 8px #FFFFFF;
    }

    /*--hover-glitzer-beginn-*/
    a:hover {
    position: relative;
    top: 2.0px; LEFT: 2.0px;
    }
    a:hover {
    background-image:url(http://i69.servimg.com/u/f69/11/49/29/60/196_st10.gif);
    }
    /*--hover-glitzer-end--*/
Du solltest dann nach dem absenden auch keine Fehlermeldung mehr erhalten.
Auch sollten dann alle weiteren Codes eingesetzt werden und ihre Wirkung zeigen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] [phpBB3] Mouseover Efffekt funktioniert nicht..

Beitrag von Silber am Do 1 Jan 2015 - 20:34

Alle funktioniert optimal!
Hab in ein paar Threads hier und im HelpLexikon gestöbert und schon einen wunderschönen MouseOver Effekt gefunden.Das CSS-Stylesheet läuft jetzt übrigens sauber und wie geschmiert Very Happy
DANKE! :*
Thema erledigt

Silber
Neuling
Neuling

Weiblich Beiträge : 17
Anmeldedatum : 01.01.15

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten