Lexi Help
Die neuesten Themen
» Impressum
von #Frank Gestern um 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Gestern um 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Gestern um 22:07

» Themen-Icons
von Bigtuber Gestern um 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Gestern um 20:09

» Themen fixieren
von inde Gestern um 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Gestern um 13:34

» Mein altes Forum zurückbekommen
von Bigtuber Di 27 Sep 2016 - 19:18

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

[phpBB3] Code funktioniert nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB3] Code funktioniert nicht

Beitrag von Jyrki75 am Fr 31 Okt 2014 - 8:49

Hallo ihr Lieben,

Vielleicht stelle ich mich jetzt auch nur tooootal dämlich an, aber ich hab auch nicht allzuviel Ahnung von Javascripts.

Ich wollte den folgenden Code in unserem Forum einbauen und hab ihn bei den Templates in die index-Body gesetzt. Allerdings kann ich nun leider kein Monster, welches eigentlich von oben nach unten fallen sollte sehen. Kann mir vielleicht jemand sagen, was ich falsch mache?

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Happy Halloween</title>
<script type="text/javascript">
function monsterbewegen(y,speed) {
var monster=document.getElementById("monster");
if (monster) {
var wo= parseInt(monster.style.top);
if (wo > 400) {
y = -15;
speed = 200;
}
else if (wo < -2000) return;
wo += y;
monster.style.top=wo+"px";
window.setTimeout("monsterbewegen("+y+","+speed+")", speed);
}}

window.onload=function() {
monsterbewegen(200,10);
}
</script>
</head>
<body>

<h1>Happy Halloween</h1>
<img src="bild1.jpg" alt="Monster" style="position:absolute;top:-2000px;left:100px; z-index:20" id="monster">
<p>gruselige Grüße</p>
</body>
</html>



Das ganze hab ich übrigens in unserem Testforum www.testblack.forumieren.com probiert.


Zuletzt von Jyrki75 am Fr 31 Okt 2014 - 9:39 bearbeitet, insgesamt 1 mal bearbeitet

Jyrki75
Neuling
Neuling

Beiträge : 50
Anmeldedatum : 20.03.13

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von #Frank am Fr 31 Okt 2014 - 9:04

Hast du den gesammten Code in das Template eingesetzt?
Dieser Code ist der für eine komplette HTML Seite.
Du must nur das Script selber und den img Tag einsetzen.
Am besten setzt du es dir ersteinmal in ein Indexmodul ein.
So kannst du es erstmal testen, ohne es immer im Template suchen zu müssen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von Jyrki75 am Fr 31 Okt 2014 - 9:10

Hmmmmmmm.... nu bin ich dann schon überfordert. Woran erkenne ich denn das eigentliche Script? Ich hab den Code nun in ein Index-Modul eingesetzt, aber das sehe ich dieses bescheuerte Monster auch nicht. Ich denke, ich sollte mich vielleicht noch ein bißchen mehr mit Codes beschäftigen, bevor ich so nen Kram versuche. *sfz*

Jyrki75
Neuling
Neuling

Beiträge : 50
Anmeldedatum : 20.03.13

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von #Frank am Fr 31 Okt 2014 - 9:16

Setz das ganze mal auf einer Html Seite ein und schau dir diese dann mal an.
Dort sollte es Funktionieren.

Das Script ist alles zwischen:
<script....

Und

</script>


Du musst dann nur noch das Bild irgentwo auf der Seite einsetzen.
Das Bild ist das hier:
<img src="bild1.jpg" alt="Monster" style="position:absolute;top:-2000px;left:100px; z-index:20" id="monster">
Wobei du bild1.jpg durch dein Bild ersetzen must.

Und ich denke auch, das du dich einwenig mit der Materie befassen solltest, wenn du solche Sachen einsetzen willst.

Edit: Ich habe mal auf dein Testforum gesehen, es schwebt dort schon etwas rum, allerdings hast du keine Grafik eingesetzt.
Deshalb siehst du dort auch nichts.
Das ganze schwebt etwas rechs vom linken Bildrand eimal von unten nach oben beim neuladen der Seite.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von Jyrki75 am Fr 31 Okt 2014 - 9:39

Danke für deine Hilfsversuche lieber Frank, aber ich glaube ich gebe mich der Technik geschlagen. Trotzdem danke für deine schnelle Meldung. *küsscheeeeeeeen*

Jyrki75
Neuling
Neuling

Beiträge : 50
Anmeldedatum : 20.03.13

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von #Frank am Fr 31 Okt 2014 - 9:42

Pass auf, das es Funktioniert, kannst du jetzt hier bei uns im Forum sehen.

Ich zeige dir jetzt, das ist nur eine Ausnahme, was du machen musst. Dauert einen Moment.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von #Frank am Fr 31 Okt 2014 - 9:57

So, nun kommen wir zur Umsetzung:

Als erstes Erstellst du dir ein persönliches Index Modul nach dieser Vorgabe:


Der Inhalt des Moduls ist dieser (Achtung: Code Modus bei der Eingabe wählen!):
Code:
<script type="text/javascript">
function monsterbewegen(y,speed) {
var monster=document.getElementById("monster");
if (monster) {
var wo= parseInt(monster.style.top);
if (wo > 400) {
y = -15;
speed = 200;
}
else if (wo < -2000) return;
wo += y;
monster.style.top=wo+"px";
window.setTimeout("monsterbewegen("+y+","+speed+")", speed);
}}

window.onload=function() {
monsterbewegen(200,10);
}
</script>
<img src="http://i39.servimg.com/u/f39/18/89/36/37/geiste10.png" alt="Monster" style="position: absolute; top: -2000px; left: 100px; z-index: 20; width: 100px; height: 100px;" id="monster" />

Das einzige was du machen musst, ist das du ein endsprechendes Bild (am Besten ein Transparentes PNG Bild) einsetzt:
<img src="http://i39.servimg.com/u/f39/18/89/36/37/geiste10.png" alt="Monster" style="position: absolute; top: -2000px; left: 100px; z-index: 20; width: 100px; height: 100px;" id="monster" />
Das Hellblaue: Die Adresse deines Bildes
Das Dunkelblaue: Die Breite des Bildes
Das Grüne: Die Höhe des Bildes

Dieses Modul stellst du dann ganz unten in deiner Modulspalte rein, so wie du es schon mit deinem anderen Modul gemacht hast, das du entfernst.

Was ich aber gerade feststelle ist, das dieses Script die CPU des Rechners stark belastet.
Du musst testen, wie sich das bei dir auswirkt.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von Jyrki75 am Fr 31 Okt 2014 - 10:10

Juchuuuuuuuu.... es geht wirklich!!! Vielen. vielen Dank Frank!!! Du bist der Beste. *umplüsch*

Jyrki75
Neuling
Neuling

Beiträge : 50
Anmeldedatum : 20.03.13

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB3] Code funktioniert nicht

Beitrag von #Frank am Fr 31 Okt 2014 - 10:15

Gut, aber das war wirklich eine Ausnahme.

Aber du hast das Bild nun sehr groß eingesetzt. Das würde ich nicht machen, da es doch sehr stört, und auch nicht gerade gut aussieht.
Wenn du das Script etwas verstehen würdest, könntest du auch noch weitere Einstellungen dort vornehmen, wie z.B. die Schritte, die sich das Bild bewegt oder auch die Position an welcher das durchläuft.

Aber ich denke das du damit arbeiten kannst und deshalb schließe ich hier nun.

Thema erledigt und closed



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten