Lexi Help
Die neuesten Themen
» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Heute um 20:56

» Begriff : "merken"
von inde Heute um 19:31

» Private Nachrichten
von inde Heute um 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde Gestern um 22:24

» Ad Ware im Forum?
von inde Gestern um 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank Gestern um 16:57

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

Partner
free forum

[phpBB2] Staff-Online-Modul funkt nicht im Portal

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von weimaranerfreundin am Mo 29 Sep 2014 - 18:34

Hallo liebes Team,

Ich beziehe mich auf mein damaliges Problem: http://hilfe.forumieren.com/t36851-phpbb2staff-online-anzeigemodul-hilfe-bei-script?highlight=staff

Bin gerade dabei alle Module aus dem Forum (Index) zu entfernen und ins Portal zu verschieben.
Nun habe ich die 3 Module, die für die Anzeige des Staff-Online nötig sind im portal arrangiert und jetzt funktionieren sie im Portal nicht  Sad
1. Modul - (unsichtbar) "wer ist online?"
2. Modul - nur für Gäste sichtbar - "Gäste-Staff online"
3. Modul - für alle anderen ausser Gäste sichtbar - "Staff online"

Zuerst hab ich gedacht es liegt daran, dass ich diese Module nun sowohl im Portal als auch im Index habe - und habe diese 3 Module komplett aus dem Forum (Index) entfernt. aber auch dies führte zu keiner Wirkung Sad

Ist vielleicht im Script irgendwo verankert, dass die Module nur im Index funktionieren?

LG Susanne


Zuletzt von weimaranerfreundin am Mi 1 Okt 2014 - 8:52 bearbeitet, insgesamt 1 mal bearbeitet

weimaranerfreundin
Stammgast
Stammgast

Weiblich Beiträge : 284
Hinweis : Hauptforum: www.weimaranerforum.eu
Anmeldedatum : 16.02.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von #Frank am Mo 29 Sep 2014 - 19:21

Ja, es liegt daran, das das Script unten die Informationen in diesem Teil ausliest:
#left .forumline:eq(0) .row1 a
Im Index ist das ja auch richtig, weil dein Modul im Bereich Left gestanden hat und das Modul die Class forumline row1 hatte.
Im Portal ist das aber nicht so und du musst im Script die Classen entsprechend der Position anpassen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von weimaranerfreundin am Di 30 Sep 2014 - 7:09

Hallo Frank,

Danke Dir für den Tipp Smile

Könntest Du mir bitte mit dem Code für die Position im Portal behilflich sein - Bitte?

LG Susanne

weimaranerfreundin
Stammgast
Stammgast

Weiblich Beiträge : 284
Hinweis : Hauptforum: www.weimaranerforum.eu
Anmeldedatum : 16.02.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von #Frank am Di 30 Sep 2014 - 15:08

Tut mir echt leid, aber ich habe zur Zeit keinen Rechner.
So kann ich dir die nötigen Änderungen leider nicht geben.
Eventuell schaut sich Günther das ja später mal an.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von Günther am Mi 1 Okt 2014 - 0:20

Hallo,
#Frank schrieb:Eventuell schaut sich Günther das ja später mal an.
Gerne. Smile

Wie Frank bereits gesagt hat, musst du diesen Teil anpassen:
jQuery(document).ready (function () {
jQuery('#left .forumline:eq(0) .row1 a').each(function () {
jQuery('#onlinestaff a[href="' + this.href + '"]').css('display','block');
});
});
#left wird ersetzt durch...
  • .column:first-child
    Arrow Module befinden sich in der linken Portalspalte
  • .column:last-child
    Arrow Module befinden sich in der rechten Portalspalte

Die Ordnungszahl .forumline:eq(0) wird folgendermaßen festgelegt:
Das wievielte Portalmodul in dieser Spalte mit der Klasse forumline ist das "Wer ist online?"-Modul? Das siehst du ganz schnell mit Firebug. Die Zählung beginnt bei 0 und nicht bei 1. Wink


Beispiel:
Das "Wer ist online?"-Modul befindet sich in der rechten Portalspalte und ist dort das 2. Modul, das die Klasse .forumline besitzt.
jQuery(document).ready (function () {
jQuery('.column:last-child .forumline:eq(1) .row1 a').each(function () {
jQuery('#onlinestaff a[href="' + this.href + '"]').css('display','block');
});
});
Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von weimaranerfreundin am Mi 1 Okt 2014 - 8:51

Vielen Dank Günther Smile
Das werde ich gleich probieren Smile Super!!!

Liebe Grüsse
Susanne


weimaranerfreundin
Stammgast
Stammgast

Weiblich Beiträge : 284
Hinweis : Hauptforum: www.weimaranerforum.eu
Anmeldedatum : 16.02.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Staff-Online-Modul funkt nicht im Portal

Beitrag von Günther am Mi 1 Okt 2014 - 12:46

Gerne. Smile
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten