Lexi Help
Die neuesten Themen
» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von Bobaustria Heute um 2:46

» Servamp Forum
von Raine Kamiya Gestern um 22:47

» Begriff : "merken"
von Ray Gestern um 21:34

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Gestern um 20:56

» Private Nachrichten
von inde Gestern um 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank So 25 Sep 2016 - 16:57

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

Partner
free forum

Chatbox Login funktioniert nicht mehr

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Chatbox Login funktioniert nicht mehr

Beitrag von Traiceheart am So 17 Aug 2014 - 15:29

Hallo,
ich melde mich wieder einmal mit einem Problem Smile

Ich wollte das meine Chatbox reinslided, somit habe ich diesen Code hier verwendet: http://hilfe.forumieren.com/t37170-phpbb2popup-chatbox-soll-nicht-rein-ploppen-sonder-fliesen

Leider ist danach jeder Chatbox Button verschwunden, somit ist auch kein Login Button vorhanden, weder im aufgeklapptem Chat noch im normalem unter der WIO. Hier ein Screenshot: http://abload.de/img/chatboxenl4zf7.png


Und hier, so sieht mein overall footer end aus:
Code:
<!-- BEGIN html_validation -->
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<body>
<table>
   <tr>
      <td>
         <div>
            <div>
               <div>
<!-- END html_validation -->
               </div>
            </div>
            <!-- BEGIN switch_footer_links -->
            <div align="center">
               <div class="gen">
                  <!-- BEGIN footer_link -->
                     <!-- BEGIN switch_separator -->&nbsp;|&nbsp;<!-- END switch_separator -->
                     <a name="bottom" class="copyright" href="{switch_footer_links.footer_link.U_FOOTER_LINK_HREF}" rel="{switch_footer_links.footer_link.FOOTER_LINK_REL}" target="{switch_footer_links.footer_link.FOOTER_LINK_TARGET}" title="{switch_footer_links.footer_link.L_FOOTER_LINK_TITLE}">{switch_footer_links.footer_link.L_FOOTER_LINK_TEXT}</a>
                  <!-- END footer_link -->
               </div>
            </div>
            <!-- END switch_footer_links -->
         </div>
         {PROTECT_FOOTER}
      </td>
   </tr>
</table>

<!-- BEGIN switch_facebook_login -->
<div id="fb-root"></div>
<script type="text/javascript">
//<![CDATA[
FB.init({appId: '{switch_facebook_login.FACEBOOK_APP_ID}', status: true, cookie: true, xfbml: true, oauth: true});
//]]>
</script>
<!-- END switch_facebook_login -->

<!-- BEGIN switch_facebook_logout_TMP -->
<script type="text/javascript">
//<![CDATA[
FB.Event.subscribe('auth.logout', function(response) {
   if ($('a#logout'))
   {
      var lien_redir = $('a#logout').attr('href');

      if ($('a#logout').attr('href') && $('a#logout').attr('href') != '')
      {
         document.location.href = 'http://{switch_facebook_logout.SERVER_NAME}/' + lien_redir;
      }
   }
});

$(document).ready( function() {
   $('a#logout').click( function() {
      FB.logout();
   } );
});
//]]>
</script>
<!-- END switch_facebook_logout_TMP -->

<script type="text/javascript">
//<![CDATA[
   fa_endpage();
//]]>
</script>
<script type="text/javascript">
if(my_getcookie('chatbx')&& my_getcookie('chatbx')=='1') {
jQuery('#popup_chatbox').css('margin-left', '-610px');
}
</script>
<TABLE id="popup_chatbox" style="Z-INDEX: 10000; POSITION: fixed; BOTTOM: 10px; LEFT: 0px">
<TBODY>
<TR>
<TD><IFRAME style="WIDTH: 600px; HEIGHT: 300px" src="/chatbox/index.forum?" frameBorder=0 scrolling=no></IFRAME></TD>
<TD style="VERTICAL-ALIGN: bottom"><img src="http://abload.de/img/chatbox2qeyht.png" onClick="my_setcookie('chatbx',(my_getcookie('chatbx')=='1'?'0':'1'),1,0);updateChatbx();"></TD></TR></TBODY></TABLE>
<script type="text/javascript">
function updateChatbx() {
if(my_getcookie('chatbx')&& my_getcookie('chatbx')=='1') {
jQuery('#popup_chatbox').css({'margin-left' : '-610px', transition : 'margin 2s ease-in-out 0s'});
}
else {
jQuery('#popup_chatbox').css({'margin-left' : '', transition : 'margin 2s ease-in-out 0s'});
}
};
updateChatbx();
</script>
</body>
</html>

Könnte es sein das ich irgendetwas bestimmtes entfernt habe oder falsch eingesetzt habe?

Lg


Zuletzt von Traiceheart am So 17 Aug 2014 - 17:27 bearbeitet, insgesamt 1 mal bearbeitet

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Chatbox Login funktioniert nicht mehr

Beitrag von Günther am So 17 Aug 2014 - 15:53

Hallo,

dein Problem hat gar nichts mit diesem Code zu tun, sondern kommt daher, dass du in dein Stylesheet folgenden CSS-Code eingesetzt hast:
Code:
td.catBottom {
  display: none;
}
Die Kopfzeile der Chatbox (mit Login-Button & Co) besitzt die Klasse catBottom und wird deshalb nicht angezeigt.

Man kann sich in deinem Forum sogar nicht einmal mehr registrieren, weil der Absenden-Button auch in einer catBottom-Zelle liegt:


In Zukunft solltest du deine CSS-Codes in der Praxis testen, bevor du sie einsetzt - vor allem bei so allgemeinen Zuweisungen wie zur Klasse catBottom, die an unzähligen verschiedenen Stellen im Forum vorkommt... Wink

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Chatbox Login funktioniert nicht mehr

Beitrag von Traiceheart am So 17 Aug 2014 - 17:27

Oh, wann hab ich den denn da eingefügt  scratch 
Ich habe glaub ich mal etwas rumgespielt und vergessen ihn wieder rauszunehmen. Mein Fehler.
Danke dir für den Hinweis  Freunde 

Schönen Tag noch ^^
Lg, Traice

Traiceheart
Stammgast
Stammgast

Weiblich Beiträge : 337
Anmeldedatum : 30.04.12
Chrome

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten