Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind, loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Forenaustausch

Alle Anzeigen ansehen

Regeln und nützliche Hinweise
Lexi Help
Lexi Help
Schnelle
Hilfe
Klicke Hier
Die neuesten Themen
» [phpBB2] Funktion 'Module einklappen', Bild erscheint nicht
von Keks Di 21 Nov 2017 - 18:57

» Bildlöschungen von servimg!
von Blocksberg Di 21 Nov 2017 - 16:51

» Style löschen
von Bigtuber Di 21 Nov 2017 - 1:37

» [phpBB2] Moderatorenanzeige Reihenfolge ändern!
von Keks Mo 20 Nov 2017 - 13:18

» "oder"-Feld beim Login-Bildschirm
von Keks Mo 20 Nov 2017 - 0:24

» [Mitteilung] Abschied als Administrator im Forumieren-Support [inde]
von Geli Sa 18 Nov 2017 - 14:50

» [phpBB2] Komplettes Style durcheinander.. (CSS)
von Bigtuber Do 16 Nov 2017 - 13:23

» Https weg
von Fisch Di 14 Nov 2017 - 15:08

» Ansicht auf Avatar umstellen - Canesboard
von Keks Mo 13 Nov 2017 - 18:24

» Vernetzung mit dubiosen Seiten
von Ray Sa 11 Nov 2017 - 18:05

» [PunBB] Forentitel in Fettschrift bei Chrome
von Bigtuber Sa 11 Nov 2017 - 15:26

» [phpBB2] HTML Code zur Passworteingabe true/false hinzufügen
von Professor Sa 11 Nov 2017 - 12:07

» [phpBB2] Titel des Forens in die Mitte schieben?
von Keks Mi 8 Nov 2017 - 17:03

» Domainname ändern und nicht verlängern
von goldhauch Mi 8 Nov 2017 - 9:43

» Moderatoren in Foren ausblenden
von Keks Di 7 Nov 2017 - 14:00

» Bitte um Übernahme des Gründeraccounts
von Carpe_Diem1985 Mo 6 Nov 2017 - 21:11

www.forumieren.de

[PunBB] Präfix-Code ändert sich von selbst?

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von Ghostwriter am Mo 11 Aug 2014 - 3:51

Sorry,

dass ich schon wieder nerve  pale 

Ich wollte, diese Präfix Funktion machen und ich gebe zu, ich kenne mich mit sowas nicht aus und selbstverständlich ging es schief.

Ich habe gegoogelt und gegoogelt und keine Lösung gefunden, weil mir aufgefallen ist, dass bei mir irgendwas offenbar nicht stimmt.

Wenn ich den Originalen Code von Zuckerpuppe:
Code:
function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_editor_textarea').before('<select name=tags4 onchange=tagprefixo()><option value="">(ohne Präfix)</option><option value=[Bewerbung]>Bewerbung</option><option value=[Test]>Test</option><option value=[Tutorial]>Tutorial</option><option value=[Video]>Vídeo</option></select>&nbsp<img src=http://illiweb.com/fa/wysiwyg/separator.png style=vertical-align:middle>&nbsp')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}});

Eingebe und ihn völlig unverändert einfach nur abspeicher, kommt folgendes raus:
Code:
function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_editor_textarea').before('(ohne Präfix)BewerbungTestTutorialVídeo  ')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}});

Ich nehme wirklich keine Veränderung vor.
Ich kopiere den Code -> Füge ihn ein -> Klicke auf "Annehmen" -> Und dann kommt der 2. Code raus. Ich weiß echt nicht, was ich falsch machen kann, wenn ich nicht mal was verändere  Shocked 


Zusätzlich: Um ein doppelpost zu vermeiden, stell ich meine 2. Frage gleich hier mit, da sie zusammen gehören.

Jedes meiner Präfix(e?) soll mit ">"enden, wie muss ich das in den Code eingeben, ohne dass er dadurch ruiniert wird?
zB:
S>
B>
T>
Bio 2>
Bio 4>
Juperos>
usw.

Mit freundlichen Grüßen
Ghostwriter
avatar
Ghostwriter
Neuling
Neuling

Beiträge : 19
Anmeldedatum : 24.07.14
keine
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von Mike am Mo 11 Aug 2014 - 8:00

Hallo,
also wenn du sagst das diese 2 Codes gleich sind solltest du sie wirklich mal genau ansehen, denn es sind 2 verschiedene Codes!

Wenn du den Original OHNE Änderungen eingibst funktioniert es dann?

LG Mike
avatar
Mike
Kaiser
Kaiser

Männlich Beiträge : 1230
Anmeldedatum : 11.07.10
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von #Frank am Mo 11 Aug 2014 - 8:26

Zum ersten:
Setzt du das Script auch wirklich in der Javascript Verwaltung ein?
Du schreibst:
Ich kopiere den Code -> Füge ihn ein -> Klicke auf "Annehmen"
Das kann schon nocht sein, weil es dort kein Annehmen gibt. Dort heißt es Bestätigen.
Deshalb gehe ich davon aus, das du es im falschen Bereich einfügst.

Noch als Tip:
Kopiere dir das Script erst in ein TXT Dokument auf deinem Rechner (Editor auf deinem Rechner, nicht Word oder andere Textprogramme).
Dort nimmst du deine Änderungen vor. Das Ergebnis setzt du dann in deinen AB ein.

Zur Frage der > Zeichen:
Du kannst dieses Zeichen nicht direkt einsetzen, weil diese Steuerzechen sind.
Wenn du solche Zeichen innerhalb von Scripten einsetzen wilst, musst du die HTML Zeichen dafür benutzen.
Eine Aufstellung findest du hier:
http://de.selfhtml.org/html/referenz/zeichen.htm
Deine Klammer hat den Code:
Code:
&gt;
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34605
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von Ghostwriter am Mo 11 Aug 2014 - 13:00

@Mike schrieb:Hallo,
also wenn du sagst das diese 2 Codes gleich sind solltest du sie wirklich mal genau ansehen, denn es sind 2 verschiedene Codes!

Wenn du den Original OHNE Änderungen eingibst funktioniert es dann?

LG Mike

Nein ich habe mit keiner Silbe erwähnt das sie gleich sind, sondern hab ich geschrieben:
"Eingebe und ihn völlig unverändert einfach nur abspeicher, kommt folgendes raus:"
Damit wollt ich ausdrücken, das ich nichts mache, außer speichern und der Code sich von selbst ändert.

#Frank schrieb:Zum ersten:
Setzt du das Script auch wirklich in der Javascript Verwaltung ein?
Du schreibst:
Ich kopiere den Code -> Füge ihn ein -> Klicke auf "Annehmen"
Das kann schon nocht sein, weil es dort kein Annehmen gibt. Dort heißt es Bestätigen.
Deshalb gehe ich davon aus, das du es im falschen Bereich einfügst.

Bei mir steht Annehmen:


#Frank schrieb:Noch als Tip:
Kopiere dir das Script erst in ein TXT Dokument auf deinem Rechner (Editor auf deinem Rechner, nicht Word oder andere Textprogramme).
Dort nimmst du deine Änderungen vor. Das Ergebnis setzt du dann in deinen AB ein.

Hab ich auch probiert, dennoch ändert sich der Code von selbst, sobald ich auf "Annehmen" drücke.

#Frank schrieb:Zur Frage der > Zeichen:
Du kannst dieses Zeichen nicht direkt einsetzen, weil diese Steuerzechen sind.
Wenn du solche Zeichen innerhalb von Scripten einsetzen wilst, musst du die HTML Zeichen dafür benutzen.
Eine Aufstellung findest du hier:
http://de.selfhtml.org/html/referenz/zeichen.htm
Deine Klammer hat den Code:

Das hatte ich auch ergoogelt, weil beim ersten mal hab ich einfach ">" eingesetzt und dachte, dass sei der Grund dafür,
dass sich der Code ändert, dann hatte ich das mit dem html ausprobiert und es passierte das gleiche.
Dann hab ich ihn Code unverändert gespeichert, um zu testen, ob es überhaupt funktioniert und dabei fiel mir auf, dass sich der Code einfach so verändert nach dem speichern.  Sad 

Mit freundlichen Grüßen
Ghostwriter

P.S.: Liegt es daran, dass ich PunBB habe?
avatar
Ghostwriter
Neuling
Neuling

Beiträge : 19
Anmeldedatum : 24.07.14
keine
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von Ghostwriter am Mo 11 Aug 2014 - 13:31

Ooooooooke habs offensichtlich in den falschen Bereich eingefügt, ich werd's jetzt mal in den richtigen einfügen und hier via Edit sagen, ob's funktioniert hat. Sorry!

Edit: Alles klar, jetzt funktioniert es... Habs einfach nur in den falschen Bereich gespeichert... Mein Fehler, tut mir leid!

Dann hab ich nur noch eine kleine Frage, dann ist das erledigt.

Ich würde gerne den Präfix vom Thementitel unterscheiden können, Beides ist ja Bold(Fett), kann man das nicht so einstellen, dass der Präfix nicht Bold geschrieben wird, sondern normal, um eine optische Differenz zwischen Präfix und Titel zu erstellen?

Mit freundlichen Grüßen
Ghostwriter
avatar
Ghostwriter
Neuling
Neuling

Beiträge : 19
Anmeldedatum : 24.07.14
keine
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [PunBB] Präfix-Code ändert sich von selbst?

Beitrag von #Frank am Mo 11 Aug 2014 - 17:08

Nein, da das Präfix ja zum Thementitel gehört, und der nun mal in einer Zeile steht, ist das nicht möglich.

Wenn nun alles funktioniert, schließe ich hier nun.

closed
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34605
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten