Lexi Help
Die neuesten Themen
» Impressum
von #Frank Gestern um 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Gestern um 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Gestern um 22:07

» Themen-Icons
von Bigtuber Gestern um 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Gestern um 20:09

» Themen fixieren
von inde Gestern um 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Gestern um 13:34

» Mein altes Forum zurückbekommen
von Bigtuber Di 27 Sep 2016 - 19:18

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

[phpBB2] Präfixe werden bei mir nicht als solche angezeigt

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Präfixe werden bei mir nicht als solche angezeigt

Beitrag von BVB134 am Do 19 Jun 2014 - 1:11

Nun habe ich das nächste Problem: Die Präfixe sind auswählbar, aber wenn ich einen auswähle, steht dann vor dem Titel: undefinied. Ich habe das unter die anderen Codes gesetzt: <option value=[WWM]>WWM</option>
Ich habe es mit jedem dieser Präfixe versucht, aber immer kommt dieses englische Wort. Was muss ich tun, damit auch bei mir die Präfixe so angezeigt werden, wie in diesem Forum. Da werden die ja auch angezeigt.

MfG
BVB134

BVB134
Lehrling
Lehrling

Männlich Beiträge : 166
Hinweis : Borusse
2.Ermahnung
Anmeldedatum : 26.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Präfixe werden bei mir nicht als solche angezeigt

Beitrag von Günther am Do 19 Jun 2014 - 2:22

Hallo,

hatte ich dir nicht vorhin gerade gesagt, dass du deine Scripte ständig mit eigenen Änderungen zerschießt, die nicht nötig wären und die du falsch machst?
Nochmals: Du übernimmst in Zukunft bitte jedes Script 1:1 aus den Tutorials und änderst ausschließlich das, was du laut Tutorial auch ändern sollst/kannst. Dann hast du auch keine Probleme dieser Art mehr.

Diesmal bist du anscheinend auf die Idee gekommen, einfach irgendwo im Script eine Zahl zu ändern. Zum Vergleich in Grün die Originalstelle und in Rot deine veränderte Stelle:
function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_editor_textarea').before('<select name=tags4 onchange=tagprefixo()><option value="">(ohne Präfix)</option><option value=[Bewerbung]>Bewerbung</option><option value=[Test]>Test</option><option value=[Tutorial]>Tutorial</option><option value=[Video]>Vídeo</option></select>&nbsp<img src=http://illiweb.com/fa/wysiwyg/separator.png style=vertical-align:middle>&nbsp')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}});
function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_editor_textarea').before('<select name=tags10 onchange=tagprefixo()><option value="">(ohne Präfix)</option><option value=[GESETZ!]>GESETZ!</option><option value=[Anleitung]>Anleitung</option><option value=[BVB]>BVB</option><option value=[1. Liga]>1. Liga</option><option value=[2. Liga]>2. Liga</option><option value=[3. Liga]>3. Liga</option><option value=[ŞÜPLIG]>ŞÜPLIG</option><option value=[WWM]>WWM</option><option value=[WWM ZOCK]>WWM ZOCK</option><option value=[QVGDM]>QVGDM</option><option value=[KMOI]>KMOI</option></select>&nbsp<img src=http://illiweb.com/fa/wysiwyg/separator.png style=vertical-align:middle>&nbsp')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}})
Ich kann mir schon denken, warum du auf diese Idee gekommen bist. Allerdings:
1. Wenn man das schon ändert, sollte man sich ausreichend mit Javascript auskennen, um zu sehen, dass diese Änderung auch noch an weiteren Stellen im Script fortgeführt werden muss. Genau deshalb funktioniert dein Script nämlich nicht mehr.
2. Hast du irgendwo im Tutorial gelesen, dass diese Änderung gemacht werden muss?
Nein... Wink Im Tuto wird beschrieben (und ich habe es dir nochmals gesagt), dass eine kleine Stelle pro zusätzlichem Präfix ergänzt werden kann - und das alles ist.
Du solltest dann auch genau und ausschließlich diese Änderung laut Tuto vornehmen und das Script ansonsten unberührt lassen.

Einen zweiten Hinweis habe ich noch für dich: Du darfst bei den values keine normalen Leerzeichen einsetzen:
<option value=[1. Liga]>1. Liga</option><option value=[2. Liga]>2. Liga</option><option value=[3. Liga]>3. Liga</option>
Das Script würde zwar trotzdem generell funktionieren, aber die betreffenden Präfixe würden nur bis zum Leerzeichen eingesetzt und nicht vollständig.
Die Leerzeichen müssen in den Werten entweder als Scriptausdruck gesetzt werden oder - was noch einfacher ist und ich dir empfehle - als geschütztes HTML-Leerzeichen:
http://wiki.selfhtml.org/wiki/SELFHTML:Beispiel-Dokumentationsseite#Gesch.C3.BCtzte_Leerzeichen
Beispiel:
<option value=[1.&nbsp;Liga]>1. Liga</option>
Dann werden die Präfixe vollständig und inkl. des gewünschten Leerzeichens vor den Thementitel gesetzt.

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Präfixe werden bei mir nicht als solche angezeigt

Beitrag von BVB134 am Do 19 Jun 2014 - 5:41

Ich habe diese eine Zahl wieder auf 4 umgestellt. Habe gedacht, dass dies eine Zahl wäre, mit der man angeben müsste, wie viele Präfixe man sich vergeben hat. Dann müsste ich ja jetzt genauso auch beim Wörter-/Zeichenzähler vorgehen. Den Code so ins Forum kopieren, und FALLS was geändert werden muss, auch nur das, was da im Tutorial steht. Kann ich denn mehrere solcher Codes ins Forum kopieren, oder wurde von forumieren eine Höchstgrenze von bspw. 10 Codes gesetzt, damit das Forum nicht von solchen Codes überladen wird? Weil ich wollte jetzt den Wörter-/Zeichenzähler in mein Forum integrieren. Ich versuch das mal und wenn es wieder klemmt, melde ich mich wieder.

BVB134
Lehrling
Lehrling

Männlich Beiträge : 166
Hinweis : Borusse
2.Ermahnung
Anmeldedatum : 26.01.14

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Präfixe werden bei mir nicht als solche angezeigt

Beitrag von Günther am Do 19 Jun 2014 - 12:20

@BVB134 schrieb:Ich habe diese eine Zahl wieder auf 4 umgestellt. Habe gedacht, dass dies eine Zahl wäre, mit der man angeben müsste, wie viele Präfixe man sich vergeben hat.
Ja, ich dachte mir, dass das dein Beweggrund dazu war.
Aber wie gesagt: Wenn im Tutorial nichts davon steht, dann musst und sollst du das auch nicht machen. Wink

Von Forumieren gibt es eine sehr hohe Obergrenze für Scripte, die im dreistelligen Bereich liegt. An diese Grenze wirst du also nie stoßen.
Allerdings gilt auch dafür, dass du dein Forum nicht mit Scripten überladen solltest. Jedes Script beansprucht Rechenleistung und Zeit, damit es bei deinen Usern ausgeführt wird. Lässt man in einem Forum zu viele Scripte ausführen, kann dadurch die Lade-/Aufbauzeit stark verlängert werden und bei usern mit leistungsschwachen Endgeräten kann es zu größeren Problemen kommen.
Also beschränke dich auf die wirklich nötigen und sinnvollen Scripte und übertreibe es bitte nicht. Wink

Wie du beim Zählerscript vorgehen solltest, hast du richtig verstanden. Und da hier die Eingangsfrage wieder geklärt ist und der Wörter-/Zeichenzähler ein ganz anderes Thema ist, schließe ich nun ab.
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten