Lexi Help
Partner
www.forumieren.com

z-index bei Navigation wird nicht übernommen

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt z-index bei Navigation wird nicht übernommen

Beitrag von Gast am Mo 9 Jun 2014 - 13:21

Hallo,
ich habe folgendes Problem:

Bei meiner Navigation , bei der der Wert opacity: 0.5; beträgt ist ein z-index von 990 eigestellt.
Bei mainmenu ist aber der z-index von 999 eingetragen...
Warum funktioniert das ganze nicht?

Die codes:

Navigationsleiste
Code:
#page-header .navbar {
  left: 0;
  position: fixed ;
  top: 0;
  width: 100%;
  z-index: 990;
  -webkit-box-shadow: 0 8px 6px -6px black;
  -moz-box-shadow: 0 8px 6px -6px black;
  box-shadow: 0 8px 6px -6px black;
  background-color: #4F1C12;
  opacity: 0.5;

}

mainmenu (Links)

Code:
.mainmenu {
  background-color: #ffffff;
 border-radius: 10px 0;
 font-size: 12px;
 margin: 3px;
 padding: 4px;
  z-index: 999;
}

Gast
Gast


Nach oben Nach unten

Erledigt Re: z-index bei Navigation wird nicht übernommen

Beitrag von Günther am Mo 9 Jun 2014 - 13:33

Hallo,

Opacity wird immer auf die jeweiligen Kinderelemente vererbt und der z-index hat mit der Kaskade (Vererbung) überhaupt nichts zu tun. Folglich ändert dieser auch nichts daran, dass deine Navigation ihre Opacity an die Navilinks weitervererbt. Wink

Opacity sorgt dafür, dass das jeweilige Element inkl. aller seiner Kinderelemente die festgelegte Deckkraft erhält.

Du kannst aber anders vorgehen, wenn nur die Navigation teiltransparent sein soll und die Kinderelemente nicht. Dazu entfernst du die opacity aus deinem CSS-Code und gibst die background-color nicht als #Hexadezimalwert an, sondern als RGBA-Farbwert.
RGBA-Farbwerte setzen sich aus drei Farbangaben (Rot, Grün, Blau) und einer Angabe für die Deckkraft zusammen.
Dort kannst du z.B. Hexadezimalwerte zu RGBA-Werten umwandeln lassen:
http://hex2rgba.devoth.com/

Dein Farbwert #4F1C12 mit einer Opacity von 0.5 wird z.B. zu folgendem RGBA-Wert:
Code:
rgba(79, 28, 18, 0.5)
Die letzte Position 0.5 steht dabei für die Deckkraft.

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: z-index bei Navigation wird nicht übernommen

Beitrag von Gast am Mo 9 Jun 2014 - 14:05

Das ganze funktioniert nicht, sorry.

Habe es jetzt in verschiedenen Variationen probiert...

Gast
Gast


Nach oben Nach unten

Erledigt Re: z-index bei Navigation wird nicht übernommen

Beitrag von Günther am Mo 9 Jun 2014 - 14:17

@Günther schrieb:Dazu entfernst du die opacity aus deinem CSS-Code und gibst die background-color nicht als #Hexadezimalwert an, sondern als RGBA-Farbwert.
War dir das nicht klar?

Das wäre ganz einfach, ich zeige es dir mal an deinem Code. Das Rote kommt weg, das Grüne dazu...
#page-header .navbar {
left: 0;
position: fixed ;
top: 0;
width: 100%;
z-index: 990;
-webkit-box-shadow: 0 8px 6px -6px black;
-moz-box-shadow: 0 8px 6px -6px black;
box-shadow: 0 8px 6px -6px black;
background-color: rgba(79, 28, 18, 0.5);
opacity: 0.5;
}

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: z-index bei Navigation wird nicht übernommen

Beitrag von Gast am Mo 9 Jun 2014 - 14:21

Jetzt hat es geklappt!
Ich habe vorher background-color auch weggelöscht...
Desswegen ging es nicht...

Gast
Gast


Nach oben Nach unten

Erledigt Re: z-index bei Navigation wird nicht übernommen

Beitrag von Günther am Mo 9 Jun 2014 - 14:25

Das ist klar. Smile
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten