Lexi Help
Partner
www.forumieren.com

[phpBB2] Forenindex in Chrome verzerrt, falsche Größe der Spalten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Forenindex in Chrome verzerrt, falsche Größe der Spalten

Beitrag von Tierfreund-97 am Do 13 Feb 2014 - 18:31

Hallo!

In meinem neuen (Test)Forum www.insomnia.my-rpg.com habe ich das Template index_box bearbeitet; die einzelnen Spalten haben entsprechende Angaben, wie breit sie sein sollen:

Code:
<td width="50px" class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
        <div style="width:50px;"><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></div>
      </td>

Code:
<td class="row3" align="center" valign="middle" height="50" width="100px">
         <div style="width:100px;"><span class="gensmall">Threads: {catrow.forumrow.TOPICS}
           <br/>Posts: {catrow.forumrow.POSTS}</span></div>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50" width="150">
        <div style="width:150px;"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></div>
      </td>

Bei Firefox sieht auch alles so aus, wie es sein soll:


Allerdings scheinen die Größenangaben bei Chrome keinerlei Auswirkungen zu haben:


Kann mir jemand helfen?

Liebe Grüße,
Tierfreund-97


Zuletzt von Tierfreund-97 am Fr 14 Feb 2014 - 14:12 bearbeitet, insgesamt 1 mal bearbeitet

Tierfreund-97
Lehrling
Lehrling

Weiblich Beiträge : 166
Hinweis : I LOVE THE SYSTEM
Anmeldedatum : 09.04.11
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Forenindex in Chrome verzerrt, falsche Größe der Spalten

Beitrag von #Frank am Do 13 Feb 2014 - 19:39

Du mußt bei deinen Weitenangaben die "Px" Einhet weglassen.
Diese sind nicht HTML konform.
Bei festen Werten ohne Einheiten ist es immer Pixel.
Bei variablen Elementen wird dann % angegeben.
Der Firefox interpretiert das nicht ganz so genau, wohin gegen der Crome hier sensibel reagiert.




Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Forenindex in Chrome verzerrt, falsche Größe der Spalten

Beitrag von Tierfreund-97 am Fr 14 Feb 2014 - 13:40

Danke für die Antwort!

Leider hat sich bei der Anzeige im Chrome nichts verändert. Ich habe festgestellt, dass das nur so ungleichmäßig ist, wenn ich ein Kategorienbild reinsetze. Es liegt nicht daran, dass der Papierkorb ein Forum und das andere eine Kategorie, auch ist es egal, ob es da Beiträge gibt oder nicht. Als ich den Kategoriebanner entfernte, wurde auch dieses Kategorie unter Chrome richtig angezeigt.


Ich hänge gleich mal das entsprechende Template ran. Wobei ich da sagen muss, dass das von mir selbst zurechtgebastelt wurden ist, könnte also gut sein, dass ich da was vermasselt hab.

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
 <tr>
          <td valign="bottom"><img src="{SPACER}" alt="" height="5" width="1" /><br/>
 <!-- BEGIN switch_user_logged_in -->
 <span class="gensmall">{LAST_VISIT_DATE}<br />
 {CURRENT_TIME}<br />
 </span>
 <!-- END switch_user_logged_in -->
 <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
                 <img src="{SPACER}" alt="" height="5" width="1" /></td>
          <td class="gensmall" align="right" valign="bottom"><img src="{SPACER}" alt="" height="5" width="1" /><br/>
 <!-- BEGIN switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
 <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
 <!-- END switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
                  <br/><img src="{SPACER}" alt="" height="5" width="1" /></td>
 </tr>
</table>

<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">

         </span>
         <!-- END switch_user_logged_in -->

      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->

         <!-- END switch_user_logged_in -->
         <a class="gensmall" href=""></a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow -->

<!-- BEGIN tablehead -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <th colspan="4" nowrap="nowrap" width="100%" class="secondarytitle">{catrow.tablehead.L_FORUM}</th></tr>
<!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td width="50" class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
        <div style="width:50px;"><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></div>
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="middle" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="forumdesc">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>
      <!-- BEGIN forum_link_no -->
      <td class="row3" align="center" valign="middle" height="50" width="100">
         <div style="width:100px;"><span class="gensmall">Threads: {catrow.forumrow.TOPICS}
           <br/>Posts: {catrow.forumrow.POSTS}</span></div>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50" width="150">
        <div style="width:150px;"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></div>
      </td>
      <!-- END forum_link_no -->
      <!-- BEGIN forum_link -->
      <td class="row3" colspan="3" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.forum_link.HIT_COUNT}</span></td>
      <!-- END forum_link -->
   </tr>
   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table>
<img src="{SPACER}" alt="" height="5" width="1" />
<!-- END tablefoot -->
<!-- END catrow -->

---
EDIT 14:10

Jetzt funktioniert auf einmal alles.  Suspect 
Ich verstehe es nicht. Naja, egal, das Thema wäre dann hiermit erledigt. ^^

Tierfreund-97
Lehrling
Lehrling

Weiblich Beiträge : 166
Hinweis : I LOVE THE SYSTEM
Anmeldedatum : 09.04.11
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten