Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Mi 28 Sep 2016 - 13:34

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

Grundsätzliches Problem bei einem Script

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Keine Rückmeldung closed Grundsätzliches Problem bei einem Script

Beitrag von jany am Do 9 Jan 2014 - 19:44

Guten Abend,

allen Leuten erstmal ein frohes neues Jahr! Ich bin momentan dabei mein Forum neu zu bauen und habe derzeit ein Grund-Problem. Das untere Bild verdeutlicht meine Frage dazu!
Ich baue momentan an einer Seitenleiste die ich versuche zu bauen. Die Leiste baue ich in dem Template overall_header (Forumkopfteil).

Nach einigen Versuchen musste ich jedoch feststellen, das alle Links und Texte die ich an die Seite platziere, zwar funktionieren... aber dadurch die komplette rechte Seite des Forums unantastbar ist. Mache ich beispielshalber einen Link auf höhe des Symbols (siehe Bild), kann ich das halbe Forum nicht mehr anklicken. Die Seite sitzt links auf der Seite.
Liegt es eventuell daran, das ich auf dem falschen Template arbeite?



jany
Premium-User
Premium-User

Männlich Beiträge : 428
Hinweis : EURO TRUCK SIMULATOR 2
2. Verwarnung
Anmeldedatum : 22.10.09

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von #Frank am Do 9 Jan 2014 - 20:08

Eigentlich gehört das Zwar nicht zu unseren Augaben, aber ich denke das du hier einen Fehler machst, indem du ein Element über einem Anderen platzierst, so das das darunter liegende durch einen unsichtbaren Inhalt deiner Leiste verdeckt wird.
Du müsstest hier mal den Link zu deiner Seite und auch den Code Posten, den du eingesetzt hast.
Aber eventuell kommst du auch selber dahinter was das Problem ist mit dem "Überlappen".
Ich denke das du mit einer Z-Index Angabe arbeitest.
Das solltest du Bedenken.

Edit: Zur Zeit sehe ich dieses Element in deinem Forum nicht. Du solltest das schon einsetzen, wenn du hier Hilfe erwartest.


Zuletzt von #Frank am Do 9 Jan 2014 - 20:12 bearbeitet, insgesamt 1 mal bearbeitet



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von jany am Do 9 Jan 2014 - 20:11

#Frank schrieb:Eigentlich gehört das Zwar nicht zu unseren Augaben, aber ich denke das du hier einen Fehler machst, indem du ein Element über einem Anderen platzierst, so das das darunter liegende durch einen unsichtbaren Inhalt deiner Leiste verdeckt wird.
Du müsstest hier mal den Link zu deiner Seite und auch den Code Posten, den du eingesetzt hast.
Aber eventuell kommst du auch selber dahinter was das Problem ist mit dem "Überlappen".
Ich denke das du mit einer Z-Index Angabe arbeitest.
Das solltest du Bedenken.

http://tivo.forumieren.com/forum

Richtig, ich arbeite mit den Z-Index. Aber auch ohne Z-Index passiert das  Neutral 

Code:
<span class="gensmall"style="; top: 85px; left: 80px; position: fixed ; font-size: 14px; z-index: 9; font-weight: bold; color:#fbf5e9; text-shadow:#000000 2px 2px; font-size: big; font-family:Verdana" >Willkommen</span> <span class="gensmall"style="; top: 55px; left: 20px; position: fixed ; font-size: 10px; z-index: 9; font-weight: Normal; color:#fbf5e9; text-shadow:#000000 2px 2px; font-size: big; font-family:Verdana" >{LOGGED_AS}</span>  
<img src="http://abload.de/img/sidebar3e9xae.png" title="" border="0" style="; top: 40px; left: 0px; position: fixed"><
  
<span class="gensmall"style="; top: 90px; left: 55px; position: fixed ; font-size: 10px; z-index:10; font-weight: Normal; color:#fbf5e9; text-shadow:#000000 2px 2px; font-size: big; font-family:Verdana" >{RANK_IMAGE}</span>  
          
  


EDIT: Mein css ist gerade auf einmal verschwunden Oo

jany
Premium-User
Premium-User

Männlich Beiträge : 428
Hinweis : EURO TRUCK SIMULATOR 2
2. Verwarnung
Anmeldedatum : 22.10.09

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von #Frank am Do 9 Jan 2014 - 20:21

Ja, genau wie ich es schon vermutet habe.
Du setzt hier Elemente vor das Forum. Diese Elemente haben keine Höhen und Breiten Angaben.
So passiert es, das Elemente die sich unter diesen befinden auch nicht mehr angeklickt werden können.
Du kannst deine Elemente mal mit der Maus markieren, dann siehst du, wie Weit die über anderen Elementen liegen.
Ist dir klar, das es auf deinem Bildschirm nicht nur die X und Y Positionen gibt? Z ist hier die Tiefe der Darstellungen. Je hoher der Z- Index ist um so weiter vorne sind die Elemente und die anderen liegen dahinter.
Du solltest deine Elemente in eine Tabelle packen die du dann auch in der Höhe und Breite genau anpassen musst.

Du kannst dir mal unsere Tutos ansehen und dort mal das "freistehend Modul" anschauen. Dort findest du eine Lösung die etwas besser ist, da diese nicht ganz so viel überdeckt.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von jany am Do 9 Jan 2014 - 20:42

#Frank schrieb:Ja, genau wie ich es schon vermutet habe.
Du setzt hier Elemente vor das Forum. Diese Elemente haben keine Höhen und Breiten Angaben.
So passiert es, das Elemente die sich unter diesen befinden auch nicht mehr angeklickt werden können.
Du kannst deine Elemente mal mit der Maus markieren, dann siehst du, wie Weit die über anderen Elementen liegen.
Ist dir klar, das es auf deinem Bildschirm nicht nur die X und Y Positionen gibt? Z ist hier die Tiefe der Darstellungen. Je hoher der Z- Index ist um so weiter vorne sind die Elemente und die anderen liegen dahinter.
Du solltest deine Elemente in eine Tabelle packen die du dann auch in der Höhe und Breite genau anpassen musst.

Du kannst dir mal unsere Tutos ansehen und dort mal das "freistehend Modul" anschauen. Dort findest du eine Lösung die etwas besser ist, da diese nicht ganz so viel überdeckt.

Jop, als gelernter Bauzeichner kann ich mit den Begriffen schon etwas anfangen. Kann ich denn die Größe der Ausbreitung auch via Code einfügen? Das funktioniert mit den freistenden Modulen ja viel besser als ich gedacht habe! Und vorallem, viel übersichtlicher wo ich welchen Code hatte... Wie siehts aus mit der Überdeckung? Kann ich anfangen jetzt zu Bauen ohne mir sorgen darüber zu machen? Was ist, wenn ich nun den Z-Index im freistehenden Index benutze?

jany
Premium-User
Premium-User

Männlich Beiträge : 428
Hinweis : EURO TRUCK SIMULATOR 2
2. Verwarnung
Anmeldedatum : 22.10.09

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von #Frank am Do 9 Jan 2014 - 20:56

Das mit dem Modul ist schon die bessere Lösung. Nur das dieses Modul auch das was sich darunter befindet überdecken kann, ist nicht zu verhindern.
Das ist nun mal so.
Und da ich davon ausgehe, das es von dir auch beabsichtigt ist, das diese Informationen immer oben am Bildrand sichtbar bleiben, wirst du das auch in Kauf nehmen müssen.
Es gibtvja auch noch die Möglichkeit sowas wie eine Zweite Menüleiste einzusetzen, so wie du es in meinem Forum unter 1 siehst.
Diese muss ja nicht zwangsläufig oben sein, sondern die kann auch an der Seite platziert werden und von oben nach unten verlaufen. Wenn die dann nur sehr Schmal gehalten wird mit entsprechenden Icons, dann stört die auch nicht so sehr.
Dazu findest du etwas wenn du nach Zweite Navigation suchst.
Das Vorgehen ist so ähnlich, wie du es schon versucht hast.
Das war ja grundsätzlich nicht falsch, nur musst du deine Inhalte in eine Schmale Tabelle setzen.
Ich hoffe du verstehst wie ich das meine.
Ist etwas blöd zu erklären.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von jany am Do 9 Jan 2014 - 21:31

#Frank schrieb:Das mit dem Modul ist schon die bessere Lösung. Nur das dieses Modul auch das was sich darunter befindet überdecken kann, ist nicht zu verhindern.
Das ist nun mal so.
Und da ich davon ausgehe, das es von dir auch beabsichtigt ist, das diese Informationen immer oben am Bildrand sichtbar bleiben, wirst du das auch in Kauf nehmen müssen.
Es gibtvja auch noch die Möglichkeit sowas wie eine Zweite Menüleiste einzusetzen, so wie du es in meinem Forum unter 1 siehst.
Diese muss ja nicht zwangsläufig oben sein, sondern die kann auch an der Seite platziert werden und von oben nach unten verlaufen. Wenn die dann nur sehr Schmal gehalten wird mit entsprechenden Icons, dann stört die auch nicht so sehr.
Dazu findest du etwas wenn du nach Zweite Navigation suchst.
Das Vorgehen ist so ähnlich, wie du es schon versucht hast.
Das war ja grundsätzlich nicht falsch, nur musst du deine Inhalte in eine Schmale Tabelle setzen.
Ich hoffe du verstehst wie ich das meine.
Ist etwas blöd zu erklären.

Ahh, das sieht ja klasse aus! Mhh... also die Menüleiste wird nicht direkt über bzw. unter etwas sein, der Foruminhalt wird immer Rechts neben dieser Leiste stehen bleiben. Das einzige was halt stimmen muss, das etwas in der gleichen höhe immernoch anklickbar ist, das ist wichtig. Also so wie du es mir erklärt hast, würde das so wie ich es nun beschrieben habe funktionieren?

Noch eine Frage zu den Modulen, jetzt funktioniert dort zwar die Leiste, allerdings wäre der einzige wunsch nun noch von mir, zwischen eingeloggt und ausgeloggt zu unterscheiden. Im Template konnte ich dazu

<!-- END switch_user_logged_in -->
<!-- END switch_user_logged_out -->

benutzen, das funktioniert jetzt leider im Modul nicht mehr  cyclops

So schauts in der Tabelle jetzt aus, eigentlich ganz simple?!


<div style="position: absolute; top: 40px; left: -3px; z-index: 10000; position: fixed">
     
    <table>
         
        <tbody>
            <tr>
                 
                <td>
                     <img src="http://abload.de/img/sidebar3e9xae.png" />
                </td>
                 
            </tr>
             
        </tbody>
    </table>
</div>
     

jany
Premium-User
Premium-User

Männlich Beiträge : 428
Hinweis : EURO TRUCK SIMULATOR 2
2. Verwarnung
Anmeldedatum : 22.10.09

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von #Frank am Fr 10 Jan 2014 - 0:54

Ich habe mir dein "Modul" gerade noch mal angesehen.
Ich sehe zwar, das du dort eine große Grafil eingesetzt hast und davor hast du die Ganzen Elemente (Links und Beschriftungen) als Fixe Elemente plaziert.
So war das nicht gemeint und das ist auch die Falsche richtung.
Die Elemente die du hier Fix Eingesetzt hast müssen sich alle in einer Tabelle innerhalb des Moduls befinden.
Was du hier gemacht hast, ist unnötig Kompliziert und du siehst selber was du für Probleme damit hast.

Auserdem sollte dir doch klar sein, das wenn du Auf der rechten Seite eine Grafik wie diese einsetz:


Die schon alleine 318 Px breit ist, dir den gesammten Inhalt des darunter liegenden Forums überdeckt.
Wenn du mal überlegst, das wenn einer mit kleiner Bildschimauflösung dein Forum aufruft, dieses Modul schon ein drittel des Bildschirm ausfüllt, must du einsehen, das diese Lösung so absolut nicht mehr vernünftig ist.
Hier solltest du dir echt etwas anderes einfallen lassen, denn so wird das nie vernünftig werden und aussehen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von jany am Fr 10 Jan 2014 - 10:14

Die Texte sind aber innerhalb des Moduls, die habe ich alle in das gleiche Modul, untereinander, gesetzt. Wie wäre es denn, wenn ich die Leiste auf- und zuklappen lassen würde?

jany
Premium-User
Premium-User

Männlich Beiträge : 428
Hinweis : EURO TRUCK SIMULATOR 2
2. Verwarnung
Anmeldedatum : 22.10.09

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: Grundsätzliches Problem bei einem Script

Beitrag von #Frank am Fr 10 Jan 2014 - 18:53

Es ist mir schon klar, was du gemacht hast und was du beabsichtigst, nur warum gehst du dabei düsen komplizierten Weg.
Was du hier gebaut hast ist im Grunde ja nicht als Modul zu bezeichnen, sondern das ist eine Anhäufung von Fixierten Elementen.
Das ist der Falsche Weg um soetwas zu realisieren.
Und um es gleich zu sagen, wirst du so, wie du es jetzt aufgebaut hast nicht so leicht auf und zu klappen können.
Lösungen zum klappen findest du wenn du nach Ausklappen oder klappen suchst.
Du hast sicher schon mal diese Ausklappbare Chatbox gesehen. Das ist das selbe Prenzip.


Zuletzt von Günther am Do 16 Jan 2014 - 18:25 bearbeitet, insgesamt 1 mal bearbeitet (Grund : keine Rückmeldung -> closed)



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34502
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten