Lexi Help
Partner
www.forumieren.com

[phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Keine Rückmeldung closed [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 15 Dez 2013 - 7:19

Huhu,

ich habe vorhin versucht, die Kategoriebilder auf die ganze Breite des Forums einzustellen. Die Kategoriebilder sind von der Größe her genauso groß wie der Header - 720px. Wenn ich mich in einem Thread oder in einer Kategorie befinde, stimmt die Anzeige. Befinde ich mich jedoch im Index, so ist über dem zuletzt geposteten Thema ein leeres Feld zu sehen.
Ich hab jetzt schon rumprobiert und auch die Suchfunktion genutzt, aber leider keine Lösung für mein Problem gefunden.

Danke schonmal,

EvilQueen


Zuletzt von EvilQueen am So 15 Dez 2013 - 18:37 bearbeitet, insgesamt 1 mal bearbeitet

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von LouiXIV am So 15 Dez 2013 - 9:54

Hallo EvilQueen,

der Präfix sagt zwar, es wäre ein BB3-Forum, mir scheint aber du hast ein BB2-Forum.

Wenn dem so ist, kannst du dies mit Template-Änderungen erreichen. Schau mal HIER.

Dies ist leider bei BB3-Foren nicht möglich.

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 15 Dez 2013 - 17:33

Hallo LOUIXIV,

mein Fehler. Es handelt sich tatsächlich um ein BB2 Forum.
Ich hab genau wie es dort beschrieben ist das Template geändert - aber dann sieht es auch nicht viel anders aus, wie jetzt.

lG
Evil Queen

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von LouiXIV am So 15 Dez 2013 - 19:00

Sorry,

bei BB2 und Templates bin ich nicht der richtige Ansprechpartner.

Gebe an jemand ab, der sich auskennt Wink

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am Mo 16 Dez 2013 - 0:25

Alles klar, Danke trotzdem Smile

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 22 Dez 2013 - 15:05

Das Problem ist leider immer noch aktuell :/

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von ~Julian~ am So 22 Dez 2013 - 15:27

Hallo! Smile

Ich hab übersehen, dass Loui den Thread freigegeben hatte.
Magst du mir mal den Inhalt des Templates index_box hier in den [code]-Tag packen? ^^

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 22 Dez 2013 - 22:38

Kein Problem Smile

Hier der Inhalt aus dem Template
Code:

<!-- BEGIN catrow -->
    <!-- BEGIN tablehead -->
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
       
   <tr>
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="690" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50" width="100">
         <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
   </tr>
   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von ~Julian~ am So 22 Dez 2013 - 23:06

Setz den Code mal so ein:
Code:
<!-- BEGIN catrow -->
    <!-- BEGIN tablehead -->
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
          <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>

    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <!-- END tablehead -->
  <!-- BEGIN cathead -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
        <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
              <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
        </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
  </tr>
  <!-- END cathead -->
  <!-- BEGIN forumrow -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="690" height="50">
        <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
        </h{catrow.forumrow.LEVEL}>
        <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
        <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
        </span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50" width="100">
        <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
  </tr>
  <!-- END forumrow -->
  <!-- BEGIN catfoot -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
  </tr>
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Ehrlich gesagt wundert es mich ein bisschen, dass die Bilder überhaupt bei dir angezeigt werden, weil dem Code nach fehlt der wichtigste Teil eigentlich. :'D

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 22 Dez 2013 - 23:16

Hab ihn kopiert und eingesetzt - sieht genauso aus wie vorher o.ô

Ich hab auch schon versucht, die Forumsbreite zu ändern, aber darüber geht es auch nicht.

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von ~Julian~ am Mo 23 Dez 2013 - 14:50

Hmmh. Okay, dann probieren wir da mal ein wenig rum ^^"

Such diesen Bereich:
Code:
<!-- BEGIN catrow -->
    <!-- BEGIN tablehead -->
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
          <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>

    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <!-- END tablehead -->

Und ersetz ihn durch:
Code:
<!-- BEGIN catrow -->
    <!-- BEGIN tablehead -->
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
          <th colspan="3" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>

    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <!-- END tablehead -->

In dem <th>-Bereich ist das colspan nun direkt definiert. Siehst du ja auch hieran:
Code:
<th colspan="3" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th>

Sollte das zum selben Ergebnis führen, versuche mal das colspan="3" zu erhöhen, d.h. auf "4" oder "5" zu setzen.
Ansonsten kann ich nur empfehlen, das Template nochmal komplett zu löschen und den Code neu einzufügen. notknowing

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am Di 24 Dez 2013 - 20:15

Ausprobiert - auch colspan erhöht, keine Veränderung.

Ich verstehe einfach nicht, warum es wenn ich auf eines der Kategoriebildchen klicke von der Breite her komplett stimmt, sobald es dann aber im Index ist, die "letzte Posting" Angabe so weit rechts außen ist o.O

Dann muss ich den Code tatsächlich nochmal neu einfügen. Sollte der Fall eintreten, dass es dann immer noch nicht funktioniert - was mache ich dann?
Bei anderen funktioniert es ja auch einwandfrei

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von ~Julian~ am Sa 28 Dez 2013 - 17:52

So, jetzt melde ich mich auch mal wieder. Hoffe, dass du ein paar schöne Weihnachtstage hast verbringen können. Smile

Ich würde wirklich versuchen, den ganzen Code nochmal Schritt für Schritt einzufügen. Wie gesagt, wunderte es mich ja eh, dass die Kategoriebilder überhaupt bei dir angezeigt wurden, weil einfach das wichtigste für das Anzeigen der Bild gefehlt hat, nämlich der Part für Kategorie-Überschrift selbst. Dementsprechend war der Code ganz am Anfang schon fehlerhaft, aber aus irgendeinem Grund wurde es doch angezeigt. Lösch das Template einfach nochmal durch einen Klick auf delete_icon und gib die Änderungen dann erneut im Template ein.

Wenn sich dann jedoch immernoch nichts tut, dann müsstest du eventuell ein bisschen abwarten. Momentan haben wir ja immernoch die Probleme mit dem Editor und es sind durch das Updaten der Editoren im ACP neue Probleme hinzugekommen. Inwieweit davon letztlich die Templates auch betroffen sein könnten, kann ich dir nicht sagen. Ich kann mir aber gut vorstellen, dass Änderungen an Templates auch von den Editor-Änderungen betroffen sind.

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von EvilQueen am So 29 Dez 2013 - 19:44

Hey Julian Smile

Danke, hatte ich tatsächlich. Ich hoffe, du hast auch ein paar schöne Tage mit der Familie / Freunden verbracht.

Ich hab das Template jetzt mal gelöscht, neu nach Zuckerpuppes Tutorial eingefügt. Wie man sieht, ist rechts immer noch frei über Themen/Beiträgen und letzer Post. Ich kann mir einfach nicht erklären, woran das liegt da ich alles genau nach ihren Vorgaben gemacht habe und mir ziemlich sicher bin, das mir da kein Fehler unterlaufen sein kann zu mal es ja auch von allem stimmt, wenn ich auf ein Kategoriebild klicke. Da hat es genau die richtige Größe, ist weder zu groß, noch zu klein und es hat eben auch die Themen etc. unter dem Kategoriebild und nicht rechts davon.

Falls es denn tatsächlich an dem Problem mit den Editoren liegt- ist schon absehbar, wie lange das noch dauern wird? Mir macht es zwar nichts aus, das Forum zu eröffnen obwohl das mit den Kategoriebildern noch nicht ganz stimmt (notfalls nehme ich sie dann eben raus und füge sie ein, wenn es wieder funktioniert), aber mich ärgert es dennoch ein bisschen, dass es nicht so will wie ich.

EvilQueen
Neuling
Neuling

Beiträge : 8
Anmeldedatum : 15.12.13

Benutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Darstellung in Thread und Kategorie stimmt, im Index jedoch nicht

Beitrag von #Frank am So 29 Dez 2013 - 21:00

Nur mal um auf diese Frage einzugehen:
@EvilQueen schrieb:Ich verstehe einfach nicht, warum es wenn ich auf eines der Kategoriebildchen klicke von der Breite her komplett stimmt, sobald es dann aber im Index ist, die "letzte Posting" Angabe so weit rechts außen ist o.O
Da es sich hier um zwei verschiedene Templates handelt, hat eine Änderung an der Stelle an der ihr im Moment arbeitet nichts mit der Ansicht der Unterforen zu tun.

Es wäre echt gut, wenn du das gesammte Template von index_box hier noch mal postest.

Und noch was: wenn ihr euch mal den Code aus Zuckerpuppes Beitrag anschaut, der oben verlinkt ist, fehlt bei euch eine ganze Zeile.
Code:
<!-- BEGIN catrow -->
    <!-- BEGIN tablehead -->
    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
          <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>

    <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
      <tr>
    <th nowrap="nowrap" width="50">{}</th>
    <th nowrap="nowrap" width="50">{}</th>
          <th nowrap="nowrap" width="50">{L_TOPICS}</th>
          <th nowrap="nowrap" width="50">{L_POSTS}</th>
          <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th>
      </tr>
      <!-- END tablehead -->
     


Das nur so als Zwischenwurf und nun macht Julian hier weiter.


Zuletzt von Günther am Do 2 Jan 2014 - 12:24 bearbeitet, insgesamt 1 mal bearbeitet (Grund : keine Rückmeldung -> closed)



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten