Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Passi92 Heute um 17:13

» Impressum
von #Frank Gestern um 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Gestern um 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Gestern um 22:07

» Themen-Icons
von Bigtuber Gestern um 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Gestern um 20:09

» Themen fixieren
von inde Gestern um 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Gestern um 13:34

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

[phpBB2] Wahlschalter

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Keine Rückmeldung closed [phpBB2] Wahlschalter

Beitrag von Fuchsstern am Sa 29 Jun 2013 - 18:59

Ich habe versucht einen Wahlschalter zu machen.
doch irgendwie funktioniert das nicht
Ich bräuchte da echt mal etwas Hilfe!
hier den Code den ich eingegeben habe:
<option value="Wert1">ORGINALSTYLE </option>
if (type == 'wert1')
{
document.write('<link rel="stylesheet" type="text/css" href="http://warriorcats1.freiforum.com/">');
}
<option value="Wert2">Style2 </option>
else if (type == 'Wert2')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://warriorcats1.freiforum.com/198575-ltr.css">');
}

kann mir da jemand helfen?
danke im Voraus

Fuchsstern
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 29.06.13

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Wahlschalter

Beitrag von Günther am Sa 29 Jun 2013 - 19:16

Hallo und herzlich Willkommen,

du bist neu hier im Forum.
Mache dich bitte zunächst mit den hiesigen Forenregeln vertraut.

Viele Antworten findest du auch in der Wissenssammlung "Lexi Help" Exclamation

Klick einfach auf das Bild Arrow

Solltest du keine für dich passende Antwort in der Suchfunktion (Link in der Navigation) oder bei "Lexi Help" gefunden haben, dann eröffne pro Frage ein neues Thema.

Ich wünsche dir hier im Forum viele Informationen und guten Erfolg mit deinem Forum top
Du hast dich bei deinem Geburtstag vertippt (so wärst du 50 Jahre alt), bitte bessere das in deinem Profil aus. Danke! Wink

Zu deiner Frage:
Du hast bei "Beschreibung der Webseite" Folgendes eingegeben:
Code:
<div id="sugar"></div>
<script src="http://warriorcats1.freiforum.com/-198575" type="text/javascript">
Folglich hast du die URL der HTML-Seite nicht korrekt kopiert, denn diese ist falsch:
http://warriorcats1.freiforum.com/-198575

Ein weiteres Problem ist, dass man den Schalter unter Chrome und IE auch nach Beheben des Fehlers bzw. der Fehler nicht sehen wird:
http://hilfe.forumieren.com/t36467-chrome-wechselschalter-wahlschalter-stylewechsler-wird-nicht-angezeigt#239207
Ich weiß nicht, ob es für dich in Frage kommt, die dort genannten Alternativlösungen anzugehen. Dazu ist etwas Erfahrung in solchen Umsetzungen nötig, um das Script, wie beschrieben, auch für Chrome und IE gerecht einzubinden.

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Wahlschalter

Beitrag von Fuchsstern am Sa 29 Jun 2013 - 19:41

wegen der falschen URL:
ich habe aber alles richtig gemacht
wieso ist es dann falsch?

und ich habe nun die alternativ sachen gemacht.
und nun ist das logo verschwunden .(

Fuchsstern
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 29.06.13

Nutzerprofil anzeigen

Nach oben Nach unten

Keine Rückmeldung closed Re: [phpBB2] Wahlschalter

Beitrag von Günther am Sa 29 Jun 2013 - 20:12

Dann hast du offenbar die Umsetzung für das Wechsellogo durchgeführt, was natürlich nicht richtig ist. Du müsstest das Script extern hosten, wie im verlinkten Beitrag beschrieben, aber das ist nur bei entsprechendem Grundwissen sinnvoll.
Ist dieses nicht vorhanden, wirst du unter Chrome wohl auf den Schalter verzichten müssen.

Und das hast du anscheinend überlesen:
@Günther schrieb:Du hast dich bei deinem Geburtstag vertippt (so wärst du 50 Jahre alt), bitte bessere das in deinem Profil aus. Danke! Wink

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten