Lexi Help
Partner
www.forumieren.com

[phpBB2] Wechselschalter - Buttons

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Wechselschalter - Buttons

Beitrag von Raylan am Do 23 Mai 2013 - 23:34

Huhu, hier bin ich wieder mit meinem CSS-Gerüstproblem, und zwar habe ich folgenden Code geschrieben:
Code:
#one {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/new10.png);
height:64px; /*Höhe des Bildes */
width:115px; /*Breite des Bildes*/}

#i_reply {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/antwor10.png);
height:64px; /*Höhe des Bildes */
width:181px; /*Breite des Bildes*/}

#i_icon_quote {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/zitat10.png);
height:52px; /*Höhe des Bildes */
width:75px; /*Breite des Bildes*/}

#i_icon_delete {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/xxx10.png);
height:52px; /*Höhe des Bildes */
width:57px; /*Breite des Bildes*/}

#i_icon_profile {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/profil10.png);
height:52px; /*Höhe des Bildes */
width:87px; /*Breite des Bildes*/}

#i_icon_edit{background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/edit10.png);
height:52px; /*Höhe des Bildes */
width:68px; /*Breite des Bildes*/}

#i_icon_pm {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/nachri10.png);
height:52px; /*Höhe des Bildes */
width:137px; /*Breite des Bildes*/}

#i_icon_online {background-image: url(http://i12.servimg.com/u/f12/17/43/29/62/online12.png);
height:52px; /*Höhe des Bildes */
width:106px; /*Breite des Bildes*/}

um die Buttons meines Versuchs Forums dem meines eigentlichen Forums anzupassen. Das tolle? - Es funktioniert nur für die ERSTEN 2. Danach, sind die Buttons einfach nicht mehr vorhanden, obwohl es die Richtigen Bezeichnungen sein müssten. Frage, hat das etwas mit der profil-icon Klasse in die es vorher eingebaut ist über den Link zu tun?

Zweite Frage gleich im Anschluss, das waren die einzigen schon existierenden Klassen, die ich gefunden habe, jetzt gibt es noch die Website, und die E-mail buttons, für die muss ich dann eine klasse erstellen und im Template einfügen oder?

Großes, dickes, fettes, danke im Voraus, und tut mir leid, dass ich damit so oft nerve Sad *hoff dass ihr mir verzeihen könnt*

Ray <3


Zuletzt von Raylan am Fr 24 Mai 2013 - 0:09 bearbeitet, insgesamt 1 mal bearbeitet

Raylan
Neuling
Neuling

Weiblich Beiträge : 54
Anmeldedatum : 06.11.12
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Wechselschalter - Buttons

Beitrag von Raylan am Do 23 Mai 2013 - 23:41

Äh sry, wegen der zweiten Frage, hab grade erst gesehen, dass das nicht erlaubt ist, aber es wäre irgendwie dumm dafür ein zweites Thema aufzumachen, weil sie ja mit dem ersten zusammenhängt :/.... *nomm nomm*

Raylan
Neuling
Neuling

Weiblich Beiträge : 54
Anmeldedatum : 06.11.12
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Wechselschalter - Buttons

Beitrag von Günther am Fr 24 Mai 2013 - 0:02

Hallo,

bitte lies dir unsere Regeln durch. Idea
Zu den zwei Fragen in einem Thema wurdest du ja bereits selbst fündig - aber:
Doppelpostings sind laut unseren Forenregeln nicht erlaubt. Verwende stattdessen bitte den -Button, um deinem Beitrag etwas hinzuzufügen.

Nun zu deiner Frage: Ich nehme an, du arbeitest mit Firebug und hast auf diesem Weg die jeweiligen Klassen gefunden?
Dann solltest du dir den Quellcode bei den Buttons/Icons, bei denen dein CSS-Code nicht wirkt, nochmals genauer ansehen:
<img class="i_icon_quote" title="Mit einem Zitat antworten" alt="Mit einem Zitat antworten">
Bei "i_icon_quote" handelt es sich also um eine Klasse. Du hast "i_icon_quote" hingegen als eine ID angesprochen:
#i_icon_quote {background-image: url(https://i12.servimg.com/u/f12/17/43/29/62/zitat10.png);
height:52px; /*Höhe des Bildes */
width:75px; /*Breite des Bildes*/}
Zwischen Klassen- und ID-Namen besteht ein Unterschied und wenn du diesen nicht beachtest, wirken die Zuweisungen nicht. Das ist bei allen Buttons/Icons der Fall, die bei dir momentan nicht angezeigt werden.
Falls du nicht wissen solltest, wie du Klassennamen ansprechen kannst:
http://www.css-lernen.net/css-klassen.php
Ersetzt du an allen nötigen Stellen das Selektorzeichen # durch jenes für Klassen, ist der Fehler behoben.

Und zu deiner zweiten Frage: Ja, damit hast du selbst bereits die richtige Antwort gefunden. Wink

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Wechselschalter - Buttons

Beitrag von Raylan am Fr 24 Mai 2013 - 0:09

Danke!!! <3333 && sry tut mir leid, ich hab nur so schnell wie möglich versucht mich zu entschuldigen und dabei das Edit total verpeilt -.- :/ sry nochmal

<3333 vielen dank Smile du hast mir wirklich viel weiter geholfen!!

#Closed

Raylan
Neuling
Neuling

Weiblich Beiträge : 54
Anmeldedatum : 06.11.12
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Wechselschalter - Buttons

Beitrag von Günther am Fr 24 Mai 2013 - 0:11

Ist gut, das kann passieren. Bitte in Zukunft darauf achten und unsere Regeln nochmals durchgehen. Wink

Bitte und gute Nacht. Smile
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten