Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Regeln und nützliche Hinweise
Slideshow-Generator
Der Forumieren Slide Show - Diashow-GeneratorDer Forumieren Slide Show - Diashow-GeneratorDer Forumieren Slide Show - Diashow-GeneratorDer Forumieren Slide Show - Diashow-GeneratorDer Forumieren Slide Show - Diashow-Generator
Lexi Help
Die neuesten Themen
» Wrestling Around the World!
von Emily Stein Gestern um 11:46

» Wrestling Forum
von Emily Stein Gestern um 11:45

» Spacemaniac-das Modellraketen Forum für alle ;)
von Emily Stein Gestern um 11:43

» Signatur (468*60) für http://rpg-drachenkrieg.forumieren.eu
von Zocker96 Do 22 Jun 2017 - 21:45

» Guthaben kaufen / einsetzen - Was kostet wie viel?
von Forumbot Do 22 Jun 2017 - 19:43

» [Update] jQuery-Update: von Version 1.7 zu 3.2
von Forumbot Do 22 Jun 2017 - 18:23

» C&C Renegade Forum
von inde Do 22 Jun 2017 - 17:32

» Tutorial-Forum für forumieren Administratoren.
von inde Do 22 Jun 2017 - 17:31

» Youtube Fanforum
von Emily Stein Do 22 Jun 2017 - 17:07

» Youtuber Fanforum
von Emily Stein Do 22 Jun 2017 - 17:07

» Prime-Kingz.de - We Love to Prime-Kingz
von Emily Stein Do 22 Jun 2017 - 17:06

» [phpBB3] Inter-NET - Das Forum zum allgemeinen Internet
von Emily Stein Do 22 Jun 2017 - 17:05

» CodeLabs
von Emily Stein Do 22 Jun 2017 - 17:04

» Animal Crossing Villagers Forum
von Emily Stein Do 22 Jun 2017 - 17:03

» Htmlfreak-Forum für Webdesign, Events und Frageforum
von Emily Stein Do 22 Jun 2017 - 17:02

» Test-Forum (Foruml)
von Emily Stein Do 22 Jun 2017 - 16:57

www.forumieren.de

Bug bei den CSS Sprites

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am So 5 Mai 2013 - 11:04

Hallo ich wolle mal fragen wieso bei dr Moderation immer die Extramenü-CSS Sprites weg sind. Ich glaube das ist irgendwie ein Bug. Kann man das so fixen oder ist das ein technisches Problem?


Zuletzt von Blade@CodeLabs am Mo 6 Mai 2013 - 20:47 bearbeitet; insgesamt 1-mal bearbeitet
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von #Frank am So 5 Mai 2013 - 11:40

Ich kann das jetzt nicht genau nachvollziehen, aber meinst du die Lücke in deiner Navigation?
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am So 5 Mai 2013 - 15:30

Nein, die Bilder für die Extramenüs verschwinden völlig...
Siehe hier:


So sieht's normalerweise aus.
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von #Frank am So 5 Mai 2013 - 18:01

Ist das dauerhaft so oder immer nur beim ersten Hoovern?

Edit:
Ich habe es mir nun nochmal angeschaut, aber ich kann als Gast so keine Fehler feststellen.
Kann es sein, das die Bilder teilweise nicht geladen werden?
Hat das schon mal Funktioniert, oder ist das dauerhaft so.
Wenn es nur ab und an mal vorkommt, dann musst du nachsehen, ob die Grafiken auch wirklich geladen werden.
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34607
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am Mo 6 Mai 2013 - 19:49

Ich sage ja, nur beim moderieren...
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Günther am Mo 6 Mai 2013 - 19:59

Welche Moderationshandlung führst du auf deinem Screenshot denn gerade durch:
avatar
Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
keine
Firefox phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am Mo 6 Mai 2013 - 20:02

Das ist egal, bei allen Moderatoroperationen passiert das. Auch in einem anderen Forum mit CSS Sprites.
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Günther am Mo 6 Mai 2013 - 20:05

Kannst du bitte trotzdem meine Frage beantworten, was du genau gemacht bzw. angeklickt hast, als der Screenshot entstanden ist? Dann kann ich die Situation auch identisch nachstellen und das wäre vorteilhaft. Wink
avatar
Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
keine
Firefox phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am Mo 6 Mai 2013 - 20:09

Okay klar, bei IP View, Move, Split, Delete, Lock, Unlock und Merge, also alle Moderationsoperationen. Egal welches Thema...
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Günther am Mo 6 Mai 2013 - 20:14

Okay, danke. Auf diesen Seiten sollte das persönliche CSS normalerweise auch geladen werden.

Darf ich mir das mal selbst in deinem Forum ansehen? Wenn das für dich in Ordnung ist, sende mir bitte per PN Logindaten für einen (Test-)Account mit Moderationsrechten oder Administrationsrechten.
avatar
Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
keine
Firefox phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am Mo 6 Mai 2013 - 20:25

Klar kein Problem!
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Günther am Mo 6 Mai 2013 - 20:43

Danke, jetzt ist alles klar. Smile

Während einer Moderationshandlung wird allen Links im Forum eine tid-Nummer (Sitzungsnummer) angefügt. Diese siehst du auch in der zu diesem Zeitpunkt angezeigten URL in der Adresszeile deines Browsers. Dadurch lautet z.B. die URL deines Navibuttons "Rules" nicht mehr
/portal?pid=2
sondern etwa
tid-Nummer aus Sicherheitsgründen versteckt Wink
Die Standardnavibuttons sprichst du über ihre jeweilige ID an (z.B. #i_icon_mini_profile), aber die zusätzlich hinzugefügten Navibuttons besitzen ja keine eigene ID und deshalb wurde dir hier empfohlen, sie stattdessen mit Attributselektoren anzusprechen:
.mainmenu[href="/portal?pid=2"] img {
Da dieser verwendete Attributselektor nur zum Einsatz kommt, wenn exakt das eingegebene Attribut im Quellcode vorhanden ist, wirkt er nicht, wenn die URL des Navibuttons durch die tid-Nummer ergänzt wird.

Wenn dich das während Moderationshandlungen stört, kannst du die Attributselektoren jeweils um folgendes Zeichen ergänzen:
.mainmenu[href^="/portal?pid=2"] img {
Das Ergebnis wirst du in deinem Forum sehen und wodurch sich dieser Attrobutselektor von deinem bisherigen unterscheidet, kannst du dort nachlesen:
http://jendryschik.de/wsdev/einfuehrung/css/selektoren
http://www.mediaevent.de/css/css-selektor-attributselektor.html


Zuletzt von Günther am Mo 6 Mai 2013 - 20:50 bearbeitet; insgesamt 2-mal bearbeitet (Grund : tid-Nummer versteckt)
avatar
Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
keine
Firefox phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Blade@CodeLabs am Mo 6 Mai 2013 - 20:46

Ah verstehe, also [foo^=bar] oder wie das heißt. Ja, das mach ich dann mal, danke schön ;D
avatar
Blade@CodeLabs
Lehrling
Lehrling

Männlich Beiträge : 136
Anmeldedatum : 17.11.12
1.Verwarnung
PunBB

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Bug bei den CSS Sprites

Beitrag von Günther am Mo 6 Mai 2013 - 20:48

Bitte, gerne. Smile

Ich bin wieder ausgeloggt und du kannst den Testaccount gerne wieder löschen oder das Passwort ändern.
-closed-
avatar
Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
keine
Firefox phpBB3

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten