Lexi Help
Partner
www.forumieren.com

Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von AniX72 am Fr 19 Apr 2013 - 21:40

Ich kann zu meinem Problem leider keine passende Lösung hier im Forum finden oder in den Anleitungen, weder von Forumieren noch von GoDaddy.

Ich betreibe ein Forum unter ups-raven.7forum.net - mit eigener Domain ups-raven.com und Weiterleitung auf diesen persönlichen Domainnamen - soweit funktioniert alles.

Zusätzlich leiten wir die extern gekaufte TLD-Domain ups-clan.com auf ups-raven.com weiter. Ich habe allerdings Probleme die Weiterleitung einzurichten. Wie in eurer Anleitung und auch in der von Godaddy beschrieben, habe ich folgenden CNAME (Alias) für die Zonendatei von ups-clan.com eingerichtet:

Host: www
Points to: www.ups-raven.com
TTL: 1 Stunde

Das seltsame ist, dass die Weiterleitung zum Teil funktioniert und man gelangt bei Eingabe von ups-clan.com auf unser Forum. Das kann im gleichen Browser aber bei varieender Schreibweise, z.B. www.ups-clan.com oder ups-clan.com/ (mit "/" hinten) schon wieder anders aussehen und ich komme auf folgende Seite:

Code:
http://www.forumieren.com/de/search/www.ups-clan.com

Das Verhalten unterscheidet sich auch zwischen den Browsern, sogar bei gleichem Browser aber unterschiedlichem Nutzerprofil. Ich kann da keine Logik erkennen.

Ich habe es alternativ zum CNAME-Eintrag auch mit Domain-Forwards (temporär und permanent) versucht, aber auch dann landet man in vielen Fällen auf dieser seltsamen Suchseite.

Habt Ihr noch einen Ratschlag?


Zuletzt von AniX72 am So 21 Apr 2013 - 20:30 bearbeitet, insgesamt 1 mal bearbeitet

AniX72
Neuling
Neuling

Beiträge : 13
Anmeldedatum : 08.09.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von Günther am Sa 20 Apr 2013 - 3:06

Hallo,

zuerst mal: Hast du diese Domain auch unter
AB -> Allgemeines -> Forum -> Internetadresse des Forums -> Persönlicher Domainname
oben in der ersten Box Persönlicher Domainname eingetragen? Das ist unbedingt nötig, damit die Domainweiterleitung von unseren Servern zugelassen wird und nicht nur zur Suchseite führt. Du musst wissen, dass es auch 24-48h dauern kann, bis solche Konfigurationen einwandfrei und allgemein funktionieren.


Außerdem zur Optimierung deiner Konfiguration:
@AniX72 schrieb:Host: www
Points to: www.ups-raven.com
TTL: 1 Stunde
Bei Host solltest du am besten, wenn du mehrere CNAME-Einträge für die Domain vornehmen kannst, zusätzlich zum www-Präfix auch noch einen Wert ohne dieses Präfix (d.h. die reine Domain für das http-Protokoll, ohne jegliche Präfixe) und bestenfalls auch noch eine Wildcard bestimmen.

Bei Points to solltest du die Zieldomain ohne das www-Präfix eingeben, also entweder ups-raven.7forum.net oder ups-raven.com

Ich habe noch einen Screenshot mit Beispielkonfigurationen eines einwandfreien CNAME-Eintrags erstellt, damit du dir das auch bildlich ansehen kannst:

Nochmals der Hinweis: Nach allen Konfigurationen bzw. Konfigurationsänderungen kann es bis zu 48h dauern, bis diese ihre Wirkung (richtig/vollständig) zeigen.

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von AniX72 am Sa 20 Apr 2013 - 12:19

Erst mal vielen Dank Smile

@Günther schrieb:Hallo,

zuerst mal: Hast du diese Domain auch unter
AB -> Allgemeines -> Forum -> Internetadresse des Forums -> Persönlicher Domainname
oben in der ersten Box Persönlicher Domainname eingetragen? Das ist unbedingt nötig, damit die Domainweiterleitung von unseren Servern zugelassen wird und nicht nur zur Suchseite führt. Du musst wissen, dass es auch 24-48h dauern kann, bis solche Konfigurationen einwandfrei und allgemein funktionieren.


Dort steht "www.ups-raven.com" fest eingetragen. Ich kann weder eine Domain hinzufügen, noch den Wert ändern.

@Günther schrieb:
Außerdem zur Optimierung deiner Konfiguration:
@AniX72 schrieb:Host: www
Points to: www.ups-raven.com
TTL: 1 Stunde
Bei Host solltest du am besten, wenn du mehrere CNAME-Einträge für die Domain vornehmen kannst, zusätzlich zum www-Präfix auch noch einen Wert ohne dieses Präfix (d.h. die reine Domain für das http-Protokoll, ohne jegliche Präfixe) und bestenfalls auch noch eine Wildcard bestimmen.

Bei Points to solltest du die Zieldomain ohne das www-Präfix eingeben, also entweder ups-raven.7forum.net oder ups-raven.com

www habe ich jetzt auf ups-raven.com umgestellt.
Leider kann ich keine CNAME-Einträge mit Wildcard (*) oder ohne Präfix/Subdomain eingeben. Aber das ist wohl eine Einschränkung von Godaddy.

AniX72
Neuling
Neuling

Beiträge : 13
Anmeldedatum : 08.09.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von Günther am Sa 20 Apr 2013 - 12:58

@AniX72 schrieb:Dort steht "www.ups-raven.com" fest eingetragen. Ich kann weder eine Domain hinzufügen, noch den Wert ändern.
Okay, das kommt daher, dass du über Forumieren auch eine Domain gemietet hast.

@AniX72 schrieb:www habe ich jetzt auf ups-raven.com umgestellt.
Du hast aber nicht den Wert bei Host verändert, oder?
Was ich dir empfohlen hatte, war eine Änderung des Werts bei Points to, nämlich dort das www. vor der Zieldomain zu entfernen. Beim "Host"-Wert darfst du nicht die Zieldomain eingeben, falls du das so verstanden hast, sondern kannst dort das www stehen lassen. Wink

Ich denke aber, du hast das schon richtig verstanden und nur den Wert bei Points to verändert, oder?
Soweit ich es nämlich sehe, funktioniert die Weiterleitung nun mit http://ups-clan.com Smile Kannst du das ebenfalls bestätigen?

Übrigens findest du auch dort gute Erklärungen dazu:
http://support.godaddy.com/help/article/7921/adding-or-editing-cname-records
http://support.google.com/a/bin/answer.py?hl=de&answer=47610&ctx=cb&src=cb&cbid=j9niwbuf7bmp&cbrank=0

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von AniX72 am Sa 20 Apr 2013 - 14:49

@Günther schrieb:
@AniX72 schrieb:Dort steht "www.ups-raven.com" fest eingetragen. Ich kann weder eine Domain hinzufügen, noch den Wert ändern.
Okay, das kommt daher, dass du über Forumieren auch eine Domain gemietet hast.
Ja. Ich würde nur im Notfall auf die Domain verzichten wollen Sad

@Günther schrieb:
Ich denke aber, du hast das schon richtig verstanden und nur den Wert bei Points to verändert, oder?
Soweit ich es nämlich sehe, funktioniert die Weiterleitung nun mit http://ups-clan.com Smile Kannst du das ebenfalls bestätigen?

Yep, hatte ich schon richtig verstanden Smile
Und ja, http://ups-clan.com leitet erfolgreich weiter. Aber sobald hinten ein "/" hängt oder vorne ein "www." kommt nur die Forumieren-Suchseite. Zwar ist als Treffer unser Forum ganz oben, aber die meisten Besucher erkennen das nicht und sind verwirrt. Gibt es irgendwie eine Möglichkeit statt auf der angezeigten Suchseite unsere Forenseite zu zeigen?

Bei Godaddy könnte ich auch ein Subdomain-Forwarding einrichten, z.B. www.ups-clan.com zu www.ups-raven.com - aber das würde ja mit jetzigen CNAME-Eintrag für "www" konkurrieren... keine Ahnung, was dann passiert.

Falls es da keine andere Lösung gibt, wie könnte ich ups-raven.com entfernen und stattdessen als eigenen (externen) Domainnamen ups-clan.com verwenden?

AniX72
Neuling
Neuling

Beiträge : 13
Anmeldedatum : 08.09.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von Günther am Sa 20 Apr 2013 - 16:13

@AniX72 schrieb:Bei Godaddy könnte ich auch ein Subdomain-Forwarding einrichten, z.B. www.ups-clan.com zu www.ups-raven.com
Das wäre dann keine DNS-Konfiguration, sondern eine HTTP-301-Weiterleitung:
http://support.godaddy.com/help/article/4040/managing-a-domain-names-forwarded-subdomains
Der wesentliche Unterschied dabei: Ruft man deine externe, so konfigurierte TLD auf, wird man zur TLD deines Forums mit URL-Änderung in der Adresszeile deines Browsers weitergeleitet. Idea Außerdem werden Suchmaschinen diese externe TLD nicht bzw. nicht gut indiziert listen, weil die HTTP-Weiterleitung signalisiert, dass der Content dauerhaft über die Zieldomain zu erreichen ist und die weiterleitende Domain nur mehr zur Verfügung steht, falls User diese noch verwenden sollten.
Wenn das für dich kein Problem darstellt, wäre eine solche Weiterleitung schon eine Option, aber du musst dir dieser Punkte bewusst sein. Eine HTTP-Weiterleitung mit maskierter Domain (d.h. die URL in der Adresszeile des Browsers bleibt gleich) ist eben nicht möglich, da die Weiterleitung auf eine Forumieren-Domain dir keine so weitreichenden Möglichkeiten bietet.

Grundsätzlich möchte ich noch erklären, weshalb deine externe Domain z.B. mit Angabe des www-Präfix oder einer Verzeichnisangabe (Slash hinter Domain) nicht funktioniert.
Wenn jemand deine externe Domain ups-clan.com mit Angabe einer Subdomain (was das www-Präfix genaugenommen darstellt) aufruft, dann wird dieser Domain über den DNS-Nameserver des Users die Forumieren-Domain ups-raven.com bzw. ups-raven.7forum.net zugewiesen. Deshalb wird anschließend die Forumieren-Domain aufgerufen, wo dann zuerst der Forumieren-Nameserver dieser Domain die korrekte IP/Zone deines Forums auf den Forumieren-Servern zuordnen muss. Dorthin gelangt der User schlussendlich.
Dazu muss dem Forumieren-Nameserver allerdings die verweisende externe TLD auch bereits bekannt sein. Ist sie ihm nicht bekannt, wird nur die Suchseite ausgewiesen, die du schon kennst.

Damit eine externe TLP also auch mit Subdomain-CNAME-Einträgen zu deinem Forum weiterleiten kann, muss zwingend unter
AB -> Allgemeines -> Forum -> Internetadresse des Forums -> Persönlicher Domainname
die externe Domain eingetragen werden.
Das Problem hierbei ist: Unser System lässt dort nur die Eintragung einer externen Domain zu, wenn nicht bereits über Forumieren eine TLP gemietet wird. Aus diesem Grund stehen dir drei Möglichkeiten offen:
  • du belässt alles wie aktuell, wobei deine externe TLP dann aber nur ohne Subdomains/www-Präfix/Verzeichnisangaben funktionell auf dein Forum verweist, weil unseren Forumieren-Nameservern diese Domain unbekannt ist
  • du entscheidest dich für eine Nicht-DNS-Weiterleitung, d.h. eine HTTP-301-Weiterleitung (dazu gehören auch die nicht empfehlenswerten Frameweiterleitungen oder refresh-HTML-Weiterleitungen). Dann ist nämlich keine DNS-Konfiguration nötig, die den Forumieren-Nameservern die externe TLP bekannt macht. Nachteil: In der Adresszeile des Browsers wird nicht die eingegebene externe TLD angezeigt, sondern die Zieldomain (= Domain deines Forums). Auch in Suchmaschinen wird die externe TLD dann nicht gut indiziert. Das dürfte deinen Vorstellungen also nicht wirklich entsprechen. Du müsstest nämlich davon ausgehen, dass dann mit der Zeit niemand mehr die externe TLD verwenden würde, sondern klarerweise gleich die TLD des Forums. Damit würde die externe TLD hinfällig.
  • du löschst die TLP, die du derzeit über Forumieren mietest. Dadurch kannst du dann unter
    AB -> Allgemeines -> Forum -> Internetadresse des Forums -> Persönlicher Domainname
    deine externe Domain in der gewünschten Form (d.h. mit www-Präfix) angeben und nach einer Wartezeit von 24-48h ist diese unseren Nameservern bekannt. Dadurch weisen diese deiner externen TLP dann dein Forum korrekt zu und lassen dorthin weiterleiten. Das würde dem entsprechen:
    @AniX72 schrieb:Falls es da keine andere Lösung gibt, wie könnte ich ups-raven.com entfernen und stattdessen als eigenen (externen) Domainnamen ups-clan.com verwenden?
    Löschen kannst du die über Forumieren gemietete TLP unter
    AB -> Verschiedenes -> Guthaben-Verwaltung -> Guthaben einsetzen -> Domainname
    oder, wenn es sich um eine von Forumieren geschenkte Domain handelt, stattdessen hier über den Support:
    (Geschenkte) Domain löschen
Ich hoffe, ich konnte dir damit die Zusammenhänge verständlich machen und du weißt, welche Optionen dir offenstehen.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von AniX72 am So 21 Apr 2013 - 20:33

Tausend Dank für die sehr gute Erklärung der verschiedenen Optionen!

Ich werde die Punkte mal mit meinen Admins besprechen und bestimmt finden wir eine gute Lösung.

(Thema als erledigt markiert)

AniX72
Neuling
Neuling

Beiträge : 13
Anmeldedatum : 08.09.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Weiterleitungsproblem von externer TLD-Domain zum Forum mit eigener Domain

Beitrag von Günther am So 21 Apr 2013 - 20:35

Bitteschön, gerne. Smile
Einen schönen Abend noch.
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten