Lexi Help
Partner
www.forumieren.com

Code in Modul nicht lesbar/umsetztbar

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Code in Modul nicht lesbar/umsetztbar

Beitrag von Mandy* am Di 16 Apr 2013 - 20:54

Hallo zusammen,

ich habe da eine frage und zwar moechte ich gerne von dieser Seite http://www.transparent.com/word-of-the-day/today/arabic.html#.UW2V_2cw9XQ das angebotene Tool einfuegen.

So habe ich es versucht:
Admin bereich Portale und Widgets
Index Module dort auf persoenliches Module erstellen
Neues Module benannt und Code eingefuegt, einmal mit HTML und einmal ohne Probiert.
doch beides mal erschien nur der Code

Was mache ich falsch?

Code:
<div style="width:160px;height:206px;margin:0 auto;">   <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="160" height="190" id="widgetResult"><param name="movie" value="http://www.transparent.com/word-of-the-day/small.swf" /><param name="id" value="widgetResult" /><param name="name" value="widgetResult" /><param name="quality" value="high" /><param name="allowscriptaccess" value="always" /><param name="allowfullscreen" value="true" /><param name="wmode" value="transparent" /><param name="bgcolor" value="#993399" /><param name="flashvars" value="bgimgfill=repeat&lang=french&bgcolor=#993399&bordercolor=#6c236c&txtcolor=#6c236c&boxtxtcolor=#ffffff&boxbgcolor=#6c236c&bgimgfile=texture/02.gif&bgimgenabled=true&bgimgalpha=0.25" />   <!--[if !IE]>-->      <object type="application/x-shockwave-flash" data="http://www.transparent.com/word-of-the-day/small.swf" width="160" height="190"><param name="movie" value="http://www.transparent.com/word-of-the-day/small.swf" /><param name="id" value="widgetResult" /><param name="name" value="widgetResult" /><param name="quality" value="high" /><param name="allowscriptaccess" value="always" /><param name="allowfullscreen" value="true" /><param name="wmode" value="transparent" /><param name="bgcolor" value="#993399" /><param name="flashvars" value="bgimgfill=repeat&lang=french&bgcolor=#993399&bordercolor=#6c236c&txtcolor=#6c236c&boxtxtcolor=#ffffff&boxbgcolor=#6c236c&bgimgfile=texture/02.gif&bgimgenabled=true&bgimgalpha=0.25" />   <!--<![endif]-->   <!--[if gte IE 6]>-->      <p>Either scripts and active content are not permitted to run or Adobe Flash Player version 10.0.0 or greater is not installed.</p>   <!--<![endif]-->      <a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash Player" /></a>   <!--[if !IE]>-->       </object>   <!--<![endif]-->   </object> <div style="font:bold 9px/16px Verdana; margin:-4px 5px 0 5px; padding:0; height:16px;"><div style="float:right; margin:0;"><a href="http://www.transparent.com/learn-french/" target="_parent" style="color:#004078; text-decoration:none;" title="Learn more French">Learn&nbsp;more</a></div><a href="http://www.transparent.com/word-of-the-day/today/french.html" target="_parent" style="color:#004078; text-decoration:none;" title="Get this widget">Get&nbsp;widget</a></div></div>


Zuletzt von Mandy* am Di 16 Apr 2013 - 21:26 bearbeitet, insgesamt 1 mal bearbeitet

Mandy*
Neuling
Neuling

Beiträge : 17
Anmeldedatum : 15.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von LouiXIV am Di 16 Apr 2013 - 21:03

Hallo Mandy,

ich habe den Code einfach mal in ein Index-Modul in meinem Forum eingesetzt. Funktioniert wunderbar ...

schau selbst (unten links): http://www.rigormortis-forum.com/

Ich seh hier kein Problem.

Hier das Modul im Adminbereich:


Wichtig dabei ist, dass du das Symbol HTML-EDIT sehen musst, damit der Code auch richtig umgesetzt wird.

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von Mandy* am Di 16 Apr 2013 - 21:08

@LouiXIV schrieb:Hallo Mandy,

ich habe den Code einfach mal in ein Index-Modul in meinem Forum eingesetzt. Funktioniert wunderbar ...

schau selbst (unten links): http://www.rigormortis-forum.com/

Ich seh hier kein Problem.

Hallo,

komisch was mach ich den da Falsch?

Mein beschriebener Vorgang ist der richtig, oder bist du anderst an die Sache dran?

hast du irgendwan mal was im Index aktiviert!

Mandy*
Neuling
Neuling

Beiträge : 17
Anmeldedatum : 15.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von Mandy* am Di 16 Apr 2013 - 21:13

Ja, Komisch!!

bei mir funktioniert es nicht, habe es gerade so wie auf deinem Screenshot eingestellt, aber es erscheint nur der Code nicht das Bild!





Zuletzt von Mandy* am Di 16 Apr 2013 - 21:18 bearbeitet, insgesamt 1 mal bearbeitet

Mandy*
Neuling
Neuling

Beiträge : 17
Anmeldedatum : 15.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von LouiXIV am Di 16 Apr 2013 - 21:16

Ich mache das so wie du:

- neues Modul erstellen
- Code rein
- absenden
- Modul einfügen

Versuch doch nochmal ein ganz neues Modul zu erstellen. Und bevor du den Code einfügst achte darauf, dass du das Symbol HTML-EDIT siehst.

EDIT: Bitte keine Doppelposts, dafür gibt es hier den "Edit"-Button.

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von Mandy* am Di 16 Apr 2013 - 21:19

@LouiXIV schrieb:Ich mache das so wie du:

- neues Modul erstellen
- Code rein
- absenden
- Modul einfügen

Versuch doch nochmal ein ganz neues Modul zu erstellen. Und bevor du den Code einfügst achte darauf, dass du das Symbol HTML-EDIT siehst.

EDIT: Bitte keine Doppelposts, dafür gibt es hier den "Edit"-Button.

ja tut mir leid, habe gerade mein letzten beitrag editiert und Scrennshot hinzugefuegt

Mandy*
Neuling
Neuling

Beiträge : 17
Anmeldedatum : 15.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von LouiXIV am Di 16 Apr 2013 - 21:23

Anhand deines Screenshots erkenne ich, dass du nicht nur den Code eingesetzt hast, sondern diesen in einer "Codebox" verpackt hast, dann ist es klar, dass du den Code auf deiner Seite angezeigt bekommst.

Lösch den ganzen Schmonz mal raus und pack nur den von dir geposteten Code in das Feld:
Code:
    <div style="width:160px;height:206px;margin:0 auto;">  <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="160" height="190" id="widgetResult"><param name="movie" value="http://www.transparent.com/word-of-the-day/small.swf" /><param name="id" value="widgetResult" /><param name="name" value="widgetResult" /><param name="quality" value="high" /><param name="allowscriptaccess" value="always" /><param name="allowfullscreen" value="true" /><param name="wmode" value="transparent" /><param name="bgcolor" value="#993399" /><param name="flashvars" value="bgimgfill=repeat&lang=french&bgcolor=#993399&bordercolor=#6c236c&txtcolor=#6c236c&boxtxtcolor=#ffffff&boxbgcolor=#6c236c&bgimgfile=texture/02.gif&bgimgenabled=true&bgimgalpha=0.25" />  <!--[if !IE]>-->      <object type="application/x-shockwave-flash" data="http://www.transparent.com/word-of-the-day/small.swf" width="160" height="190"><param name="movie" value="http://www.transparent.com/word-of-the-day/small.swf" /><param name="id" value="widgetResult" /><param name="name" value="widgetResult" /><param name="quality" value="high" /><param name="allowscriptaccess" value="always" /><param name="allowfullscreen" value="true" /><param name="wmode" value="transparent" /><param name="bgcolor" value="#993399" /><param name="flashvars" value="bgimgfill=repeat&lang=french&bgcolor=#993399&bordercolor=#6c236c&txtcolor=#6c236c&boxtxtcolor=#ffffff&boxbgcolor=#6c236c&bgimgfile=texture/02.gif&bgimgenabled=true&bgimgalpha=0.25" />  <!--<![endif]-->  <!--[if gte IE 6]>-->      <p>Either scripts and active content are not permitted to run or Adobe Flash Player version 10.0.0 or greater is not installed.</p>  <!--<![endif]-->      <a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash Player" /></a>  <!--[if !IE]>-->      </object>  <!--<![endif]-->  </object> <div style="font:bold 9px/16px Verdana; margin:-4px 5px 0 5px; padding:0; height:16px;"><div style="float:right; margin:0;"><a href="http://www.transparent.com/learn-french/" target="_parent" style="color:#004078; text-decoration:none;" title="Learn more French">Learn&nbsp;more</a></div><a href="http://www.transparent.com/word-of-the-day/today/french.html" target="_parent" style="color:#004078; text-decoration:none;" title="Get this widget">Get&nbsp;widget</a></div></div>
Dann sollte es auch klappen Wink

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von Mandy* am Di 16 Apr 2013 - 21:25

Ja, Super hat funktioniert!

habe dein Tipp beherzigz und habe alles geloescht und habe von der Seite den Code neu erstellen lassen und wie beim erstmal alles eingetsellt und es funktionierte, Echt komisch!

keine Ahnung was da von Anfang an scheif lief

Dankeschoen fuer die Geduld und hilfreiche Antworten!!!

Mandy*
Neuling
Neuling

Beiträge : 17
Anmeldedatum : 15.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Code in Modul nicht lesbar/umsetztbar

Beitrag von LouiXIV am Di 16 Apr 2013 - 21:29

Wie gesagt, irgendwie hattest du den Code in eine Codebox verpackt (siehst du an den ersten Befehlen in deinem Screenshot). Wahrscheinlich, weil du zuerst den Editor aktiviert hattest. Wann man nachträglich den Editor ausschaltet bleiben die HTML-Behfehle dann aber erhalten, die den Code einpacken.

Also Merke: Hast du einen fertigen Code, dann achte auf das Symbol HTML-EDIT sonst wird das nix Wink

Dann werd ich mal das Modul bei mir wieder rauswerfen. Bin zu alt jetzt noch Arabisch zu lernen...

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten