Lexi Help
Partner
www.forumieren.com

[phpBB2] Rahmen trotz halbtransparenter Forentabelle

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am Sa 23 März 2013 - 21:44

Hallo ihr lieben,
ich hab da mal ne gaaaanz doofe Frage und vielleicht ist es auch ganz simple zu lösen...

Ich hab in meinem Lady Oscar Forum nein kleines Problem mit dem Tabellenrahmen.
Ich hab da abgerundete Ecken und einen halbtransparenten Hintergrund in der Tabelle... soweit ganz chic und das soll auch so bleiben.
Nur hab ich jetzt keine (Trenn-)Linien mehr zwischen den einzelnen Forenlinks und Posts.

Hab dazu mal zwei Bilder... irgendwie weiß ich grad nicht, wie ich das deutlicher erklären soll.
Hier zwischen den einzelnen Foren:


und hier zwischen den einzelnen Posts:


Das ist der CSS-Code, den ich für den Tabellehintergrund nutze:
Code:
    .forumline {
    background-color:transparent;
    background-image: url('http://i70.servimg.com/u/f70/16/88/01/40/hg_bri10.png');
    background-repeat: repeat;
}

Meine Frage: Kann man in den bereits genutzten Code noch was einbauen, um diese Linien wieder zu bekommen? Oder brauche ich einen neuen (extra) Code und wenn ja, welchen in etwa.
Wäre vielleicht auch ganz nett, wenn es etwas in der Art - 1px dotted #3B0101; - wäre.
Wäre das machbar?

Sorry, falls es solch eine Frage schon mal gab, aber ich hab mit der Suchfunktion alles mögliche schon durchprobiert, aber nichts gefunden und im Netz hab ich mich scheinbar auch zu dämlich angestellt. Embarassed

Vielen Dank schon mal im Voraus!
Liebe Grüße, eure lost angel


Zuletzt von lost_angel am Mo 25 März 2013 - 16:30 bearbeitet, insgesamt 1 mal bearbeitet

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am Sa 23 März 2013 - 22:15

Hallo,

das hängt mit einer Besonderheit unter BB2 zusammen: Dort befinden sich eigentlich keine Zellrahmen. Stattdessen liegt unter den forumline-Tabellen eine Farbebene (Farbverwaltung: "Farbe der Zellenrahmen") und die einzelnen Zellen besitzen einen Zellabstand von 1px. Durch diese Zellabstände hindurch sieht man nun die darunterliegende Farbenene, die zwischen den Zellhintergründen (Farbverwaltung: "Tabellenreihe Farbe 1/2/3") eben wie ein Rahmen wirkt. Idea

Das bedeutet aber: Entfernt man die Hintergrundfarben der Zellen, wie du das wegen des transparenten Hintergrundbildes getan hast, dann würde direkt darunter die Farbebene "Farbe der Zellenrahmen" zum Vorschein kommen. Diese würde die gesamte Tabelle unterlegen und damit die Halbtransparenz der Hintergrundgrafik stören, weshalb mit deinem CSS-Eintrag auch diese Farbebene entfernt wurde.
Durch diesen Eintrag sieht man zwar die halbtransparente Hintergrundgrafik durch, aber zugleich verliert man eben auch die Zellenrahmen.
Genauer habe ich das in diesen Threads mal erklärt:
http://hilfe.forumieren.com/t33343-phpbb2-post-trennlinien#217412
http://hilfe.forumieren.com/t33420-rahmenart-andern#217954
Kannst du dem soweit folgen?

Diese Farbebene muss in deinem Fall fehlen, damit die halbtransparente Hintergrundgrafik der forumline-Tabellen ihre Wirkung zeigt. Also müsstest du - wenn dich die fehlenden Zellrahmen stören - diese per CSS als echte Rahmen (statt Zellabstände + dahinter Farbebene wie bisher Wink) festlegen.
Dabei kann ich dir helfen. Für die Beiträge füge in dein CSS-Stylesheet unter
AB -> Anzeige -> Bilder & Farben -> Farben -> Reiter "CSS Stylesheet"
folgenden Code ein:
Code:
.post > td, .browse-arrows, .messaging {
  border-bottom: 1px solid #000000;
}
.post > td:first-child, .browse-arrows {
  border-right: 1px solid #000000;
}
Für die Forentabelle im Index gehst du in die Templates zu
AB -> Anzeige -> Templates -> Allgemeines -> index_box
und suchst dort folgende Stelle (unverändertes Template: Zeile 20):
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
Den rot markierten Wert entfernst du, dann fügst du die grün markierten Stellen hinzu:
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline ind_tab" width="100%" border="0" cellspacing="0" cellpadding="0">
Danach sendest du das veränderte Template ab und veröffentlichst es über einen Klick auf plus.
Danach fügst in dein CSS-Stylesheet unter
AB -> Anzeige -> Bilder & Farben -> Farben -> Reiter "CSS Stylesheet"
folgenden Code ein:
Code:
.ind_tab td {
  border-bottom: 1px solid #000000;
  border-right: 1px solid #000000;
}
Wie du die border-Werte jeweils verändern kannst, weißt du sicher schon.
http://www.css4you.de/border.html

Entspricht das deinen Vorstellungen? Smile

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am So 24 März 2013 - 19:22

Also wenn ich jetzt Beiträge lese habe ich da die Tabellenlinien.
Aber auf der Indexseite hat sich nichts getan.
Ich hab alles so eingetragen, wie du es hier erklärt hast, aber irgendwas hat da nicht geklappt.

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am So 24 März 2013 - 19:47

Wie ich sehe, hast du das Template zum Zweck von durchgehenden Kategoriebildern modifiziert und hast deshalb die falsche forumline-Tabelle erwischt. Wink

Kannst du hier bitte dein aktuelles Template index_box zwischen den code-Tags posten, damit ich es mir mal ansehen kann?
Code:
[code][/code]

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am Mo 25 März 2013 - 15:39

So hier ist mein Template index_box:
Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
    <!-- BEGIN catrow -->
        <!-- BEGIN tablehead -->
        <table class="forumline ind_tab" width="100%" border="0" cellspacing="0" cellpadding="0">
          <tr>
              <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>

        <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
          <tr>
        <th nowrap="nowrap" width="50">{}</th>
        <th nowrap="nowrap" width="50">{}</th>
              <th nowrap="nowrap" width="50">{L_TOPICS}</th>
              <th nowrap="nowrap" width="50">{L_POSTS}</th>
              <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th>
          </tr>
          <!-- END tablehead -->
         
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>
      <td class="row3" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.TOPICS}</span>
      </td>
      <td class="row2" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.POSTS}</span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
   </tr>
   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Und danke, dass du mir dabei so schnell hilfst. Das liebe ich an eurem Team hier so! Freunde

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am Mo 25 März 2013 - 15:47

Bitte, bitte. Wink
Wie gesagt hattest du eine forumline-Tabelle zu früh erwischt, weil es bei dir zwei gibt (eine für das durchgehende Kategoriebild und eine für die Forentabelle):
<!-- BEGIN catrow -->
<!-- BEGIN tablehead -->
<table class="forumline ind_tab" width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>
</table>
<table class="forumline ind_tab" width="100%" border="0" cellspacing="1" cellpadding="0">
...
An der roten Stelle hast du die zusätzliche Klasse eingesetzt, an der grünen sollte sie sich aber tatsächlich befinden.
Ich habe dir das mal ausgebessert:
Code:
    <table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
      <tr>
          <td valign="bottom">
            <!-- BEGIN switch_user_logged_in -->
            <span class="gensmall">{LAST_VISIT_DATE}<br />
            {CURRENT_TIME}<br />
            </span>
            <!-- END switch_user_logged_in -->
            <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
          </td>
          <td class="gensmall" align="right" valign="bottom">
            <!-- BEGIN switch_user_logged_in -->
            <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
            <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
            <!-- END switch_user_logged_in -->
            <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
          </td>
      </tr>
    </table>
        <!-- BEGIN catrow -->
            <!-- BEGIN tablehead -->
            <table class="forumline" width="100%" border="0" cellspacing="0" cellpadding="0">
              <tr>
                  <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th></tr>
            </table>
            <table class="forumline ind_tab" width="100%" border="0" cellspacing="0" cellpadding="0">
              <tr>
            <th nowrap="nowrap" width="50">{}</th>
            <th nowrap="nowrap" width="50">{}</th>
                  <th nowrap="nowrap" width="50">{L_TOPICS}</th>
                  <th nowrap="nowrap" width="50">{L_POSTS}</th>
                  <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th>
              </tr>
              <!-- END tablehead -->
           
      <!-- BEGIN cathead -->
      <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
          <!-- END inc -->
          <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
            <h{catrow.cathead.LEVEL} class="hierarchy">
                <span class="cattitle">
                  <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
                </span>
            </h{catrow.cathead.LEVEL}>
          </td>
          <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
      </tr>
      <!-- END cathead -->
      <!-- BEGIN forumrow -->
      <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
          <!-- END inc -->
          <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
            <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
          </td>
          <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
            <h{catrow.forumrow.LEVEL} class="hierarchy">
                <span class="forumlink">
                  <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
                </span>
            </h{catrow.forumrow.LEVEL}>
            <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
            <span class="gensmall">
                <!-- BEGIN switch_moderators_links -->
                {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
                <!-- END switch_moderators_links -->
                {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
            </span>
          </td>
          <td class="row3" align="center" valign="middle" height="50">
            <span class="gensmall">{catrow.forumrow.TOPICS}</span>
          </td>
          <td class="row2" align="center" valign="middle" height="50">
            <span class="gensmall">{catrow.forumrow.POSTS}</span>
          </td>
          <td class="row3 over" align="center" valign="middle" height="50">
            <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
          </td>
      </tr>
      <!-- END forumrow -->
      <!-- BEGIN catfoot -->
      <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
          <!-- END inc -->
          <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
      </tr>
      <!-- END catfoot -->
      <!-- BEGIN tablefoot -->
    </table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am Mo 25 März 2013 - 16:05

Super, jetzt passt es.
Aber mir ist aufgefallen, wenn ich jetzt in ein Forum reingehe und dort die Titel der einzelnen Threads sehe, dann sind da keine Tabellenlinien. Ist das normal?
Und kann man die auch noch irgendwie einbauen?

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am Mo 25 März 2013 - 16:10

Dazu gehst du in die Templates zu
AB -> Anzeige -> Templates -> Allgemeines -> topics_list_box
und suchst dort folgende Stelle (unverändertes Template: Zeile 22):
<table class="forumline ind_tab" width="100%" border="0" cellspacing="0" cellpadding="0">
Den grün markierten Bereich fügst du hinzu und änderst auch den cellspacing-Wert von 1 auf 0.
Danach sendest du das veränderte Template ab und veröffentlichst es über einen Klick auf plus.

Dadurch werden auch die Thementabellen innerhalb der (Unter-)Foren vom CSS-Code angesprochen, den du eingesetzt hast.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am Mo 25 März 2013 - 16:20

Cool, hat alles geklappt!
Du bist ein Schatz.

Dann hab ich aber nochmal ne doofe Frage, wenn nicht möglich ist, ist's ok... ist ja nicht so wichtig. Bin ja auch schon eigentlich mit dem allen jetzt schon zufrieden.
Aber:

Die Tabellenlinien bekommt man nicht irgendwie wieder weg, oder?
Wie gesagt, wenns nicht geht, dann ist es auch nicht so schlimm. Sieht ja trotzdem irgendwie ganz chic aus. Wink

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am Mo 25 März 2013 - 16:25

Freut mich. Smile

Diese Rahmen kommen daher, dass du dort nochmal eine zusätzliche Tabelle für das Multiforum eingesetzt hast. Aber wir können sie dort entfernen, indem du folgenden CSS-Code ins Stylesheet ergänzt:
Code:
.ind_tab table td {
  border: none;
}

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von lost_angel am Mo 25 März 2013 - 16:30

Ich könnt dich knutschen! jippie
Hat geklappt!

gut, dann bin ich jetzt wunschlos glücklich!!!

lost_angel
Premium-User
Premium-User

Weiblich Beiträge : 368
Anmeldedatum : 09.12.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Rahmen trotz halbtransparenter Forentabelle

Beitrag von Günther am Mo 25 März 2013 - 16:34

Das freut mich aber, gerne. Very Happy

Einen schönen Tag noch.
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten