Lexi Help
Partner
free forum

[phpBB2] Probleme beim Einfügen in Gruppen - User bekommen Admin"strich"

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Probleme beim Einfügen in Gruppen - User bekommen Admin"strich"

Beitrag von Gast am Di 19 März 2013 - 17:08

Hallihallo *seufzt*
Ich habe folgendes Problem:
Adminstratoren bekommen in meinem Forum einen Strich unter ihren Namen, als kennzeichen, dass sie Admins sind:


Diesen Strich hab ich mit folgendem Code im CSS gemacht:
Code:
a[href^="/u1"] strong{
  border-bottom:1px solid #689989;

}

Soweit kein Problem.
Wenn ich jetzt jedoch einen User in eine Nutzergruppe einfüge, bekommen diese den Strich auch, ich weiß jedoch nicht wieso. Bisher habe ich das so gelöst:

Code:
a[href^="/u10"] strong{
  border-bottom:0px solid #689989;

}

Für den Anfang in Ordnung, aber wenn das zukünftig bei jedem User ist, wird der CSS 1. unendlich lang und 2. ist es echt nervig, für jeden einzelnen User immer einen extra Eintrag zu machen.

Hab ich beim Code, der den Strich generiert irgendwas falsch gemacht?
Danke schon mal für die Hilfe. <3

Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Probleme beim Einfügen in Gruppen - User bekommen Admin"strich"

Beitrag von Günther am Di 19 März 2013 - 17:14

Hallo,

hast du den Code aus einem meiner Beiträge? Dieses Zeichen ist für den unerwünschten Effekt verantwortlich:
a[href^="/u1"] strong{
border-bottom:1px solid #689989;
}
Unter bestimmten Umständen ist es nötig, aber in deinem Fall nicht. Hier habe ich diesen Code mal gepostet und auch genau erklärt, wann das ^-Zeichen zum Einsatz kommen muss:
http://hilfe.forumieren.com/t35412-benutzernamen-sollen-nicht-fett-sein#232828
@Günther schrieb:Übrigens, weil du danach gefragt hast: Gibt man in einem Attributselektor das ^-Zeichen mit an, hat das diese Folge: Es werden alle Elemente (vor der eckigen Klammer angegeben) mit dem Attribut X (hier: href) angesprochen, wenn der Inhalt des Attributs X mit dem Code zwischen den Anführungszeichen beginnt. Deshalb werden durch diese Zuweisung alle Userlinks angesprochen, da diese immer mit mein-forum.com/u... beginnen. Smile
Dieses Zeichen nimmt man also in den Selektor auf, um (in diesem Fall) alle Usernamen anzusprechen. Genau das möchtest du aber nicht erreichen, sondern du willst nur einen einzelnen Usernamen damit ansprechen - also musst du es entfernen. Wink
Code:
a[href="/u1"] strong {
  border-bottom: 1px solid #689989;
}

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Probleme beim Einfügen in Gruppen - User bekommen Admin"strich"

Beitrag von Gast am Di 19 März 2013 - 17:20

Ohhhhh *facepalm* Ich wusste doch, da war noch was.. >o<

Ich daanke dir Smile <3

Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Probleme beim Einfügen in Gruppen - User bekommen Admin"strich"

Beitrag von Günther am Di 19 März 2013 - 17:20

Bitte, gerne. Smile
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten