Lexi Help
Partner
www.forumieren.com

[phpBB2] Problem mit dem Fixieren der Navigation

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Gast am Sa 16 März 2013 - 16:29

Guten Tag^^
Ich habe folgenden Code bei diesem Forum verwendet, doch leider kann ich keinen Unterschied erkennen.
Bei den Templates sind die nötigen Änderungen angewandt worden und trotzdem scheint das CSS den Banner und die Navigaiton nicht anzusprechen. Woran könnte das liegen?

Edit: Nach mehrmaligem Probieren hat dies zumindest geklpaat, kann gelöscht werden Oo
Edit2: Es ist zum Verrückt werden.... Jetzt ist alles wieder darunter >.< (und das ohne, dass ich was verändert hätte...)

Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 16 März 2013 - 16:40

Hallo,

erstens sehe ich im Quellcode keine entsprechende Veränderung.
Bist du dir sicher, dass du das veränderte Template auch über plus veröffentlicht hast? Überprüfe bitte auch, dass folgende Option gewählt ist:
AB -> Anzeige -> Templates -> Allgemeines
Standard-Templates aktivieren: Nein
Wenn beides in Ordnung ist, dann poste hier bitte mal das gesamte aktuell verwendete Template zwischen zwei code-Tags:
Code:
[code][/code]

Zweitens wird deine CSS-Zuweisung zur Klasse "navifix" gestört, weil du zuvor diese Zeichenkette eingesetzt hast:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#navifix{
...
CSS kennt keine Zeilenumbrüche - wenn du solche Zeichen einsetzt, dann wird der Code folgendermaßen interpretiert:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~#navifix
Deshalb wird die Zuweisung nicht erkannt, wie du dir sicher denken kannst. Wink
Wenn du also Kommentare oder solche Symbole zur Strukturierung/Trennung des CSS verwenden möchtest, dann mache das bitte ausschließlich in Kommentarform:
http://www.css4you.de/wscss/css02.html#comment

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Gast am Sa 16 März 2013 - 16:45

Danke für die schnelle Hilfe =D
Hier wäre das Template:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" id="min-width" lang="{L_LANG_HTML}" xml:lang="{L_LANG_HTML}" {NAMESPACE_FB_LIKE} {NAMESPACE_FB} {NAMESPACE_BBCODE}>
<head>
   <title>{SITENAME_TITLE}{PAGE_TITLE}</title>
   <meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
   <meta http-equiv="content-script-type" content="text/javascript" />
   <meta http-equiv="content-style-type" content="text/css" />
   <!-- BEGIN switch_compat_meta -->
   <meta http-equiv="X-UA-Compatible" content="IE={switch_compat_meta.VERSION}" />
   <!-- END switch_compat_meta -->
   <!-- BEGIN switch_canonical_url -->
   <link rel="canonical" href="{switch_canonical_url.CANONICAL_URL}" />
   <!-- END switch_canonical_url -->
   {META_FAVICO}
   {META}
   {META_FB_LIKE}
   <meta name="title" content="{SITENAME_TITLE}{PAGE_TITLE}" />
   {T_HEAD_STYLESHEET}
   {CSS}
   <link rel="search" type="application/opensearchdescription+xml" href="/improvedsearch.xml" title="{SITENAME}" />
   <link rel="search" type="application/opensearchdescription+xml" href="{URL_BOARD_DIRECTORY}/search/improvedsearch.xml" title="{SEARCH_FORUMS}" />
   <script src="{JQUERY_PATH}" type="text/javascript"></script>
   <script src="{JS_DIR}{L_LANG}.js" type="text/javascript"></script>

   <!-- BEGIN switch_fb_login -->
   <script src="http://connect.facebook.net/{switch_fb_login.FB_LOCAL}/all.js" type="text/javascript"></script>
   <script src="{switch_fb_login.JS_FB_LOGIN}" type="text/javascript"></script>
   <!-- END switch_fb_login -->

   <!-- BEGIN switch_ticker -->
   <link type="text/css" rel="stylesheet" href="{JS_DIR}jquery/ticker/ticker.css" />
   <script src="{JS_DIR}jquery/ticker/ticker.js" type="text/javascript"></script>
   <!-- END switch_ticker -->

   <!-- BEGIN switch_ticker_new -->
   <script src="{JS_DIR}jquery/jcarousel/jquery.jcarousel.js" type="text/javascript"></script>
   <script type="text/javascript">//<![CDATA[
      /* Definir le sens de direction en fonction du panneau admin */
      var tickerDirParam = "{switch_ticker.DIRECTION}";
      var slid_vert = false;
      var auto_dir = 'next';
      var h_perso = parseInt({switch_ticker.HEIGHT});

      switch( tickerDirParam )
      {
         case 'top' :
            slid_vert = true;
            break;

         case 'left':
            break;

         case 'bottom':
            slid_vert = true;
            auto_dir = 'prev';
            break;

         case 'right':
            auto_dir = 'prev';
            break;

         default:
            slid_vert = true;
      }

      $(document).ready(function() {
         var w_cont = $('#fa_ticker_container').width();

         if (w_cont > 0)
         {
            $('#fa_ticker_container').width(w_cont);

            /* Affichage de la liste */
            $('#fa_ticker_content').css('display','block');

            /* Calcul des dimensions du conteneur et des elements */
            var width_max = $('ul#fa_ticker_content').width();
            var width_item = Math.floor(width_max / {switch_ticker.SIZE});
            var height_max = h_perso;

            /* Calcul de la hauteur maximale du conteneur en fonction des elements et de la hauteur personnalisee dans l'admin */
            $('ul#fa_ticker_content li').each( function () {
               if ($(this).height() > height_max)
               {
                  height_max = $(this).height();
               }
            } );

            /* Redimensionnement des elements et des images trop larges */
            $('ul#fa_ticker_content li').width(width_item).height(height_max).find('img').each(function () {
               if ($(this).width() > width_item)
               {
               var ratio      = $(this).width() / width_item;
               var new_height = Math.round($(this).height() / ratio);
               $(this).height(new_height).width(width_item);
               }
            });

            /* Redimensionnement et centrage du conteneur en mode vertical */
            if (slid_vert)
            {
               $('ul#fa_ticker_content').width(width_item).height(height_max).css('marginLeft','auto').css('marginRight','auto');
            }

            /* Initialisation du caroussel */
            $('#fa_ticker_content').jcarousel({
                  vertical: slid_vert,
               wrap: 'circular',
               auto: {switch_ticker.STOP_TIME},
               auto_direction: auto_dir,
            scroll: 1,
            size: {switch_ticker.SIZE},
            height_max: height_max,
            animation: {switch_ticker.SPEED}
            });
         }
         else
         {
            $('ul#fa_ticker_content li:not(:first)').css('display','none');
            $('ul#fa_ticker_content li:first').css('list-style','none').css('text-align','center');
         }
      });
   //]]>
   </script>
   <!-- END switch_ticker_new -->

   <script type="text/javascript">//<![CDATA[
   $(document).ready(function(){
      <!-- BEGIN switch_enable_pm_popup -->
         pm = window.open('{U_PRIVATEMSGS_POPUP}', '_faprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');
         pm.focus();
      <!-- END switch_enable_pm_popup -->
      <!-- BEGIN switch_report_popup -->
         report = window.open('{switch_report_popup.U_REPORT_POPUP}', '_phpbbreport', 'HEIGHT={switch_report_popup.S_HEIGHT},resizable=yes,scrollbars=no,WIDTH={switch_report_popup.S_WIDTH}');
         report.focus();
      <!-- END switch_report_popup -->
      <!-- BEGIN switch_ticker -->
         ticker_start({switch_ticker.HEIGHT}, {switch_ticker.SPACING}, {switch_ticker.SPEED}, '{switch_ticker.DIRECTION}', {switch_ticker.STOP_TIME});
      <!-- END switch_ticker -->
   });

   <!-- BEGIN switch_login_popup -->
      var logInPopUpLeft, logInPopUpTop, logInPopUpWidth = {LOGIN_POPUP_WIDTH}, logInPopUpHeight = {LOGIN_POPUP_HEIGHT}, logInBackgroundResize = true, logInBackgroundClass = false;
   <!-- END switch_login_popup -->

   <!-- BEGIN switch_login_popup -->
   $(document).ready( function() {
      $(window).resize(function() {
         var windowWidth = document.documentElement.clientWidth;
         var popupWidth = $("#login_popup").width();
         var mypopup = $("#login_popup");

         $("#login_popup").css({
         "left": windowWidth/2 - popupWidth/2
            });
      });
   });
   <!-- END switch_login_popup -->
   //]]>
   </script>
   {GREETING_POPUP}
   <!-- BEGIN switch_ticker_new -->
   <style>
   .jcarousel-skin-tango .jcarousel-item {
      text-align:center;
      width: 10px;
   }

   .jcarousel-skin-tango .jcarousel-item-horizontal {
      margin-right: {switch_ticker.SPACING}px;
   }

   .jcarousel-skin-tango .jcarousel-item-vertical {
      margin-bottom: {switch_ticker.SPACING}px;
   }
   </style>
   <!-- END switch_ticker_new -->
   {HOSTING_JS}
   <!-- BEGIN google_analytics_code -->
   <script type="text/javascript">
   //<![CDATA[
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', '{G_ANALYTICS_ID}']);
    _gaq.push(['_trackPageview']);
   _gaq.push(['_trackPageLoadTime']);

   <!-- BEGIN google_analytics_code_bis -->
   _gaq.push(['b._setAccount', '{G_ANALYTICS_ID_BIS}']);
   _gaq.push(['b._trackPageview']);
   <!-- END google_analytics_code_bis -->

    (function() {
      var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
      ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
   //]]>
   </script>
   <!-- END google_analytics_code -->
</head>
<body background="{T_BODY_BACKGROUND}" bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">
   <!-- BEGIN hitskin_preview -->
   <div id="hitskin_preview" style="display: block;">
      <h1><img src="http://illiweb.com/fa/hitskin/hitskin_logo.png" alt="" /> Hit<em>skin</em>.com</h1>
      <div class="content">
         <p>
            {hitskin_preview.L_THEME_SITE_PREVIEW}
            <br />
            <span>{hitskin_preview.U_INSTALL_THEME}<a href="http://{hitskin_preview.U_RETURN_THEME}">{hitskin_preview.L_RETURN_THEME}</a></span>
         </p>
      </div>
   </div>
   <!-- END hitskin_preview -->

   <!-- BEGIN switch_login_popup -->
   <div id="login_popup">
      <table class="forumline" width="{LOGIN_POPUP_WIDTH}" height="{LOGIN_POPUP_HEIGHT}" border="0" cellspacing="1" cellpadding="0">
         <tr height="25">
            <td class="catLeft">
               <span class="genmed module-title">{SITENAME}</span>
            </td>
         </tr>
         <tr height="{LOGIN_POPUP_MSG_HEIGHT}">
            <td class="row1" align="left" valign="top">
               <div id="login_popup_buttons">
                  <form action="{S_LOGIN_ACTION}" method="get">
                     <input type="submit" class="mainoption" value="{L_LOGIN}" />
                     <input type="button" class="mainoption" value="{L_REGISTER}" onclick="parent.location='{U_REGISTER}';" />
                     <input id="login_popup_close" type="button" class="button" value="{L_DONT_DISPLAY_AGAIN}" />
                  </form>
               </div>
               <span class="genmed">{LOGIN_POPUP_MSG}</span>
            </td>
         </tr>
      </table>
   </div>
   <!-- END switch_login_popup -->

   <a name="top"></a>
   {JAVASCRIPT}

   <table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
      <tr>
         <td class="bodyline">
            <table id="logofix" width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_left -->
                  <td align="center" width="100%" valign="middle">
                     <!-- BEGIN switch_logo_center -->
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                     <br />
                     <!-- END switch_logo_center -->
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />&nbsp; </span>
                  </td>
                  <!-- BEGIN switch_logo_right -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_right -->
               </tr>
            </table>

            <table id="navifix" cellspacing="0" cellpadding="0" border="0" align="{MENU_POSITION}">
               <tr>
                  <td align="{MENU_POSITION}"{MENU_NOWRAP}>{GENERATED_NAV_BAR}</td>
               </tr>
            </table>

            <div style="clear: both;"></div>

            <!-- BEGIN switch_ticker_new -->
            <div id="fa_ticker_block" style="margin-top:4px;margin-bottom:4px;">
               <table width="100%" border="0" cellspacing="0" cellpadding="0" class="forumline">
                  <tr>
                     <td {CLASS_TABLE_TYPE} align="left" class="row1">
                        <div id="fa_ticker_container">
                           <ul id="fa_ticker_content" class="jcarousel-skin-tango" style="display:none;">
                              <!-- BEGIN ticker_row -->
                              <li>{switch_ticker.ticker_row.ELEMENT}</li>
                              <!-- END ticker_row -->
                           </ul>
                        </div>
                     </td>
                  </tr>
               </table>
            </div>
            <!-- END switch_ticker_new -->

            <!-- BEGIN switch_ticker -->
            <div id="fa_ticker_block" style="margin-top:4px;margin-bottom:4px;">
               <table width="100%" border="0" cellspacing="0" cellpadding="0" class="forumline">
                  <tr>
                     <td {CLASS_TABLE_TYPE} align="left" class="row1">
                        <div id="fa_ticker_container">
                           <div id="fa_ticker" style="height:{switch_ticker.HEIGHT}px;">
                              <div class="fa_ticker_content">
                                 <!-- BEGIN ticker_row -->
                                 <div>{switch_ticker.ticker_row.ELEMENT}</div>
                                 <!-- END ticker_row -->
                              </div>
                           </div>
                        </div>
                     </td>
                  </tr>
               </table>
            </div>
            <!-- END switch_ticker -->

            <div id="page-body">
               <div id="{ID_CONTENT_CONTAINER}"{CLASS_CONTENT_CONTAINER}>
                  <table cellpadding="0" cellspacing="0" width="100%" class="three-col">
                     <tbody>
                        <tr>
                           <td valign="top" width="{C1SIZE}">
                              <div id="{ID_LEFT}">
                                 <!-- BEGIN giefmod_index1 -->
                                 {giefmod_index1.MODVAR}
                                    <!-- BEGIN saut -->
                                    <div style="height:{SPACE_ROW}px"></div>
                                    <!-- END saut -->
                                 <!-- END giefmod_index1 -->
                              </div>
                           </td>
                           <td valign="top" width="100%">
<!-- BEGIN html_validation -->
                           </td>
                        </tr>
                     </tbody>
                  </table>
               </div>
            </div>
         </td>
      </tr>
   </table>
</body>
</html>
<!-- END html_validation -->


Und ja, ich habe beides überprüft, sowohl die Einstellung als auch, ob ich das Plus vergessen habe. Meine ~~~~ habe ich jetzt vorerst entfernt und werde dann später einen Kommentar setzen.

LG

Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 16 März 2013 - 16:54

Bitte. Smile
Bist du dir eigentlich sicher, dass eine fixierte Navigation in Verbindung mit der ebenfalls fixierten Toolbar überhaupt gut aussieht? Wenn du das aber meinst, dann musst du zumindest dort im CSS-Code noch einen Abstand vom Seitenkopf definieren, damit die Navigation dann nicht von der Toolbar überdeckt wird:
#navifix{
height: 25px;
left: 0;
position: fixed;
top: 30px;
width: 100%;
z-index: 100;
}
Dann noch ein Hinweis: Du hast im Template und CSS auch die Änderung zum Fixieren des Logos (logofix) durchgeführt. Du willst dein Logo aber nicht tatsächlich auch mitscrollend fixieren, oder?
Der Teil von Zuckerpuppes Beitrag, der sich auf "logofix" bezieht, darf nicht durchgeführt werden, wenn man nur die Navigation fixieren will. Das solltest du also wieder entfernen. Wink

Wenn du sagst, dass das Template korrekt veröffentlicht wurde, dann könnte hier ein kleines technisches Problem bestehen. Darf ich mir das mal vor Ort selbst ansehen? Wenn das für dich in Ordnung ist, möchte ich dich darum bitten, mir per PN deine Logindaten zuzusenden (vorher und nachher bitte verändern).

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Gast am Sa 16 März 2013 - 17:02

Nunja, um ehrlich zu sein, ist mir diese Toolbar noch recht neu, da ich die bisher noch nirgends gesehen habe. Missen möchte ich sie aber auch nicht. Eigentlich wollte ich dann anschliessend auch den Befehl zum Fixieren rausnehmen und habe das mit dem Banner auch gemacht, um zu sehen, wie das Ganze überhaupt aussieht. Dann habe ich aber eben gemerkt, dass ds Forum gar nicht reagiert^^'

Und ja, ich schicke dir grade die PN ;D

Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 16 März 2013 - 17:26

Alles klar. Ob du diese Änderung nun tatsächlich belassen willst oder nicht, kannst du ja noch entscheiden.

Tatsache ist aber, dass hier ein technisches Problem bei deinem Forum vorliegt. Die Templateänderung wird, wenn man das Forum mehrmals neulädt, manchmal angezeigt und manchmal nicht.
Wie du siehst, habe ich diesen Thread nach "Techniker benötigt" verschoben, wo du zwei Threads unter diesem einen weiteren findest, in dem ebenfalls dasselbe Problem behandelt wird.

Ich habe deinen Fall ebenfalls gerade an die Technik weitergeleitet und hoffe, dass sich unsere Techniker in nächster Zeit damit auseinandersetzen können.
Da es sich bei deinem betroffenen Forum nur um ein Testforum handelt, denke ich, ist folgender Wunsch für dich kein Problem: Bitte belasse dieses Forum komplett unverändert (keine Einstellungs-/Templateänderungen etc.), bis ich mich hier wieder mit einer Rückmeldung aus der Technik melden kann. Idea
Das ist wichtig, damit der aktuelle Zustand beibehalten wird und die Techniker das Problem genau so sehen, wie ich es gemeldet habe.

Ist das für dich in Ordnung?
Ich möchte dich neben dem Unverändertlassen dieses Testforums außerdem darum bitten, deine Logindaten vorerst ebenfalls so zu belassen, damit ich mich ggf. erneut einloggen kann, wenn das im Laufe der Problemlösung nötig sein sollte.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Gast am Sa 16 März 2013 - 17:38

Ist gut, ich habe verstanden und werde warten.
Der neue Style kann ja sowieso noch warten und dann werde ich halt ein anderes Mal daran herumbasteln ;D
Das mit den Logindaten ist ebenfalls kein Problem und nur kein Stress.


Gast
Gast


Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 16 März 2013 - 17:41

Vielen Dank für dein Verständnis und dass du meinem Wunsch nachkommst. top

Ich hoffe, dass wir bei diesem Problem bald weiterkommen.
Inzwischen kann ich dir auch vorschlagen, dass du dir gerne ein weiteres Testforum eröffnest, wenn du an einem neuen Style arbeiten möchtest. Das ist kein Problem.

Danke und ein schönes Restwochenende! Smile
Sobald ich etwas Neues hierzu erfahre, werde ich mich hier wieder melden.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am So 21 Apr 2013 - 17:21

Hallo Moonangel,

bei deinem Forum http://darklight.forumieren.com/ ist mir gerade dasselbe Problem aufgefallen, das hier in diesem Thread und auch dort schon beschrieben wurde:
[phpBB2] Forum verändert sich beim aktualisieren

Wenn man dein Forum mehrmals neulädt, sieht man manchmal eine Anzeige mit korrektem Template:

Und manchmal mit dem fehlerhaften Template, das du früher hattest, nun aber eigentlich wieder ausgebessert hättest:


Dein Forum wird also nach jedem Aktualisieren manchmal mit dem aktuellen, fehlerfreien Template und manchmal mit dem alten, mittlerweile nicht mehr aktiven und fehlerhaften Template angezeigt.
Siehst du das?

Ich möchte dich deshalb um dasselbe bitten, worum ich auch die anderen Betroffenen gebeten habe, damit sich unsere Techniker dein Forum in diesem Zustand ansehen können:
@Günther schrieb:Tatsache ist aber, dass hier ein technisches Problem bei deinem Forum vorliegt. Die Templateänderung wird, wenn man das Forum mehrmals neulädt, manchmal angezeigt und manchmal nicht.
Wie du siehst, habe ich diesen Thread nach "Techniker benötigt" verschoben, wo du zwei Threads unter diesem einen weiteren findest, in dem ebenfalls dasselbe Problem behandelt wird.

Ich habe deinen Fall ebenfalls gerade an die Technik weitergeleitet und hoffe, dass sich unsere Techniker in nächster Zeit damit auseinandersetzen können.
Da es sich bei deinem betroffenen Forum nur um ein Testforum handelt, denke ich, ist folgender Wunsch für dich kein Problem: Bitte belasse dieses Forum komplett unverändert (keine Einstellungs-/Templateänderungen etc.), bis ich mich hier wieder mit einer Rückmeldung aus der Technik melden kann. Idea
Das ist wichtig, damit der aktuelle Zustand beibehalten wird und die Techniker das Problem genau so sehen, wie ich es gemeldet habe.
Ist das für dich ebenfalls in Ordnung, kannst du dieses Forum komplett unverändert belassen, bis du hier von mir eine Rückmeldung erhältst? Kann ich mich darauf verlassen? Smile

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Moonangel am So 21 Apr 2013 - 17:32

Ja da ich jetzt über die Woche sowieso im Internat bin (deswegen können Antworten manchmal etwas später kommen) ist das nicht so schlimm und das Forum ist momentan ein Testforum, sobald es komplett fertig ist wird es auch zum Forum aber das dauert ja noch.
Ich habe eine Vermutung will aber nicht weiter rumbasteln wie ich es versprochen habe aber ich stelle meine Vermutung jetzt mal als Frage:
Kann es sein das die Templates "Startseite" und "Wer ist online?" irgendwie ineinander geraten sind und sich das deswegen immer wieder verschiebt?

Lg Moon

Moonangel
Lehrling
Lehrling

Weiblich Beiträge : 134
Anmeldedatum : 20.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am So 21 Apr 2013 - 17:35

Alles klar, danke! top
@Moonangel schrieb:Kann es sein das die Templates "Startseite" und "Wer ist online?" irgendwie ineinander geraten sind und sich das deswegen immer wieder verschiebt?
Nein, das ist nicht die Ursache. Wink Du siehst über dir einen anderen User, der nur eine sehr kleine Templateänderung gemacht hatte, die kaum der Rede wert war. Trotzdem trat auch bei ihm dieses Problem auf.
Offensichtlich kann es vorkommen, dass bei manchen Foren beim Neuladen nicht nur die aktuelle Templateversion verwendet wird, sondern auch ältere Templateversionen, die derzeit nicht mehr eingesetzt sind.

Das hat nichts mit den Templatebearbeitungen an sich zu tun, sondern ist ein technisches Problem auf unserer Seite.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Moonangel am So 21 Apr 2013 - 17:39

Ah ok dann weiß ich Bescheid, darf ich auch keine neuen Foren einfügen? Kategorien? Beiträge? also praktisch jetzt einfach garnichts machen oder kann ich das schon machen?

Moonangel
Lehrling
Lehrling

Weiblich Beiträge : 134
Anmeldedatum : 20.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am So 21 Apr 2013 - 17:44

Wenn es für dich bei diesem Testforum in Ordnung ist, wäre es am besten, wenn du erstmal gar nicht daran arbeiten würdest. Möchtest du aber gerne wenigstens Foren/Themen etc. erstellen, dann bitte ich dich zumindest, an den Templates nichts zu verändern.
Wenigstens die Templates müssen wirklich unberührt bleiben, damit die Techniker das Problem dann auch genau so sehen, wie ich es gerade gemeldet habe.

Übrigens werde ich in der nächsten Woche dazu leider noch keine Rückmeldung erhalten können, sondern erst in der Woche darauf wieder.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Moonangel am So 21 Apr 2013 - 17:47

Ok dann habe ich wenigstens eine kleine Beschäftigung Wink

Danke für alles! top

Moonangel
Lehrling
Lehrling

Weiblich Beiträge : 134
Anmeldedatum : 20.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am So 21 Apr 2013 - 17:50

Bitte und dir danke für die Mitarbeit. Smile
Wie gesagt kann sich in der übernächsten Woche ein Techniker das Forum ansehen und ich melde mich wieder bei dir, wenn es eine Rückmeldung gibt, wie wir/du weiter vorgehen. Bis dahin bitte ich um etwas Geduld.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Moonangel am So 21 Apr 2013 - 17:54

Könnten Sie mir dann bitte hier eine PN schreiben. Mein Handy Internet ist ziemlich langsam und dann kann ich schon sehen ob sich was getan hat

Lg

Moonangel
Lehrling
Lehrling

Weiblich Beiträge : 134
Anmeldedatum : 20.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am So 21 Apr 2013 - 17:56

Wenn ich mich hier wieder mit einer Rückmeldung gemeldet habe, kann ich dir gleichzeitig noch einen kurzen Hinweis per PN senden, dass du in diesen Thread kommen solltest. Kein Problem. Wink

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Template funktioniert nicht

Beitrag von Schattenspiel am Sa 27 Apr 2013 - 18:19

Ich hab bei meinen Index /Startseite, die Forum Übersicht verändert also das Template so das man nur die Neuste Beiträge geschrieben habt sieht und den Rest nicht mehr, aber irgendwie wechselt das immer wieder beim aktuallisieren. Manchmal ist das neue da und manchmal nicht e.e


könnt ihr mir bitte helfen? :3

Schattenspiel
Neuling
Neuling

Beiträge : 3
Anmeldedatum : 27.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 27 Apr 2013 - 18:24

Hallo,

dieses Problem ist uns bereits bekannt. Lies dir bitte diesen beiden Threads durch:
[phpBB2] Forum verändert sich beim aktualisieren
[phpBB2] Problem mit dem Fixieren der Navigation

Ich werde deine Situation ebenfalls an unsere Technik weitergeben. Deshalb bitte ich dich um dasselbe, worum ich auch die anderen Betroffenen gebeten habe: Vorerst keine Templateveränderungen mehr vorzunehmen, bis ich mich wieder mit einer Rückmeldung bei dir melden kann. Ist das für dich in Ordnung? Question

Liebe Grüße
Günther

Ich werde diesen Thread dann einem der beiden verlinkten Sammelthreads hinzufügen. Wink

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Schattenspiel am Sa 27 Apr 2013 - 18:29

Ja ist oke, eigentlich wollte ich es heute zu Ende machen, aber ist oke (:

&' hier sind die Screenhots Smile

http://img3.fotos-hochladen.net/uploads/unbenann1tp01isgoa2t.png
http://img3.fotos-hochladen.net/uploads/unbenanntrdc9fhx30e.png

Schattenspiel
Neuling
Neuling

Beiträge : 3
Anmeldedatum : 27.04.13

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Sa 27 Apr 2013 - 18:33

Sehr gut, danke! top
Ich habe deinen Fall bereits weitergeleitet und melde mich hier wieder, sobald ich eine Rückmeldung erhalte. Smile

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Di 30 Apr 2013 - 17:25

@ Faru, Moonangel, Schattenspiel:

Wie ich in euren Forum überprüft habe, tritt das Problem dort nicht mehr auf.
Ihr könnt die Foren nun mehrmals neuladen und werdet sehen, dass sie immer in den aktuellsten Templateversionen angezeigt werden. Smile

Arrow Ich habe aus der Technik zudem die Rückmeldung erhalten, dass sich das Problem in Arbeit befindet. Sollte es dennoch wieder einmal bei euch oder bei einem anderen Forum auftreten, sollte folgende vorübergehende Lösung angewandt werden:
Das betreffende Template muss erneut über zahnrad geöffnet und mit Absenden abgesandt werden - und zwar mehrmals, bis das Problem nicht mehr auftritt.

Die Ursache besteht darin, dass die veränderten Templates manchmal nicht korrekt abgesandt werden. Werden sie anschließend erneut/mehrmals abgesandt, bis das Problem nicht mehr auftritt, hat das Absenden dann funktioniert.
Solltet ihr also wieder einmal vor diesem Problem stehen, geht bitte so vor und meldet das Problem nur hier, falls diese Lösung doch nicht wirken sollte. Unsere Techniker arbeiten in der Zwischenzeit daran, das Problem vollständig zu beheben.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Moonangel am Mi 1 Mai 2013 - 18:49

Ok dann weiß ich bescheid! Wink Gilt das auch für HTML Seiten? Ich habe einen Namensgenerator erstellt aber die ä,ü,ö werden nicht richtig angezeigt! Hat das auch damit zu tun oder ist das was anderes? Wenn ja erstelle ich ein neues Thema aber es kann ja sein...

Danke für die Mühe! Very Happy

Glg Moon

Moonangel
Lehrling
Lehrling

Weiblich Beiträge : 134
Anmeldedatum : 20.03.12

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Mi 1 Mai 2013 - 18:53

Nein, das gilt ausschließlich für die Templates (nicht für HTML-Seiten).
Zu deinem Problem wirst du aber über die Suche fündig und musst dazu keinen neuen Thread erstellen:
http://hilfe.forumieren.com/search?search_keywords=umlaute
Bereits im 1. Suchergebnis habe ich das gerade kürzlich erklärt.

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2] Problem mit dem Fixieren der Navigation

Beitrag von Günther am Do 2 Mai 2013 - 16:44

Ich habe gute Nachrichten: Unsere Technik hat mir soeben gemeldet, dass das Problem nun behoben sein sollte. Smile

Damit ist die vorübergehende Lösung, die ich vorgestern beschrieben habe (Templates mehrmals absenden) wieder hinfällig und nicht mehr aktuell.

Arrow Sollte das Problem erneut auftreten, dass sich euer Forum bei mehrmaligem Neuladen verändert, meldet euch bitte umgehend hier. Danke. Wink

Edit 10.5.
Da das Problem offensichtlich behoben sein sollte, schließe ich hier ab. Sollte es dennoch wieder einmal auftreten, bitte eine PN an mich und ich öffne hier wieder.
-closed-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten