Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 19:18

» [Update] Neues Theme der mobilen Version V2
von Tierfreund-97 Gestern um 17:05

» Begriff : "merken"
von Ray Gestern um 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Gestern um 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

Partner
free forum

Der Mauszeiger funktioniert nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Der Mauszeiger funktioniert nicht

Beitrag von Watery98 am Sa 24 Nov 2012 - 14:04

Hallo erstmal Wink ,
Ich wollte für ein Forum den Mauszeiger ändern in diesen Mogry:
Die URL:
Code:
[URL=http://www.image-load.net/][IMG]http://www.image-load.net/users/public/images/K2AOjMZlg4.gif[/IMG][/URL]

Ich hab auch schon HIER nachgesehen und den Code kopiert und eingesetzt mit der URL des Bildes. Nur es funzt net. Entweder ich hab es irgendwo falsch reinkopiert oder ich mache irgendwas falsch.

Hier der Code(Für den Mauszeiger):

Der Code:
Code:
 <script type="text/javascript">
    /*
    Simple Image Trail script- By JavaScriptKit.com
    Visit http://www.javascriptkit.com for this script and more
    This notice must stay intact
    */
    var trailimage=["<a href="http://www.image-load.net/" class="postlink" target="_blank" rel="nofollow"><img src="http://www.image-load.net/users/public/images/K2AOjMZlg4.gif" border="0" alt="" /></a>", 64,69] //image path, plus width and height
    var offsetfrommouse=[10,20] //image x,y offsets from cursor position in pixels. Enter 0,0 for no offset
    var displayduration=0 //duration in seconds image should remain visible. 0 for always.
    if (document.getElementById || document.all)
    document.write('<div id="trailimageid"style="position:absolute;visibility:visible;left:0px;top:0px;width:1px;height:1px"><img src="'+trailimage[0]+'" border="0" width="'+trailimage[1]+'px" height="'+trailimage[2]+'px" alt=""></div>')
    function gettrailobj(){
    if (document.getElementById)
    return document.getElementById("trailimageid").style
    else if (document.all)
    return document.all.trailimagid.style
    }
    function truebody(){
    return (document.compatMode!="BackCompat")? document.documentElement : document.body
    }
    function hidetrail(){
    gettrailobj().visibility="hidden"
    document.onmousemove=""
    }
    function followmouse(e){
    var xcoord=offsetfrommouse[0]
    var ycoord=offsetfrommouse[1]
    if (typeof e != "undefined"){
    xcoord+=e.pageX
    ycoord+=e.pageY
    }
    else if (typeof window.event !="undefined"){
    xcoord+=truebody().scrollLeft+event.clientX
    ycoord+=truebody().scrollTop+event.clientY
    }
    var docwidth=document.all? truebody().scrollLeft+truebody().clientWidth :
    pageXOffset+window.innerWidth-15
    var docheight=document.all? Math.max(truebody().scrollHeight, truebody().clientHeight) :
    Math.max(document.body.offsetHeight, window.innerHeight)
    if (xcoord+trailimage[1]+3>docwidth || ycoord+trailimage[2]> docheight)
    gettrailobj().display="none"
    else
    gettrailobj().display=""
    gettrailobj().left=xcoord+"px"
    gettrailobj().top=ycoord+"px"
    }
    document.onmousemove=followmouse
    if (displayduration>0)
    setTimeout("hidetrail()", displayduration*1000)
    </script>

Wie gesagt es funktioniert nicht. Entweder mache ich es falsch oder da stimmt was nicht. Ich habe auch das befolgt was HIER stand.

Ich bedanke mich schonmal im Vorraus Wink

LG Watery98 Wink

Watery98
Neuling
Neuling

Beiträge : 4
Anmeldedatum : 01.11.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Der Mauszeiger funktioniert nicht

Beitrag von Günther am Sa 24 Nov 2012 - 14:12

Hallo,
Hallo und herzlich Willkommen,

du bist neu hier im Forum.
Mache dich bitte zunächst mit den hiesigen Forenregeln vertraut.

Viele Antworten findest du auch in der Wissenssammlung "Lexi Help" Exclamation

Klick einfach auf das Bild Arrow

Solltest du keine für dich passende Antwort in der Suchfunktion (Link in der Navigation) oder bei "Lexi Help" gefunden haben, dann eröffne pro Frage ein neues Thema.

Ich wünsche dir hier im Forum viele Informationen und guten Erfolg mit deinem Forum top
Es ist gut, dass du unsere Suche verwendest hast, aber leider hast du nicht die optimale Lösung gefunden. Hier ist es nicht angebracht, mit einem Script zu arbeiten. Stattdessen kannst du den Cursor ganz einfach über dein persönliches CSS einsetzen.
Dazu füge in dein CSS-Stylesheet unter
AB -> Anzeige -> Bilder & Farben -> Farben -> Reiter "CSS Stylesheet"
folgenden Code ein:
Code:
HTML,BODY{
    cursor: url("http://www.image-load.net/users/public/images/K2AOjMZlg4.gif"), auto;
}
Du musst außerdem immer darauf achten, bei Grafiken nur den Direktlink zur Grafik zu verwenden: http://www.image-load.net/users/public/images/K2AOjMZlg4.gif
Oben hast du auch noch ein Linkelement mitverwendet, was nicht richtig ist.

Allerdings ist die verwendete Grafik nicht gerade optimal...
Sie beseitzt nämlich keinen transparenten Hintergrund, sondern einen weißen:

Dieser weiße Hintergrund würde dann immer mit angezeigt, was nicht gut aussehen würde. Deshalb solltest du dich nach einer geeigneteren Grafik umsehen oder versuchen, den Hintergrund dieser Grafik transparent zu machen. Wink

Dazu kommt auch noch, dass verschiedene Browser jeweils andere Cursorformate benötigen. Um sowohl unter IE als auch FF ein gutes Ergebnis zu erhalten, sollten Cursors immer zusätzlich auch als ani-Datei angegeben werden. Siehe:
http://www.css4you.de/cursor.html

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Der Mauszeiger funktioniert nicht

Beitrag von Watery98 am Sa 24 Nov 2012 - 14:21

Achso^^

Vielen Dank für die Hilfe Günther! VIEEELLLEEEN DANK!!!!
Es Funktioniert sogar^^ Danke nochmal^^

Wink
LG Watery 98 Wink

Watery98
Neuling
Neuling

Beiträge : 4
Anmeldedatum : 01.11.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Der Mauszeiger funktioniert nicht

Beitrag von Günther am Sa 24 Nov 2012 - 14:25

Das freut mich, gerne. Smile
Und wenn du meine Zusatzhinweise bachtest, wirst du ein noch besseres Ergebnis erhalten. Wink

Denke bitte noch daran, das -Icon zu setzen.
-done-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten