Lexi Help
Partner
www.forumieren.com

[phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von talk-about-terra am Di 4 Sep 2012 - 13:32

Hallo
habe in meinem Forum eine Buchempfehlungsseite.
Dort möchte ich zu jedem Buch einen Link von Amazon setzen.
Wenn ich aber nun den Thread bearbeite und den Link einsetze sehe ich diesen zwar in der Vorschau aber leider nicht mehr wenn ich das Thema absende.

Hier der Link von Amazon:
<iframe src="http://rcm-de.amazon.de/e/cm?t=wwwtalkaboutt-21&o=3&p=8&l=as1&asins=3936180172&ref=tf_til&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

soll auf diese Seite eingebunden werden
http://www.talk-about-terra.com/post?p=8&mode=editpost

Danke für eure Antworten und Tipps


Zuletzt von talk-about-terra am Di 4 Sep 2012 - 14:56 bearbeitet, insgesamt 1 mal bearbeitet

talk-about-terra
Lehrling
Lehrling

Weiblich Beiträge : 78
Anmeldedatum : 30.08.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von Günther am Di 4 Sep 2012 - 13:37

Hallo,

ich nehme an, du hast nicht in deinem Forum und Profil HTML aktiviert?
Überprüfe bitte nochmal, ob du das an beiden Stellen gemacht hast.

Wenn nämlich HTML im Profil nicht zugelassen wird, wird dir der Code zwar in der Vorschau umgewandelt angezeigt, allerdings nach dem Absenden nicht mehr. Wink

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von talk-about-terra am Di 4 Sep 2012 - 14:15

Danke
habe die Einstellungen geändert, aber es geht nur ein Link
der erste bzw. dann der zweite in dem Thread dann nicht mehr Sad
Und sobald ich den Thread wieder bearbeiten möchte sind die Links auch wieder verschwunden


Zuletzt von talk-about-terra am Di 4 Sep 2012 - 14:18 bearbeitet, insgesamt 1 mal bearbeitet

talk-about-terra
Lehrling
Lehrling

Weiblich Beiträge : 78
Anmeldedatum : 30.08.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von Günther am Di 4 Sep 2012 - 14:17

Kannst du mir bitte beide Codes geben, die du von Amazon erhalten hast? Und auch noch den Link zum Thread, in den du sie beide einsetzen möchtest?

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von talk-about-terra am Di 4 Sep 2012 - 14:35

Natürlich
hier die beiden Codes
<iframe src="http://rcm-de.amazon.de/e/cm?t=wwwtalkaboutt-21&o=3&p=8&l=as1&asins=3936180172&ref=tf_til&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

<iframe src="http://rcm-de.amazon.de/e/cm?t=wwwtalkaboutt-21&o=3&p=8&l=as1&asins=393158738X&ref=tf_til&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

und hier der Link für den Thread
http://www.talk-about-terra.com/t8-leopardgecko-buchtipp

Nochmals Danke für deine Mühe

talk-about-terra
Lehrling
Lehrling

Weiblich Beiträge : 78
Anmeldedatum : 30.08.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von Günther am Di 4 Sep 2012 - 14:45

Bitte. Smile

Die beiden Codes funktionieren im Normalfall bestens miteinander, wie du in meinem Testforum sehen kannst:

Im verlinkten Thread sehe ich, dass der zweite eingesetzte HTML-Code nicht vollständig vorhanden ist.

Es gibt mehrere Gründe, weshalb bei dir dieser Fehler möglich ist:
1) Du hast beim Bearbeiten einen Fehler gemacht bzw. den neuen Code nicht vollständig eingesetzt
2) Du hast statt des normalen Editors den WYSIWYG-Editor verwendet (was du daran erkennen kannst: :editor2:)
3) Teilweise führt das Verwenden der Vorschau zu Veränderungen am HTML-Code, sodass dieser nicht korrekt übernommen wird

Du solltest deshalb folgendes Vorgehen versuchen: Du editierst den Beitrag, stellst sicher, dass du nicht im WYSIWYG-Editor bist, und löschst den Inhalt heraus. Anschließend fügst du diese beiden Codes genau so in das Eingabefenster ein:
Code:
<iframe src="http://rcm-de.amazon.de/e/cm?t=wwwtalkaboutt-21&o=3&p=8&l=as1&asins=3936180172&ref=tf_til&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

<iframe src="http://rcm-de.amazon.de/e/cm?t=wwwtalkaboutt-21&o=3&p=8&l=as1&asins=393158738X&ref=tf_til&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>
Dann sendest du den Beitrag direkt ab, ohne ihn in der Vorschau anzusehen.

Diese Vorgehensweise solltest du in derartigen Fällen immer anwenden.
Jetzt sollte alles klappen, oder? Smile

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von talk-about-terra am Di 4 Sep 2012 - 14:56

Jaaa Danke

talk-about-terra
Lehrling
Lehrling

Weiblich Beiträge : 78
Anmeldedatum : 30.08.10

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: [phpBB2][phpBB2]Amazon Link wird nicht angezeigt

Beitrag von Günther am Di 4 Sep 2012 - 14:58

Bitte, gerne. Smile

Ein kleiner Hinweis noch, weil es bei dir im Forum zwischenzeitlich so ausgesehen hat:

Das passiert, wenn du die Codes im WYSIWYG-Modus einfügst. Dieser ist bei dir nicht als Standard eingestellt, sodass du dich beim Beitragsschreiben zuerst im normalen Editor (Codeansicht) befindest. Immer, wenn du HTML einbeziehst, solltest du in diesem Editor bleiben und nicht in den WYSIWYG-Modus wechseln. Dann gibt es auch keine Probleme mehr. Wink

-done-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten