Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» [Update] Neues Theme der mobilen Version V2
von inde Mi 28 Sep 2016 - 13:34

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

Partner
free forum

Seitenwechsel Logos wollen nicht erscheinen

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Seitenwechsel Logos wollen nicht erscheinen

Beitrag von HopeWolf am Sa 30 Jun 2012 - 19:52

Hallo,ich habe gerade die funktion ausprobiert wo bei seitenwechsel das logo sich ändert,
aber es erschein nichts!

Hier mein Code:
Code:
while(true){
aleatorio = Math.random();
numero = Math.round(aleatorio * 5);

if (numero == 0){
imagen = "http://i40.tinypic.com/8x1liw.png";
break;}

if (numero == 1){
imagen = "http://i45.tinypic.com/241m1qq.jpg";
break;}

if (numero == 2){
imagen = "http://www.abload.de/img/wolfestzkt5.png";
break;}

if (numero == 3){
imagen = "http://i46.tinypic.com/hrdegi.png";
break;}

if (numero == 4){
imagen = "http://i49.tinypic.com/28uhevk.png";
break;}

if (numero == 5){
imagen = "http://i46.tinypic.com/2dr9oap.png";
break;}



}
document.write('<a href="http://www.wolfmagie.com/" target="_self" ><img src="' + imagen + '" border=0 style="width: 827px; height: 620px"></a>');

und das logo habe ich auch da durch ersetzt:

Code:
http://illiweb.com/fa/empty.gif

ich habe erstmal den code erstellt den habe ich dann in eine HTML seite gespeichert und in die beschreibung das eingefügt:

Code:
<script src=http://www.wolfmagie.com/h2-wechsel-logo></script>

und nur dieser code steht auch in der beschreibung-habe ich vllt. was vergessen oder was falsch gemacht?

Lg


Zuletzt von HopeWolf am Sa 30 Jun 2012 - 20:38 bearbeitet, insgesamt 1 mal bearbeitet

HopeWolf
Lehrling
Lehrling

Beiträge : 114
Anmeldedatum : 03.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Seitenwechsel Logos wollen nicht erscheinen

Beitrag von Günther am Sa 30 Jun 2012 - 19:58

Hallo HopeWolf,

ich habe mir deinen Code angesehen und es sind keine Fehler enthalten. In meinem Testforum funktioniert er außerdem einwandfrei.
Deshalb zunächst eine Bitte: Könntest du von dieser Seite im AB bitte einen Screenshot machen und hier posten
AB -> Allgemeines -> Forum -> Einstellungen
Und auch noch einen von der HTML-Seite in der Bearbeitungsansicht, sodass ich sehen kann, was du dort eingegeben hast.

Liebe Grüße
Günther

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Seitenwechsel Logos wollen nicht erscheinen

Beitrag von HopeWolf am Sa 30 Jun 2012 - 20:09

okay hier ist der screen:

http://i48.tinypic.com/kt2mb.png

HopeWolf
Lehrling
Lehrling

Beiträge : 114
Anmeldedatum : 03.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Seitenwechsel Logos wollen nicht erscheinen

Beitrag von Günther am Sa 30 Jun 2012 - 20:11

Wie ich sehe, hast du die HTML-Seite richtig eingebunden. Ich bin jetzt in den Quelltext dieser Seite gegangen und habe entdeckt, dass du den Code aus deinem Beitrag (der richtig wäre!) nicht vollständig übernommen hast.

Diesen Code hast du eingefügt:
Code:
numero = Math.round(aleatorio * 5);

if (numero == 0){
imagen = "http://i40.tinypic.com/8x1liw.png";
break;}

if (numero == 1){
imagen = "http://i45.tinypic.com/241m1qq.jpg";
break;}

if (numero == 2){
imagen = "http://www.abload.de/img/wolfestzkt5.png";
break;}

if (numero == 3){
imagen = "http://i46.tinypic.com/hrdegi.png";
break;}

if (numero == 4){
imagen = "http://i49.tinypic.com/28uhevk.png";
break;}

if (numero == 5){
imagen = "http://i46.tinypic.com/2dr9oap.png";
break;}



}
document.write('<a href="http://www.wolfmagie.com/" target="_self" ><img src="' + imagen + '" border=0 style="width: 827px; height: 620px"></a>');
Wie du siehst, fehlen die ersten beiden Zeilen:
Code:
while(true){
    aleatorio = Math.random();
Sobald du diese ergänzt hast, funktioniert dein Script ohne Probleme. Wink

Ich möchte dir noch einen wichtigen Hinweis geben: Du lässt deine Logos auf die Größe von 827x620px skalieren bzw. verwendest sehr große Ursprungsgrafiken. Das erzeugt sehr große Bilder, die bei zahlreichen Usern deines Forums lange zum Laden brauchen werden. Bei solchen Grafiken solltest du immer auch an diejenigen denken, die eine langsamere Internetverbindung besitzen. Noch dazu handelt es sich nicht um ein einziges Logo, das nach dem 1. Mal im Cache gespeichert wird, sondern um mehrere, wodurch jedes Mal neu geladen werden muss.
Ich möchte dir nahelegen, kleinere Bildergrößen einzusetzen. Wink

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Seitenwechsel Logos wollen nicht erscheinen

Beitrag von HopeWolf am Sa 30 Jun 2012 - 20:38

danke hat geklappt ^^

HopeWolf
Lehrling
Lehrling

Beiträge : 114
Anmeldedatum : 03.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Seitenwechsel Logos wollen nicht erscheinen

Beitrag von Günther am Sa 30 Jun 2012 - 20:40

Bitte, gern geschehen. Smile
Und über die Größe solltest du wirklich nochmals nachdenken, das wäre mein persönlicher Tipp. Wink
-done-

Günther
Admin a.D.
Admin a.D.

Männlich Beiträge : 15349
Anmeldedatum : 16.07.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten