Lexi Help
Die neuesten Themen
» Entfernen von der Popupleiste
von Bigtuber Heute um 19:20

» [phpBB2] Schriftfarbe nicht vollständig
von Fayé Heute um 16:09

» [Wichtige Information] Meine Tätigkeit in diesem Support. Von #Frank
von #Frank Heute um 13:42

» [Update] Neues Theme der mobilen Version V2
von #Frank Heute um 13:03

» Mobile Ansicht leider Fehlerhaft
von Br0adsw0rd Gestern um 19:31

» [phpBB2] Hintergrund festpinnen
von Fayé Gestern um 16:56

» Mein altes Forum zurückbekommen
von Bigtuber Do 29 Sep 2016 - 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

Partner
free forum

CSS-Problem

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

CSS-Problem

Beitrag von Leonides am Do 19 Apr 2012 - 13:49

Hallo alle zusammen!

Also ich glaube dass ich wieder mal ein Problem mit CSS-Stylesheet habe.

Und zwar, wollte ich den Rahmen des Modules anpassen und hab diesen Teil hier eingefügt:

Code:
  .module {
        border: 2px solid;
    }

Allerdings ändert sich dann nichts am Rahmen.

Ich hab auch schon versucht die Schrift zu ändern, aber da hat sich auch nichts getan. Am Anfang dachte ich ok, vielleicht ist einfach nur meine Eingabe dafür falsch, aber nun denk ich dass ich wohl wieder einen Fehler im CSS habe. o.o Ich hab auch schon alles 3 mal durch geschaut aber den Fehler auch nicht gefunden. V.V Deshalb habe ich mir auch gedacht, dass ich mich an euch wende, mit der Hoffnung dass ihr mir vielleicht bitte helfen könnt. o.o

Vielleicht hilft es euch, wenn ich meine gesamten CSS Eingaben hier poste. o.o

Code:
          #beispiel {
        z-Index:10;
        position:fixed;
        top:0px;
        left:0px;
        width:100%;
        height:25px;
        }

        a.infobox {
        }
        a.infobox:hover {
        }

        a.infobox span {
        visibility:hidden;
        position:absolute;
        }
        a.infobox:hover span, a.infobox:focus span, a.infobox:active span {
        visibility:visible;
        }
     
       


        /*--- Ab hier können die Farben in der Chatbox verändert werden. Dazu das Wort "Farbcode" durch den gewünschten Wert ersetzen (Format #XXXXXX)---*/
        /*Hintergrundfarbe der Chatbox*/

        body.chatbox
        {
              background-color: #000000 ;
        }

        /*Textfarbe im Titel der Chatbox*/

        #chatbox_header .catBottom .cattitle
        {
              color:  #00BFFF ;
        }

        /*Textfarbe der Links im oberen Teil der Chatbox*/

        #chatbox_header .chatbox-options .genmed,
        #chatbox_header .chatbox-options,
        #chatbox_header .chatbox-options a
        {
              color:  #00BFFF  ;
        }

        /*Textfarbe in der Onlineliste (Userliste auf der linken Seite)*/

        #chatbox_members ul li,
        #chatbox_members ul li a
        {
              color:  #ffffff  ;
        }

        /*Hintergrundfarbe im Chat-Stream (Hauptfeld, in dem die Nachrichten angezeigt werden)*/

        .chatbox_row_1,
        .chatbox_row_2,
        .chatbox_row_3,
        .chatbox_row_1 a,
        .chatbox_row_2 a,
        .chatbox_row_3 a
        {
              background-color: #000000 ;
        }

        /*Textfarbe im Chat-Stream (Hauptfeld, in dem die Nachrichten angezeigt werden)*/

        .chatbox_row_1,
        .chatbox_row_2,
        .chatbox_row_3,
        .chatbox_row_1 a,
        .chatbox_row_2 a,
        .chatbox_row_3 a  {
            color: Farbcode;
        }

        /*---Hier endet der Bereich zum Einstellen der Farben in der Chatbox---*/

        #content-container #right
        {
              width: 0px;
        }


        .forumline .quote {
        -moz-border-radius:12px 12px 12px 12px;
        -webkit-border-radius: 12px 12px 12px 12px;
        }


        .quote .gen {
            background-color: #9d759d;
            color: #78026A;
            font-family: Arial;
            font-weight: bolder;
        }


       

        textarea.post{
        background-image: url();
        }


     

            .nav a.nav img{
            max-width: 40px;
            }


            #partner {
            Filter: alpha (opacity = 50);
            -Moz-opacity: 0,5;
            -Khtml-opacity: 0,5;
            opacity: 0.5;
            Opazität: 0,5;
            }
            #partner:hover {
            Filter: alpha (opacity = 100);
            -Moz-opacity: 1,0;
            -Khtml-opacity: 1,0;
            opacity: 1.0;
            Opazität: 1,0;
            }


        div.postbody {
        padding:10px;
        margin: 10px
            background-color: #050C12;
          border-style: solid;
          border-size: 1px;
          border-color: #00BFFF;
            -moz-border-radius: 10px 0px 10px 0px;
            -webkit-border-radius: 10px 10px 10px 10px;
        -moz-box-shadow: 2px 2px 2px 2px #00BFFF;
        }

        div.postbody{
        -style:
        font-family: Times New Roman;
        font-size: 14px;
        color: #ffffff;

        }

        .quote {
            background: url("") no-repeat scroll right bottom #050C12;
  border-radius: 5px 0px 5px 0px;
          border-size: 3px;
          border-color: #00BFFF;
  border-style: solid;
        -moz-box-shadow: 2px 2px 2px #00BFFF;
            font-family: New Times Roman;
            font-size: 14px;
        color:#ffffff;
            padding: 50px;
        }


     

        .bodyline {
            background-image: url("");
        }

        .postprofil {
        font size: center;
        }


        div .code {
            background: url("") no-repeat scroll right bottom #050C12;
  border-radius: 5px 0px 5px 0px;
          border-size: 2px;
          border-color: #00BFFF;
  border-style: dotted;
        -moz-box-shadow: 2px 2px 2px #00BFFF;
            font-family: New Times Roman;
            font-size: 14px;
        color:#ffffff;
            padding: 50px;
        }

        .bodyline {
        -moz-box-shadow: 10px 10px 10px #ffffff;
            color: #126385;
            font-family: New Times Roman;
            font-size: 12px;
            padding: 15px;}

        .forumline{
        -moz-box-shadow: 8px 8px 8px #ffffff;
            color: #126385;
            font-family: New Times Roman;
            font-size: 12px;
            padding: 0px;}

     


        /* Spoiler */
        .spoiler_closed {
          display:block;
          font-family: Verdana,Arial,Helvetica,sans-serif;
          font-size: 14px;
          color: #ffffff;
          line-height: 125%;
          background-color: #050C12;
          border: #00BFFF;
          border-style: dotted;
          border-left-width: 2px;
          border-top-width: 2px;
          border-right-width: 2px;
          border-bottom-width: 2px;
          border-radius: 5px 0px 5px 0px;
        -moz-box-shadow: 3px 3px 3px #00BFFF;
          }
        .spoiler_closed.hidden {
          display:none;
          }
        .spoiler_content {
          display:block;
          font-family: Verdana,Arial,Helvetica,sans-serif;
          font-size: 14px;
          color: #ffffff;
          line-height: 125%;
          background-color: #050C12;
          border: #00BFFF;
          border-style: dotted;
          border-left-width: 2px;
          border-top-width: 2px;
          border-right-width: 2px;
          border-bottom-width: 2px;
          border-radius: 5px 5px 5px 5px;
          padding: 25px;
          background: url("http://www7.pic-upload.de/20.03.12/7eqjose5losy.png") no-repeat scroll right bottom #92e0f9;
          }
        .spoiler_content.hidden {
          display:none;
          }





.box{
  border: 1px dotted #ffffff;
  border-style: dotted;
  border-width: 1px;
          border-radius: 6px 0px 6px 0px;
  display: block;
  background: #000000;
 box-shadow: 0 0 5px  #00BFFF;
      margin: 3px;
    width: auto;
 
}




.forumline {
border-style: dotted;
border-color: #ffffff;
border-width: 2px;
        -moz-border-radius: 5px 0px 5px 0px;
        -webkit-border-radius: 5px 0px 5px 0px;
          -moz-box-shadow: 5px 5px 5px #00BFFF;
        }


.bodyline {
border-style: solid;
border-color: #0BFFF;
border-width: 3px;
        -moz-border-radius: 5px 0px 5px 0px;
        -webkit-border-radius: 5px 0px 5px 0px;
          -moz-box-shadow: 5px 5px 5px #00BFFF;
        }

.postdetails.poster-profile_avatar a img{
  border-style: dotted;
border-color: #ffffff;
border-width: 2px;
        -moz-border-radius: 5px 0px 5px 0px;
        -webkit-border-radius: 5px 0px 5px 0px;
  -moz-box-shadow: 2px 2px 2px #00BFFF}








a.forumlink {
    -moz-transition: all 1s ease 0s;
    border-bottom: 1px solid #00BFFF;
    border-left: 5px solid #00BFFF;
    color: #00BFFF;
    display: block;
    font-family: New Times Roman;
  font-size: 14px;
    font-weight: 700;
    margin-left: 10px;
    padding-left: 10px;
    text-shadow: 1px 1px 1px #000000;
}


     
                .mein_reiter{
                  float: left;
                  padding: 2px 10px;
                  margin-right: 5px;
                  color: #000;
                  background: #fff;
                  border: 1px solid #000;
                  cursor: pointer;
                  margin-bottom: -1px;
                  list-style: none;
                }
                .mein_reiter:hover{
                  background: #b8efa1;
                } 
                .mein_reiter_selected{
                  float: left;
                  padding: 2px 10px;
                  margin-right: 5px;
                  color: #000;
                  background: #fff;
                  border-top: 1px solid #000;
                  border-right: 1px solid #000;
                  border-left: 1px solid #000;
                  border-bottom: 1px solid #fff;
                  cursor: pointer;
                  margin-bottom: -1px;
                  list-style: none;}   
                .clear{
                  clear: both;
                }
                .mein_inhalt{
                  color: #000;
                  background: #fff;
                  border: 1px solid #000;
                  padding: 10px;
                  line-height: normal;
                  font-size: 11px;}
                #meine_inhalte, #meine_reiter{
                  width: 400px;
                  margin: auto;}





.forumline {
margin-top: 20px;}



    .module {
        border: 2px solid;
    }

Hier hätte ich auch noch den Link zum Testforum.

Ich bedanke mich im Vorfeld und wünsche euch noch einen angenehmen Nachmittag.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von LouiXIV am Do 19 Apr 2012 - 14:31

Bin jetzt kein BB2-Fachmann, aber ich glaube .module ist ein Code, der nur bei BB3 funktioniert. Bei BB2 wird das wohl über die Templates geändert.

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am Do 19 Apr 2012 - 14:36

Hallo LouiXIV, danke für deine schnelle Antwort. Smile

Also wenn das nicht mit CSS geht, weiß dann jemand, wie ich das im Template bitte machen könnte? o.o

Das wäre wirklich toll. :3
Danke

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von LouiXIV am Do 19 Apr 2012 - 14:38

also ich nicht ... Wink
Deshalb geb ich hier auch für andere frei

LouiXIV
Kaiser
Kaiser

Männlich Beiträge : 5210
Hinweis : kommt ab und zu aus dem OFF hervor
Anmeldedatum : 22.03.09

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von #Frank am Do 19 Apr 2012 - 14:42

Auch die Module haben bei pbpBB2 eine CSS Class.
Ich kann nur gerade nicht nachsehen.
Du solltest dir den Umgang mit Firebug mal aneignen. Dann müsstest du nicht dauern jemanden Fragen.
Ich kann dir nun nicht sagen, welche Class das ist, weil ich nicht am Rechner bin, aber es ist schon möglich wenn man den richtigen CSS Code hat.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34507
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am Do 19 Apr 2012 - 14:45

Hallo! (:

Über die Templates lässt sich das machen, allerdings musst du eine Menge Templates dafür ändern, weil es kein "einheitliches" Template für alle Module gibt. Ebenso würde sich die Border-Breite dann auch im Portal ändern. Ich weiß nicht, ob das so dein Wunsch wäre, weil ich gesehen habe, dass du im Forum, welches du angegeben hast, auch ein Portal aktiviert.

Die Module lassen sich im Adminbereich unter Anzeige/Templates/Portal finden. Wenn du für alle einen Rand einfügen möchtest, dann kann man das wie folgt machen. Dabei sieht der vorgegebene Anfangscode ungefähr so aus:
Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">

Hinter class=forumline setzt du dann in jedem der Templates die dort angezeigt werden und die du auch im Forum aktiviert hast, folgendes:
Code:
<table class="forumline" style="border: 2px solid;" ...

Du solltest also bei jedem der gewünschen Module den style="" - Teil mit hinzufügen. Allerdings weiß ich - wie gesagt - nicht, ob du das wegen dem Portal so willst. Aber eine andere Möglichkeit gäbe es so nicht, ohne das sich auch die Rahmendicke der restlichen Forenübersicht ändert.

Liebe Grüße Freunde

EDIT: War mal wieder zu langsam mit dem Tippen. Eine CSS-Class gibt es dafür, aber die würde auch die restliche Dicke der Foren etc. mitändern. Das wäre .forumline ^^

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am Do 19 Apr 2012 - 17:15

Hallo ich danke euch für die Antworten! Smile

Also ich möchte euch definitiv nicht nerven, deshalb versuch ich regelmäßig mich mit Firebug auseinander zu setzen, aber wirkliche Freunde werden wir zwei anscheinend nicht. V.V

Ich hab das jetzt auch im Testforum ausprobiert, aber irgendwie hab ich anscheinend etwas falsch gemacht, den das gesamte Forum hat sich verzogen. o.o

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am Do 19 Apr 2012 - 22:29

Magst du mal zeigen, was sich denn verzogen hat? (:
Also anhand eines Links oder Screenshots?

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am Sa 21 Apr 2012 - 17:04

Hallo ~Julian~!

Sorry, dass ich erst heute antworte, aber gestern war ich leider nicht am PC.

Also wenn du willst kannst du dir das Problem gerne im Testforum ansehen.

Mir ist dabei aufgefallen, dass es sich erst bei folgenden Module verschiebt:
Template->
standard
mod_whoisonline
mod_poll
poll_ballot

Bei den folgenden Modulen hat sich nichts verzogen:
Template->
mod_login
mod_recent_topics
portal_body

Aber mir ist dabei aufgefallen, dass der Rahmen sich nicht geändert hat. Also im CSS Bereich hab ich dotted darin und im Template solid.

Es kann aber auch sein, dass ich vielleicht deine Anleitung falsch verstanden habe, wenn es so ist tut es mir leid. V.V

Aber ich möchte mich noch mal für deine Hilfe bedanken und für die Zeit die du hier investierst.

DANKE

Ich wünsche dir noch einen schönen Samstag!

Liebe Grüße
Leonides

Edit: Bei den persönlichen Modulen wurde auch der Rahmen übernommen.

Edit: So ich hab jetzt noch ein wenig selbst mit dem Template rum probiert und ich hab die Struktur wieder.

Ich hab nun noch ein div hinzugefügt, so dass das ganze nun so im Templates aussieht:

Code:
<div table class="forumline" style="border: 2px solid;"></div>

Allerdings ist keine Änderung vom Rahmen zu sehen. Das einzige, was sich halt noch geändert hat ist, dass sich zwischen den Modulen neue "Rahmen" gebildet haben.

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 6:52

Okay. Dann hast du irgendwo einen Fehler eingebaut. Vor allem frage ich mich, was du da bitte gemacht hast mit dem Div-Tag?
Code:
<div table class="forumline" style="border: 2px solid;"></div>
Wenn du das so machst, dann hast du ja die komplette Tabelle der Module raus, worauf diese aufgebaut sind.

Kannst du eventuell mal alle Codes komplett rauskopieren, die du nun bearbeitet hast? In deinem Testforum sehe ich halt zwischen Portal & Forenindex einen riesigen Unterschied. Allerdings verstehe ich dennoch dein Problem nicht. Die Rahmenbreite ist doch 2px breit? Breiter geht das bei 2px nicht mehr. Einen Anzeigefehler gibt es da nicht. Da müsstest du statt 2px schon etwas größeres einbauen, damit du eine Veränderung siehst. (:

Ich bin leider gerade etwas verwirrt. Tut mir leid. scratch

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am So 22 Apr 2012 - 13:30

Hallo ~Julian~

Sorry, wenn ich mich etwas unklar ausgedrückt habe. o.o

Mir geht es nicht allein nur um die Rahmenbreite sondern auch um den Rahmen Style und der Modulüberschrift. o.o Ich dache mir dass man sich das ganze etwas persönlicher gestalten könnte.

Nur wird der Rahmenstyle solid nicht bei allen angezeigt. o.o

Und das div hab ich ja nur rein gemacht, weil sich ja das Forum verzogen hat. Ich hab jetzt auch das div wieder raus genommen, so dass du siehst was ich genau meine.

Forum

Ich hoffe dass ich mich diesmal nicht so umgeschickt ausgedrückt habe und das ich die Verwirrung ein wenig entwirren konnte. Smile

Ich wünsche dir noch einen schönen Sonntag!

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 14:11

Ja, dann musst du das auch sagen. (;

Dennoch wäre es immernoch toll, wenn du mir die Codes aus den Templates herauskopieren könntest, die du bearbeitet hast. Denn dann kann man den Fehler auch finden...

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am So 22 Apr 2012 - 14:56

Ups, sorry... darauf hab ich jetzt total vergessen. o.o

Also,... jetzt muss ich noch mal doof nachfragen.... willst du die nun die ich für die Module bearbeitet habe oder alle Abschnitte die ich bisher bearbeitet habe. Also Index_Body, Index_Box etc?

Aber ich poste jetzt einfach mal die aus dem Portal. o.o

mod_login:
Code:
<!-- BEGIN switch_login -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0"; z-index: 1>
 
    <table class="forumline" style="border: 2px solid;">

 
 
   <tr>
      <td class="catLeft" height="25">
<span class="genmed module-title">{L_LOGIN}</span>

             
      </td>
   </tr>
   <tr>
      <td class="row1">
         <form action="{S_LOGIN_ACTION}" method="post">
            <table width="100%" border="0" cellspacing="1" cellpadding="3">
               <tr>
                  <td align="left" width="55%"><span class="gen">{L_USERNAME}:</span></td>
                  <td style="position:relative;padding-right:5px;"><input type="text" name="username" value="{USERNAME}" size="20" maxlength="40" style="width:100%;" /></td>
               </tr>
               <tr>
                  <td align="left"><span class="gen">{L_PASSWORD}:</span></td>
                  <td style="position:relative;padding-right:5px;"><input type="password" name="password" size="20" maxlength="32" style="width:100%;"></td>
               </tr>
               <tr align="center">
                  <td colspan="2"><span class="gen">{L_AUTO_LOGIN}: <input type="checkbox" name="autologin" {AUTOLOGIN_CHECKED}></span></td>
               </tr>
               <tr align="center">
                  <td colspan="2"><input class="mainoption" type="submit" name="login" value="{L_LOGIN}"></td>
               </tr>
               <tr align="center">
                  <td colspan="2">
                     <span class="gensmall"><a class="gensmall" href="{U_SEND_PASSWORD}" rel="nofollow">::&nbsp;{L_SEND_PASSWORD}</a></span>
                  </td>
               </tr>
            </table>
         </form>
      </td>
   </tr>
</table>
<!-- END switch_login -->

<!-- BEGIN switch_login_small -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <td class="catLeft" height="25">
         <span class="genmed"><b><center>{L_LOGIN}</center></b></span>
      </td>
   </tr>
   <tr>
      <td class="row1">
         <form action="{S_LOGIN_ACTION}" method="post">
            <table width="100%" border="0" cellspacing="1" cellpadding="3">
               <tr>
                  <td align="left" width="55%"><span class="gen">{L_USERNAME}:</span> <input type="text" name="username" value="{USERNAME}" size="15" maxlength="40" /></td>
               </tr>
               <tr>
                  <td align="left"><span class="gen">{L_PASSWORD}:</span> <input type="password" name="password" size="15" maxlength="32"></td>
               </tr>
               <tr align="center">
                  <td><span class="gen">{L_AUTO_LOGIN}:&nbsp;<input type="checkbox" name="autologin" {AUTOLOGIN_CHECKED}></span></td>
               </tr>
               <tr align="center">
                  <td><input class="mainoption" type="submit" name="login" value="{L_LOGIN}"></td>
               </tr>
               <tr align="center">
                  <td><span class="gensmall"><a class="gensmall" href="{U_SEND_PASSWORD}" rel="nofollow">::&nbsp;{L_SEND_PASSWORD}</a></span></td>
               </tr>
            </table>
         </form>
      </td>
   </tr>
</table>
<!-- END switch_login_small -->

<!-- BEGIN switch_profile -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0" id="gallery_container">
 
   <tr>
      <td class="catLeft" height="25">
         <div class="genmed center"><b>{USERNAME}</b></div>
      </td>
   </tr>
   <tr>
      <td class="row1">
         <table width="100%" border="0" cellspacing="1" cellpadding="1">
            <tr>
               <td class="row1">
                  <div style="float:{DIRECTION};">{USERNAME_AVATAR}</div>
                  <div style="margin-{DIRECTION}:5px; float:{DIRECTION};">
                     <span class="genmed">{L_MESSAGES} : <strong>{NB_MESSAGES}</strong></span><br />
                     <span class="genmed">{L_PM} : <strong>{NB_PM_UNREAD} / {NB_PM_READ}</strong></span><br /><br />
                     <span class="genmed"><a href="{U_PROFILE}">{L_MY_PROFILE}</a></span>
                  </div>
               </td>
            </tr>
         </table>
      </td>
   </tr>
</table>
<!-- END switch_profile -->

mod_poll
Code:
<a name="sondage"></a>
<table width="100%" cellpadding="0" cellspacing="1" border="0" class="forumline">


   <tr>
      <td class="catLeft" height="25">
         <span class="genmed module-title">{L_POLL}</span>
      </td>
   </tr>
   <tr>
      <td>
         {POLL_DISPLAY}
      </td>
   </tr>
</table>

mod_recent_topics
Code:
<!-- BEGIN scrolling_row -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <table class="forumline" style="border: 2px solid;">
   <tr>
      <td class="catLeft" height="25">
         <span class="genmed module-title">{L_RECENT_TOPICS}</span>
      </td>
   </tr>
   <tr>
      <td class="row1" align="left" id="comments_scroll_div">
         <!-- BEGIN recent_topic_row -->
         &raquo;&nbsp;<a onmouseover="document.getElementById('comments_scroll_container').stop();" onmouseout="document.getElementById('comments_scroll_container').start();" href="{scrolling_row.recent_topic_row.U_TITLE}" title="{scrolling_row.recent_topic_row.L_TITLE}">{scrolling_row.recent_topic_row.L_TITLE}</a><br />
         <img src="{ICON_TIME}" alt="" />{scrolling_row.recent_topic_row.S_POSTTIME} {BY}&nbsp;

         <!-- BEGIN switch_poster -->
         <a onmouseover="document.getElementById('comments_scroll_container').stop();" onmouseout="document.getElementById('comments_scroll_container').start();" href="{scrolling_row.recent_topic_row.switch_poster.U_POSTER}">{scrolling_row.recent_topic_row.switch_poster.S_POSTER}</a><br /><br />
         <!-- END switch_poster -->

         <!-- BEGIN switch_poster_guest -->
         {scrolling_row.recent_topic_row.switch_poster_guest.S_POSTER}<br /><br />
         <!-- END switch_poster_guest -->

         <!--
         <a onmouseover="document.getElementById('comments_scroll_container').stop();" onmouseout="document.getElementById('comments_scroll_container').start();" href="{scrolling_row.recent_topic_row.U_POSTER}">{scrolling_row.recent_topic_row.S_POSTER}</a><br /><br />
         -->
         <!-- END recent_topic_row -->
      </td>
   </tr>
</table>

<script type="text/javascript">
//<![CDATA[
$(function(){
   div_marquee('comments_scroll_div', 'comments_scroll_container', '{SCROLL_WAY}', '{SCROLL_STEP}', '{SCROLL_DELAY}', '{SCROLL_HEIGHT}', 'genmed');
});
//]]>
</script>
<!-- END scrolling_row -->

<!-- BEGIN classical_row -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <td class="catHead" height="25"><span class="genmed"><b><center>{L_RECENT_TOPICS}</center></b></span></td>
   </tr>
   <tr>
      <td class="row1" align="left"><span class="gensmall">
      <!-- BEGIN recent_topic_row -->
      &raquo; <a href="{classical_row.recent_topic_row.U_TITLE}">{classical_row.recent_topic_row.L_TITLE}</a><br />{BY}&nbsp;

      <!-- BEGIN switch_poster -->
      <a href="{classical_row.recent_topic_row.switch_poster.U_POSTER}">{classical_row.recent_topic_row.switch_poster.S_POSTER}</a>
      <!-- END switch_poster -->

      <!-- BEGIN switch_poster_guest -->
      {classical_row.recent_topic_row.switch_poster_guest.S_POSTER}
      <!-- END switch_poster_guest -->

      {ON} {classical_row.recent_topic_row.S_POSTTIME}<br /><br />

      <!--
      <a href="{classical_row.recent_topic_row.U_POSTER}">{classical_row.recent_topic_row.S_POSTER}</a> {ON} {classical_row.recent_topic_row.S_POSTTIME}<br /><br />
      -->
      <!-- END recent_topic_row -->
      </span></td>
   </tr>
</table>
<!-- END classical_row -->

mod_whoisonline
Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <table class="forumline" style="border: 2px solid;">

   <tr>
      <td class="catLeft" height="25">
         <span class="genmed module-title">{L_WHO_IS_ONLINE}</span>
      </td>
   </tr>
   <tr>
   <td class="row1" align="left">
      <div class="gensmall">{TOTAL_USERS_ONLINE}<br />
      <br />
      {LOGGED_IN_USER_LIST}
      <br />
      <!-- BEGIN switch_onlinelink -->
      <div class="center">
         [ <a href="{U_VIEWONLINE}" rel="nofollow">{L_VIEW_COMPLETE_LIST}</a> ]
      </div>
      <!-- END switch_onlinelink -->
      <br />
      {RECORD_USERS}
      <br />
      </div>
   </td>
</tr>
</table>

portal_body
Code:
<table width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
  <table class="forumline" style="border: 2px solid;">
   <tr>
      <td colspan="3" width="100%"><!-- BEGIN giefmod0 --> {giefmod0.MODVAR} <!-- BEGIN saut -->
      <table width="100%" border="0" cellpadding="0" cellspacing="0">
               
         <tr>
            <td height="{SPACE_ROW}"></td>
         </tr>
      </table>
      <!-- END saut --> <!-- END giefmod0 --></td>
   </tr>
</table>
<table width="100%" cellspacing="1" cellpadding="{SPACE_COL}" border="0" align="center" class="portal">
   <tr>
      <td valign="top" width="{C1SIZE}" class="column"><!-- BEGIN giefmod1 --> {giefmod1.MODVAR} <!-- BEGIN saut -->
      <table width="100%" border="0" cellpadding="0" cellspacing="0">
         <tr>
            <td height="{SPACE_ROW}"></td>
         </tr>
      </table>
      <!-- END saut --> <!-- END giefmod1 --></td>
      <td valign="top" width="{C2SIZE}"><!-- BEGIN giefmod2 --> {giefmod2.MODVAR} <!-- BEGIN saut -->
      <table width="100%" border="0" cellpadding="0" cellspacing="0">
         <tr>
            <td height="{SPACE_ROW}"></td>
         </tr>
      </table>
      <!-- END saut --> <!-- END giefmod2 --></td>
      <td valign="top" width="{C3SIZE}" class="column"><!-- BEGIN giefmod3 --> {giefmod3.MODVAR} <!-- BEGIN saut -->
      <table width="100%" border="0" cellpadding="0" cellspacing="0">
         <tr>
            <td height="{SPACE_ROW}"></td>
         </tr>
      </table>
      <!-- END saut --> <!-- END giefmod3 --></td>
   </tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
   <tr>
      <td colspan="3" width="100%"><!-- BEGIN giefmod4 --> {giefmod4.MODVAR} <!-- BEGIN saut -->
      <table width="100%" border="0" cellpadding="0" cellspacing="0">
         <tr>
            <td height="{SPACE_ROW}"></td>
         </tr>
      </table>
      <!-- END saut --> <!-- END giefmod4 --></td>
   </tr>
</table>



standard
Code:
<!-- BEGIN table_row -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <table class="forumline" style="border: 2px solid;">
<tr>
<td class="catLeft" height="25">
<span class="genmed  module-title">{table_row.L_TITRE}</span>
</td>
</tr>
<!-- END table_row --><!-- BEGIN not_table_row -->
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<!-- END not_table_row -->
<tr>
<td {CLASS_TABLE_TYPE} align="left">{S_SOURCE}</td>
</tr>
</table>

Also ich möchte mich auf jeden Fall noch mal bei dir bedanken, weil du dir die Zeit dafür nimmst und möchte dich auch auf keinen Fall damit nerven oder so. Auf jeden Fall danke, dass du dir das Ganze durchsiehst!

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 15:18

Ach, jetzt verstehe ich, was du gemacht hast. Du hast jetzt überall das hier eingesetzt:
Code:
<table class="forumline" style="border: 2px solid;">

So meinte ich das in meiner Erklärung nicht. Das hast du komplett missverstanden.

In den Templates hast du überall ganz am Anfang folgenden Tabellen-Anfang:
Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
Genau dort, solltest du das mit style="" reinsetzen. Was ich gemacht habe, war nur ein Beispiel dafür, wo du das beispielsweise reinsetzen musst, damit du das nicht falsch einsetzt. Den "Testcode", den ich dort reingesetzt habe, solltest du nicht nochmal reinkopieren in das Templates ;D
Die musst du nun alle wieder aus deinen Templates rauslöschen und in den Tabellenanfang reinsetzen!

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am So 22 Apr 2012 - 16:10

Also ich bin mir nicht sicher ob ich das nun richtig verstanden habe. o.o

Stimmt das den so, wen ich es ins Tempaltes einfüge? o.o

Code:
<table class="forumline" style="border: 2px solid;" width="100%" border="0" cellspacing="1" cellpadding="0">

Ich hab das nun auch so eingefügt, und das Forum selbst ist nicht mehr verzogen, aber bei Neue Themen, Umfrage und Login hab ich noch immer das Problem, dass der Rahmen nicht richtig angezeigt wird. Ich hab in den entsprechenden Abschnitten auch nicht diesen Teil hier gefunden:

Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">

Sorry, wegen den Umständen, aber ich glaub ich hab im Moment ein Brett vor dem Kopf. o.o

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 17:38

Also das erste ist richtig, so wie du das nun zeigst. Aber achte darauf, dass du das auch ersetzt und nicht irgendwo einfügst. Das Ersetzen ist sehr wichtig, sonst hast du nachher zwei anfangende Tabellen, aber nur ein Ende für eine Tabelle und dann verzieht sich das Forum ;D

Kannst du mir sagen, bei welchen Modulen sich der "Rahmen" nicht ändert?
Sind es noch dieselben, die du bereits oben genannt hast? Also diese?
standard
mod_whoisonline
mod_poll
poll_ballot

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am So 22 Apr 2012 - 17:49

Also es handelt sich dabei um:

mod_login
mod_recent_topics
mod_poll
poll_ballot

Aber wie gesagt da finde ich auch nicht diesen Teil hier:

Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 17:56

Im mod_login Template gibt es auf jeden Fall ingesamt drei Bereiche, die man ändern müsste, da es sich ja letztlich auch um die Umschaltung zwischen Gästen & Usern handelt. Dort müsstest du auf jeden Fall sowohl nach <!-- BEGIN switch_login --> , <!-- BEGIN switch_login_small --> und <!-- BEGIN switch_profile --> den style=""-Teil einsetzen in den Tabellenanfang.

Ebenso im mod_recent_topics. Dort sind zum einen der Teil <!-- BEGIN scrolling_row --> und der <!-- BEGIN classical_row --> Teil vorhanden.

Bei poll_ballot musst du eigentlich nichts verändert, weil dieser Teil eigentlich zum mod_poll Template selbst gehört. Allerdings kann ich dir beim besten Willen nicht sagen, warum es mit dem Umfrage-Modul nicht klappt notknowing
Bei den anderen Templates solltest du es aber so ändern können, wie ich oben beschrieben habe.

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am So 22 Apr 2012 - 18:29

Dank dir hab ich nun den Rahmen anpassen können und zum Guten Schluss hat es auch bei den Unfragen geklappt. Smile

DANKE

Ich weiß zwar, dass nur eine Frage pro Thema erlaubt ist, aber ich hab noch eine Frage und hoffe dass ihr mir die eine Frage bitte verzeihen könnt. o.o

Und zwar, wie kann ich nun am besten die Überschriften der Module ändern? o.o Also das sie indivudell aussehen und nicht so standartmäßig?

Sorry noch mal wegen der zweiten Frage hier.

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am So 22 Apr 2012 - 18:36

Kein Problem Freunde

In den meisten der Templates für die Module sollte man so einen Teil finden:
Code:
<span class="genmed module-title">{L_LOGIN}</span>

Dort kann man die Überschrift ganz leicht ändern. Ebenfalls mit style="". Da müsstest du dich dann aber selber ein wenig schlau machen, wie du dort was ändern kannst, weil ich ja nicht weiß, was du da vor hast. ;D

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von Leonides am Mo 23 Apr 2012 - 16:30

Hallo ~Julian~!

Ich hoffe du hattest einen angenehmen Start in die Woche? Smile

Also ich hab das soweit bei den Standartmodulen mit der Schrift hinbekommen. Nur bei den persönlichen Modulen, hat sich nun für mich ein weiteres Problem gebildet.

Also wenn ich direkt im Template -> standard die einzelnen Persönlichen Module bezeichnen möchte steht die Überschrift bei jeden Module.

Nun hab ich alternativ dazu, die Überschrift direkt im Modul eingefügt. Aber jetzt hab ich dort total den breiten Abstand und ich weiß nicht wie ich das weg bekomme.



Forum

Es wäre schön wenn du mir bitte hier noch weiterhelfen könntest! Smile

Danke

Ich wünsche dir noch einen angenehmen Nachmittag!

Liebe Grüße
Leonides

Edit: Also ich konnte gerade Eben, selbst das Problem lösen!
Danke ~Julian~, dass du dir die Zeit genommen hast und mir dabei geholfen hast. Smile
Ich freu mich gerade sehr darüber!
Danke noch mal! Smile

Das Thema kann nun auch geschlossen werden! Danke für eure Geduld! Smile

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: CSS-Problem

Beitrag von ~Julian~ am Mo 23 Apr 2012 - 17:19

Eh okay. Dann alles klar. Bitte schön, dass ich dir bei den letzten Problemen helfen konnte Freunde

-done-

~Julian~
Kaiser
Kaiser

Männlich Beiträge : 1713
Anmeldedatum : 26.03.12

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten