Das Forum der Foren
Willkommen im offiziellen Supportforum von Forumieren!

Um alle Vorteile unseres Forums zu nutzen, melden Sie sich bitte an. Wenn Sie bereits Mitglied sind loggen Sie sich ein.


Erstellen Sie ein kostenloses Forum wie dieses hier.
Forenaustausch

Alle Anzeigen ansehen

Regeln und nützliche Hinweise
Lexi Help
Die neuesten Themen
» [phpBB3] Bilder von Fremdhoster seit SSL nicht mehr angezeigt
von Fisch Heute um 10:39

» [phpBB3] Schlüsselwörter Keywords Anzahl
von Mazacre Do 27 Jul 2017 - 16:56

» [#10397][phpBB3] Verschobene Werbung auf allen Seiten
von Bigtuber Do 27 Jul 2017 - 16:35

» [phpBB3] Standard für Beitragseingabe?
von Bigtuber Do 27 Jul 2017 - 16:26

» [#10418] meine Mailadresse ändern und Auswirkungen auf servimg
von Kellytime Do 27 Jul 2017 - 13:31

» Arcania - High-Fantasy-RPG
von Sheep007 Mi 26 Jul 2017 - 20:10

» [phpBB3] Profile mit mehreren Icons?
von inde Di 25 Jul 2017 - 19:39

» [#10378] Guthaben mit Paypal bezahlt und nach 2 Tagen nicht in der Guthabenverw
von inde Mo 24 Jul 2017 - 16:47

» World-of-Horses
von inde So 23 Jul 2017 - 16:56

» Yorkshire Terrier Forum
von inde So 23 Jul 2017 - 16:55

» Hundeforum unter hundis.frei-forum.com
von inde So 23 Jul 2017 - 16:53

» Das Raubtierreich - Das Haustier-Talk- und Fotografie-Forum
von Emily Stein So 23 Jul 2017 - 15:22

» Naruto - SnK
von Aiko-Chan So 23 Jul 2017 - 12:07

» Weimaraner-Forum "Der vielseitige Weimaraner"
von Emily Stein So 23 Jul 2017 - 1:57

» My-Ponyclub
von Emily Stein So 23 Jul 2017 - 1:54

» Pflanzen-Samentauschbörse
von Emily Stein So 23 Jul 2017 - 1:54

www.forumieren.de

Code für bb2 funktioniert nicht !

Seite 1 von 2 1, 2  Weiter

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:05

Hallo Team^^

Ich hab mir das hier rausgesucht,da ich mir nun auch eine kleine Grafik hinter die WIO-Anzeige setzen möchte.

Hab alles wie Beschrieben gemacht,aber es will und will nicht Funktionieren...gibt es da eine max.-Grösse für die Grafik die man nicht überschreiten darf,oder ist der Code nicht mehr gültig?
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:08

Hallo Smile

Kannst du mal den entsprechenden Code posten, den du eingesetzt hast ?

LG

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:21

Klar
Code:
<img src="http://illiweb.com/fa/pbucket.gif">

Den hab ich wie beschrieben eingesetzt...ups^^ und zwar in diesem Forum
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:22

Okay, und bitte mal den Template Abschnitte posten. Wink

EDIT: Frage: Wolltest du auf dem Index die W-i-o?-Überschrift ändern oder das Modul im Portal ?

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:28

Ok hier,
Code:
<span class="genmed module-title"><img src="http://illiweb.com/fa/pbucket.gif"></span>
</td>
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:30

So, nun nocheinmal mein Edit beachten. Laughing

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:31

Nein,
einfach nur ne Grafik hinter die Wer ist Online anzeige legen
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:35

Na gut, dann ist klar, warum der Thread nicht funktioniert, du musst das ein ganz anderes Template ändern, hier:
Templates->Allgemeines->index_body->Zeile 184, dort dann die besagte Änderung vornehmen. Wink

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:37

Achso^^
Genauso wie hier aufgeführt oder mit ner kleinen änderung im wortlaut?
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:40

Nein, sollte genauso funktionieren, da die Variable, die ersetzt werden muss, dieselbe ist. Wink

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 20:47

Muss mal wieder enttäuschen^^

selbst dort wird dann die grafik auch nicht angezeigt scratch
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 20:50

Also, ich habe mal die Grafik neu hochgeladen und es funktioniert, nutze mal diesen Link:
http://i49.servimg.com/u/f49/16/09/16/99/wiogra10.jpg
Vielleicht klappt es dann. Wink

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 21:01

Auch nicht,
also langsam geb ich´s auf....es muss doch irgendwie klappen
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 21:02

Okay, bitte mal den Abschnitt ab dem <table>-Tag posten bis zum nächsten </table>-Tag.

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 21:08

Code:
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <td class="catHead" colspan="2" height="28">
      <!-- BEGIN switch_viewonline_link -->
      <span class="cattitle"><a class="cattitle" href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a></span>
      <!-- END switch_viewonline_link -->

      <!-- BEGIN switch_viewonline_nolink -->
      <span class="cattitle"><img src="http://i49.servimg.com/u/f49/16/09/16/99/wiogra10.jpg"></span>
      <!-- END switch_viewonline_nolink -->
      </td>
   </tr>
   <tr>
      <td class="row1" rowspan="6" align="center" valign="middle"><img src="{L_ONLINE_IMG}" id="i_whosonline" alt="{L_WHO_IS_ONLINE}" /></td>
      <td class="row1" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />
      {TOTAL_USERS}<br />
      {NEWEST_USER}</span></td>
   </tr>
   <tr>
      <td class="row1"><span class="gensmall">{TOTAL_USERS_ONLINE}<br />
      {RECORD_USERS}<br />
      <br />
      {LOGGED_IN_USER_LIST}</span></td>
   </tr>
   {L_CONNECTED_MEMBERS}
   {L_WHOSBIRTHDAY_TODAY}
   {L_WHOSBIRTHDAY_WEEK}
   <tr>
      <td class="row1"><span class="gensmall">{LEGEND}&nbsp;:&nbsp;{GROUP_LEGEND}</span></td>
   </tr>
   <!-- BEGIN switch_chatbox_activate -->
   <tr>
      <td class="row1">
         <span class="gensmall">{TOTAL_CHATTERS_ONLINE}&nbsp;:&nbsp; {CHATTERS_LIST}<br />
            <!-- BEGIN switch_chatbox_popup -->
            <div id="chatbox_popup"></div>
            <script type="text/javascript">
            //<![CDATA[
            insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');
            //]]>
            </script>
            <!-- END switch_chatbox_popup -->
         </span>
      </td>
   </tr>
   <!-- END switch_chatbox_activate -->
</table>
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 21:17

Okay, jetzt weiß ich wo der Fehler liegt.
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<tr>
<td class="catHead" colspan="2" height="28">
<!-- BEGIN switch_viewonline_link -->
<span class="cattitle"><a class="cattitle" href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}<img src="http://i49.servimg.com/u/f49/16/09/16/99/wiogra10.jpg"></a></span>
<!-- END switch_viewonline_link -->

<!-- BEGIN switch_viewonline_nolink -->
<span class="cattitle">{L_WHO_IS_ONLINE}<img src="http://i49.servimg.com/u/f49/16/09/16/99/wiogra10.jpg"></span>
<!-- END switch_viewonline_nolink -->
</td>
</tr>
<tr>
<td class="row1" rowspan="6" align="center" valign="middle"><img src="{L_ONLINE_IMG}" id="i_whosonline" alt="{L_WHO_IS_ONLINE}" /></td>
<td class="row1" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />
{TOTAL_USERS}<br />
{NEWEST_USER}</span></td>
</tr>
<tr>
<td class="row1"><span class="gensmall">{TOTAL_USERS_ONLINE}<br />
{RECORD_USERS}<br />
<br />
{LOGGED_IN_USER_LIST}</span></td>
</tr>
{L_CONNECTED_MEMBERS}
{L_WHOSBIRTHDAY_TODAY}
{L_WHOSBIRTHDAY_WEEK}
<tr>
<td class="row1"><span class="gensmall">{LEGEND}&nbsp;:&nbsp;{GROUP_LEGEND}</span></td>
</tr>
<!-- BEGIN switch_chatbox_activate -->
<tr>
<td class="row1">
<span class="gensmall">{TOTAL_CHATTERS_ONLINE}&nbsp;:&nbsp; {CHATTERS_LIST}<br />
<!-- BEGIN switch_chatbox_popup -->
<div id="chatbox_popup"></div>
<script type="text/javascript">
//<![CDATA[
insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');
//]]>
</script>
<!-- END switch_chatbox_popup -->
</span>
</td>
</tr>
<!-- END switch_chatbox_activate -->
</table>
Da es dort mehrere Variablen gibt, die "{L_WHO_IS_ONLINE}" heißen, scheinst du zwei vertauscht zu haben.
Ich habe mal alles rot markiert, was du gemacht hast, was falsch ist, und grün, wie es aussehen sollte.

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 21:24

du sagtest reihe 184^^

aber...Boaaaaaah es funzt immernoch nich.
Sei mir nich böse,machen wir morgen weiter,ich blick da nich mehr durch heute
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Cyborg112233 am Sa 25 Feb 2012 - 21:29

Stimmt, du hast Recht, das war mein Fehler. Embarassed

Naja, ich gehe mal nicht davon aus, dass du noch einen Fehler gemacht hast, aber wenn du willst, machen wir morgen weiter und hoffen, dass es dann klappt.

Cyborg112233
Kaiser
Kaiser

Männlich Beiträge : 2362
Anmeldedatum : 08.10.10
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von #Frank am Sa 25 Feb 2012 - 21:40

Sind die Änderungen Aktuell noch im Forum vorhanden und ist das Template auch veröffentlicht wurden?

Edit:
Die Variable:
{L_WHO_IS_ONLINE}
Sollte in beiden oben genannten Bereichen durch den Bliderlink ersetzt werden, weil die Variable der Text ist.
Wenn man etwas Englisch versteht, dann sieht man das das einmal der Bereich mit einem Link und einmal ohne einen Link ist.
Auch ist das Bild viel zu hoch, weil das so nur die Überschriften Zeile betrifft in der jetzt steht "Wer ist online".
ich gehe eigentlich davon aus, das das Bild hinter den Text im unteren Teil soll.
Dazu muss das Template so geändert werden, das die ganze Tabelle eine DIV Ode Span Class erhält und das Bild wird dann über das CSS als Hintergrundbild eingesetzt.
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34606
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 22:06

Hi Frank,
nein die änderungen hab ich erst mal wieder rückgängig gemacht.
und Ja,essoll nicht auf die Leiste sondern als Background für den Text rein^^

Aber ehrlich gesagt...Templates sind immernoch Böhmische Dörfer für mich...hinter Css bin ich mittlerweile wenigstens einigermassen gekommen.
Daher (selbst obwohl ich eigentlich gut im umgang mit Englisch bin) hab ich da jetzt grade von deiner Erklärung her höchstens 10% verstanden^^
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von #Frank am Sa 25 Feb 2012 - 22:19

Hast du morgen Vormittag Zeit? Ich würde dann mal versuchen, das ich dir das in dein Forum einsetze.
Ich brauche dann die Daten zu dem Adminaccount zu dem Forum.
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34606
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am Sa 25 Feb 2012 - 22:48

Ok,
ich weis nicht ob das morgen Vormittag klappt,da die Kids uns Tagsüber so richtig auf dem Kopf rumtanzen Very Happy

Aber ich schick dir mal die Admin-Daten
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von #Frank am So 26 Feb 2012 - 10:59

Es geht gleich los... ich muss nur noch hier alles durchschauen...
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34606
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von Rhonon am So 26 Feb 2012 - 11:19

Ôk,ich geh schnell noch eine Rauchen...muss mal stress abbauen...hier is grad Highlife wegen geplatztem Waschmaschienenschlauch lol

Bis gleich denn
avatar
Rhonon
Premium User
Premium User

Männlich Beiträge : 580
Anmeldedatum : 21.03.11
keine
phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Code für bb2 funktioniert nicht !

Beitrag von #Frank am So 26 Feb 2012 - 11:39

So, Bild ist drin...
Templateänderung index_body:
<!-- BEGIN disable_viewonline -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<tr>
Geändert in:
<!-- BEGIN disable_viewonline -->
<table class="wio" width="100%" border="0" cellspacing="1" cellpadding="0">
<tr>
Damit haben wir der Tabelle eine eigene Tabelclass gegeben.
nun die Einträge im CSS:
Code:
.wio {
  background: url("http://i49.servimg.com/u/f49/16/09/16/99/wiogra10.jpg") repeat scroll 0 0 transparent;
  padding-bottom: 144px;
}
Hier wird das Bild festgelegt. (eigentlich sollte das Bild breiter sein. Hier habe ich es so eingestellt, das es sich wiederholt (repeat))

Mit padding-bottom habe ich das Feld der Tabelle auf die benötigte Höhe aufgezogen.
Zu beachten ist, das der obere Rand des Bildes von der Tabellenüberschrift überdeckt wird.
Man kann das aber auch noch entfernen, so das die Tabelle keinen Hintergrund im Tabellen Kopf hat.
Dazu diesen Abschnitt im Template so ändern:
<td class="catHeadrow1" colspan="2" height="28">
<!-- BEGIN switch_viewonline_link -->
<span class="cattitle"><a class="cattitle" href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a></span>
<!-- END switch_viewonline_link -->

<!-- BEGIN switch_viewonline_nolink -->
<span class="cattitle">{L_WHO_IS_ONLINE}</span>
<!-- END switch_viewonline_nolink -->
</td>
Nur das Rote durch das Grüne ersetzen.
Das ist alles.
avatar
#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34606
Hinweis : Admin a.D.
Anmeldedatum : 13.08.08
keine
Firefox phpBB2

Benutzerprofil anzeigen

Nach oben Nach unten

Seite 1 von 2 1, 2  Weiter

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten