Lexi Help
Partner
www.forumieren.com

Absolute Positionierung von Elementen auf der Foren Seite

Seite 1 von 2 1, 2  Weiter

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Erledigt Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Mi 5 Okt 2011 - 17:37

Hallo alle zusammen!

Ich hoffe ich bin mit diesem Thema im richtigen Bereich, falls das nicht der Fall ist sorry.

Also ich habe heute dieses Thema hier gefunden.
Ich hab das natürlich auch im Testforum gleich probiert und hat auch super geklappt, aber dann kam mir halt ein Gedanke ob es vielleicht möglich wäre, wenn man diese Tabelle auf und zu klappen könnte?

Ich hab die Suchfunktion und auch das Lexi-Help genützt, aber leider nichts passendes zu meiner Frage gefunden, deshalb dachte ich mir dass ich dieses Thema dazu aufmache.

Wenn das möglich ist, würde ich mich sehr darüber freuen, wenn mir bitte jemand dabei weiterhelfen könnte, da ich nicht genau weiß wo ich hier ansetzen muss.

Danke schon mal im Vorfeld.

Ich wünsche euch noch einen schönen Abend.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Mi 5 Okt 2011 - 19:58

Wenn du "aufklappen" in der Suche eingibst, dann kannst du auch das hier finden:
http://hilfe.forumieren.com/t21485-chat-in-kleinen-fenster-auf-startseite-setzen
Diese Beschreibung kannst du nun so umwandeln, das anstelle der Chatbox deine Tabelle dort angezeigt wird. Mit dem was du dort schon gefunden hast in Kombination mit dem Thread, sollte es dir möglich sein das zu erreichen, was du möchtest.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 11:35

Hallo #Frank, danke für deine Antwort.

Also ich hab dazu noch eine Frage. Bei diesem Link den du mir hier gegeben hast, ist hier die Rede von overall_footer aber kann ich den Code auch für overall_header verwenden? oO

Ich frag nämlich deshalb, weil ich ja die seidliche Tabelle ja im overall_header gemacht habe und das ganze gerade nicht wirklich funktionieren wollte. o.o

Danke schon mal für deine Antwort.

Liebe Grüße
Leonides

Edit: Die Frage hat sich soweit erledigt aber die Lösung hab ich noch immer nicht. o.o

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 11:50

Du kannst das Was ich dir da Verlinkt habe auch in den Header einsetzen. das spielt keine Rolle.
Was hast du denn noch für Probleme damit?
Funktioniert es denn jetzt?



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 12:12

Es funktioniert leider noch nicht und ich glaube halt, dass meine Überlegung hier etwas verkehrt ist. o.o

Ich hab diesen Code hier für die "Chatbox" genommen.


Code:
    <TABLE style="Z-INDEX: 10000; POSITION: fixed; TOP: 0px; LEFT: 0px">
    <TBODY>
    <TR>
    <TD><IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="../chatbox/index.forum?" frameBorder=0 marginWidth=0 scrolling=no></IFRAME></TD>
    <TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>

Und hab erst mal hier die id=chatboxpop auf id=chatboxpop2 geändert.
Dadurch dass ich schon mal die Chatbox Zweckentfremdet habe und in diesem Teil hier....

src="../chatbox/index.forum?"

ein Bild eingefügt hatte, dachte ich mir halt, dass ich genau diesen Teil mit diesem Code hier ersetzen kann. Nur das halt der Code den ich geschrieben habe, etwas länger ist. o.o

Code:
    </head>
    <div style="position: absolute; top: 20px; left: 10px; z-index: 10000;">
      <table border="1" width="300" bordercolor="#000000">
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 1</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 2</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 3</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 4</span></td>
        </tr>
      </table>
    </div>

    <body background

Allerdings ist das Problem, dass entweder die Zweckentfremdete "Chatbox" sich nicht aufklappen lässt oder sie lässt sich mit der orginal Chatbox ausklappen aber OHNE das die Tabelle sichtbar wird. o.o

Deshalb nehme ich an, dass an meiner Überlegung etwas falsch ist. o.o

Danke schon mal für deine Antwort.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 12:20

Ich glaube das ich den Fehler schon sehe.
Wenn du dir den Code mal anschaust, dann ist das ein Iframe, der da auf und zu gemacht wird.
Du musst nun deine Tabelle auf einer HTML Seite erstellen und diese HTML Seite dann als Iframe in deinem Aufklappcode einstezen:
Code:
<IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="ADRESSE_DEINER_HTML_SEITE" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>

Deine Tabelle benötigt dann aber die div Class nicht mehr. Das kannst du entfernen.
Du brauchst dann nur noch das hier:
Code:
      <table border="1" width="300" bordercolor="#000000">
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 1</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 2</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 3</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 4</span></td>
        </tr>
      </table>



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 12:43

Ich bin jetzt etwas verwirrt, deshalb entschuldige bitte das ich einige Stellen von dir wiederhole und falls jetzt nervige Fragen dazu kommen.

Also ich muss diesen Code für die Tabelle hier:

Code:
<table border="1" width="300" bordercolor="#000000">
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 1</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 2</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 3</span></td>
        </tr>
        <tr>
          <td bgcolor="#FFFF00" bordercolor="#000000"><span class="genmed">Zeile 4</span></td>
        </tr>
      </table>

Auf einer HTML Seite aufbauen. Das kann ich doch im Grunde mit dem Forum machen. Also Administratoren Bereich > Module > HTML Seiten Verwaltung?

Dabei kann ich diesen Teil vom Code hier weg lassen:

Code:
<div style="position: absolute; top: 20px; left: 10px; z-index: 10000;">

Sobald ich die HTML Seite erstellt habe, brauche ich an sich nur den Link und den muss ich dann in diesem Teil hier einfügen? Ist es dabei egal wie der Link heißt oder gibt es hier eine Vorgabe?


Code:

<IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 300px" id=chatboxpop marginHeight=0 src="ADRESSE_DEINER_HTML_SEITE" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>



Und der untere Teil dieses Codes bleibt dann gleich?

Code:
</TD>
    <TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>


Sorry, dass ich deinen Text wiederholt habe und dazu noch nervige Fragen kamen, nur will ich wirklich sicher sein dass ich es auch verstanden habe.

Falls ich das jetzt alles richtig verstanden habe, wartet jetzt ein kleines Abenteuer auf mich. o.o

Danke noch mal für deine Hilfe.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 12:48

Ja, genau so wie du es schreibst, ist es. Dann sollte deine Tabelle auch in der Aufklappbox erscheinen.
Wie du den Button austauschst und wie du die Position des Ausklappen veränderst, ist dir ja hinreichend bekannt, weil du es ja schon drei mal eingesetzt hast.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 14:38

Also ich hab jetzt die HTML Seite erstellt und dort sieht an sich alles gut aus.
Bis auf eine Sache dass die Bilder nicht transparent dargestellt werden.

Hier ist mal der Link dazu:
http://anipro-testforum.forumieren.net/h1-tabelle

Ok, als ich dann den Rest wie besprochen machte, tauchte wieder ein Problem auf!

Und zwar wird nur ein Teil der HTML Seite dargestellt und dabei ist es egal ob ich die Zahl höher oder niedrige einstelle. Da es entweder nur unten abgeschnitten ist oder oben und unten. o.o

Hier ist einmal Screenshot dazu:





Und das wäre der Code so wie ich es im Templates eingefügt habe.


Code:
<TABLE style="Z-INDEX: 10000; POSITION: absolute;  BOTTOM: 0px; LEFT: 0px"; >
<TBODY>
<TR>
<TD>
    <IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 400px" id=chatboxpop marginHeight=0 src="http://anipro-testforum.forumieren.net/h1-tabelle" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>
    </TD>
        <TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>

Ich hab hier versucht die Zahlen zu ändern, aber es hat nichts gebracht.

Das nächste Problem was noch dazu kam, war das wenn ich die Chatbox ID geändert habe, dass sich die Original Chatbox mit aufklappe und der Inhalt von der HTML Seite fehlte.

Vielleicht kannst du mir bitte ein weiteres mal helfen.
Danke schon mal im Vorfeld dafür.
Liebe Grüße Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 14:50

Ich muss mir das nachher mal am Rechner anschauen, aber ich denke das es was mit den angegebenen Höhen zu tun hat.
Wenn du das Klappscript mehrfach benutzt, solltest du auch jedes Mal andere ID's und auch andere Buttons einsetzen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 14:55

Also es ist so, dass ich im Testforum ja die 3 zweckentfremdenChatboxen entfernte weil ich ja diese Tabelle stattdessen machen wollte und zu vor hat es aber mit den ID geklappt. Doch mit der Tabelle funktionierte das ganze nicht mehr wirklich.
Ich werde auch noch ein wenig rum probieren vielleicht klappt es bis dahin, dann würde ich dir auf jeden Fall bescheid sagen, nicht das du dir um sonst die Mühe machst. o.o
Auf jeden Fall danke, für deine Unterstützung und das du mir mit Rat und Tat zur Seite stehst. Smile

Liebe Grüße Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 17:46

Ich bin nun am Rechner.
Kannst du mir bitte mal die Log In Daten zu deinem Testforum geben damit ich mir das mal vor Ort anschauen kann?
Bitte sende mir das mal per PN!
!!! Bitte den PN Button im meinem Profil oder den PN Button im meiner Signatur benutzen !!!



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 18:11

Eigentlich habe ich es schon fertig. Aber ich frage mich wer das bei dir im Forum gemacht hat.
Ich denke das es dieser Code ist, den du einsetzen must:
Code:
    <TABLE style="Z-INDEX: 10000; POSITION: absolute;  top: 0px; LEFT: 0px"; >
    <TBODY>
    <TR>
    <TD>
        <IFRAME style="WIDTH: 182px; DISPLAY: none; HEIGHT: 2100px" id=iframepop marginHeight=0 src="http://anipro-testforum.forumieren.net/h1-tabelle" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>
        </TD>
            <TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('iframepop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>
Nun solltest du die Grafiken noch austauschen und alle ist Toll.
Auch mit deiner Chatbox beißt sich das nicht mehr.
Aber du hast doch in deinem Hauptforum alles auf die Gleiche Weise eingesetzt. Warum hast du jetzt hier solche Probleme.
Und noch was:
Warum nutzt du hierzu nicht die Indexmodule. Die kannst du doch auch ganz einfach ein und aus Blenden.
Schau mal auf mein Forum und klicke mal hier:
http://www.harzfuchsforum.com/

Wäre das nicht um Klassen besser, als das was du da nun machst?
Anleitung hier:
http://hilfe.forumieren.com/t26217-indexmodule-ein-und-ausblenden-mehrmals-moglich#164765



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 19:11

Ich bin echt froh und vor allem dankbar darüber, dass du dir das Problem bei mir im Forum angesehen hast. Deshalb noch mal danke.

Aber ich frage mich wer das bei dir im Forum gemacht hat.

Was meinst du den damit?

Aber du hast doch in deinem Hauptforum alles auf die Gleiche Weise eingesetzt. Warum hast du jetzt hier solche Probleme.

An sich ist es so, dass ich alles im Testforum vorbereite, weil ich ja niemanden stören möchte. Wenn ich dann alles fertig habe, kopiere ich meistens die Codestücke rüber und setz sie an den richtigen Ort. So bin ich mir dann halt sicher dass ich nicht viel falsch machen kann, aber dafür schaut halt dementsprechend das Testforum aus. -.-


Warum nutzt du hierzu nicht die Indexmodule. Die kannst du doch auch ganz einfach ein und aus Blenden.

Ich weiß, dass es diese Möglichkeit mit den Indexmodulen gibt aber ich hab keine Erklärung dafür warum ich den komplizierten Weg genommen habe, als den einfachen.

  • Aber wo lag jetzt genau das Problem? oO


Ich hab aber noch zwei Frage zu diesem Thema. Sorry wenn ich jetzt schon wieder nerve, aber danach sollte wirklich Schluss sein. -.-

  • Die erste Frage wäre, kann man den Button für schließen auch unter dieser Tabelle platzieren? Also auf der selben Position wie öffnen nur halt unter dem ganzen Balken?


  • Und die zweite wäre dann,…
    Angenommen ich will jetzt noch einen zweiten Balken setzen muss ich dafür eine neue HTML Seite schreiben oder kann ich bei der alten weiter schreiben?


Ich denke der Rest wird dann so bleiben wie jetzt. Bis auf die Position wo dieser Button platziert wird. o.o

Danke, dass du dir die Zeit genommen hast und die Geduld aufgebracht hast.

Liebe Grüße
Leonides


Edit: Also ich habe gerade gesehen, wenn man auf einen Link dort geht, wird dann der Header zb hinter dem öffenen Button angezeigt oder die Figur für die Chatbox ist dann beim schließen Button. o.o

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 20:30

Das mit den Links dort habe ich jetzt garnicht bedacht.
Das ist natürlich klar, weil sich die verlinkte Seite ja nun in dem Iframe öffnet. Und das ist auch der Grund dafür das dort noch mal deine andere Grafik angezeigt wird.
Du must mal versuchen bei deinen Links das Attribut zum öffnen im übergeordneten Frame hinzuzufügen.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 20:37

Ok jetzt muss ich ehrlich gesagt passen, da ich nicht weiß was du jetzt genau meinst und ich auf dem Gebiet ein absoluter leihe bin, der wirklich versucht etwas zu lernen. o.o

Vielleicht könntest du mir das bitte erklären und sorry wegen den ganzen Umständen. Ich wollte dir definitiv nicht soviel Arbeiten bereiten und hab auch schon total das schlechte Gewissen. -.-

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Do 6 Okt 2011 - 20:45

Versuch mal bitte deine Links so aufzubauen:
Code:
<a href="..." target="_parent">
Das target sollte dafür sorgen das sich die Links auf der Hauptseite öffnen.
Probier das bitte mal aus.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Do 6 Okt 2011 - 20:57

Danke für den link und ich hab das auch gerade ausprobiert und als ich auf den Link ging war genau dort wo die Tabelle war ein Teil des orginal Forums zusehen. o.o

Liebe Grüße
Leonides

Edit: Aber mal ne doofe Frage am Rande...
Diese Box kommt ja im Grunde dann in das orginal Forum brauch ich da dennoch etwas anderes das die Links dann funktionieren? o.O

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Fr 7 Okt 2011 - 9:19

Ich habe mir deine Tabelle mal runter geladen und diese bei mir eingesetzt.
Du hast noch nicht das gemacht, was ich dir gestern gesagt habe.
Ich habe mir aus deiner Tabelle mal den ersten Link zu den Regeln rausgepickt.
Du hast den Link ja so angegeben:
Code:
<a href="http://anime-central.all-forum.net/f14-regeln-und-haftungsausschluss">Regeln</a>
Ich sagte, das du alle deine Links mit dem Attribut:
Code:
target="_parent"
versehen solltest.
Das ist noch nicht passiert.
Alle Links müssen demnach so erwitert werden:
<a href="http://anime-central.all-forum.net/f14-regeln-und-haftungsausschluss" target="_parent">Regeln</a>
Der Hintergrund ist der, das die Links so wie du sie angegeben hast immer in dem Selben Frame geöffnet werden.
Wir wollen aber das diese in dem Hauptframe geöffnet werden.
Mit dem Link Attribut: target="_parent" weisen wir den Browser an den aufgerufenen Link im übergeordneten Frame zu öffnen.
Ich weiß, das das nun eine Menge Arbeit ist, aber es gibt keine andere Lösung.

Und zu den Links selber: Da kommt es ja darauf an, ob die Links so wie sie Jetzt eingesetzt sind schon auf die Seiten im Hauptforum verweisen.
Du kannst die Links aber auch Kürzer Schreiben in dem du die Forenadresse weg lässt.
Ich nehme nun mla diesen Link:
Code:
<a href="http://anime-central.all-forum.net/t748-ryos-verdienen-und-in-unserem-shop-ausgeben" target="_parent">hier</a>
Wenn du den Link so einsetzt:
Code:
<a href="../t748-ryos-verdienen-und-in-unserem-shop-ausgeben" target="_parent">hier</a>
Nun habe ich die Forenadresse:
http://anime-central.all-forum.net
durch zwei Punkte ersetzt.
Diese Beiden Punkte weisen den Browser an die Forenadresse vor den Link zu setzen.
Das hat den Vorteil, das wenn du mal deine Forenadresse ändern solltest, die Links zu den Themen nicht verändert werden müssen, weil diese Automatisch durch die Adresse der Seite ergänzt werden auf der sie stehen.

Ich hoffe das das nun nicht zu viel Input war und das es nun so Funktioniert, wie du es dir gedacht hast.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am So 9 Okt 2011 - 19:20

Hallo #Frank, entschuldige bitte die späte Anwort, hatte am Wochenende einiges um die Ohren so das ich nur per Handy kurz online konnte.

Danke für die ausführliche Erklärung. Ich dachte, wenn ich das bei einem Link einsetze dass es sofort gehen würde. Dadurch dass eben das oben genannte Problem entstand dachte ich halt das es nicht geht.

Dadurch das ich morgen wieder genügend Zeit habe, werde ich das auf jeden Fall bei allen Links einsetzen. Smile

Danke auf jeden Fall für deine Geduld.

Ich wünsche dir noch einen schönen Sonntag.
Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am So 9 Okt 2011 - 19:29

Es sollte auf jeden Fall schon bei den Links gehen, wo du es schon eingesetzt hast. Aber ich habe in deiner Tabelle nicht einen Link mit dem Attribut gefunden. Deshalb bin ich davon ausgegangen, das du da noch nichts gemacht hattest.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am So 9 Okt 2011 - 19:50

Das du keinen Link gefunden hast, lag daran das ich eben nach diesem Problem dachte, dass es nicht geht und deshalb hab ich es sofort raus genommen.

Ich muss ehrlich sagen, dass ich nicht wusste, dass dieses Problem durch alle Links erzeugt wurden. o.o

Aber ich werde es morgen noch einmal ausprobieren und diesmal mit allen Links.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von Leonides am Di 11 Okt 2011 - 11:19

Hallo #Frank!
Also erst mal Entschuldigung wegen den Doppelpost, aber ich wollte kurz bescheid sagen, dass es mit den Links nun geklappt hat.

Aber ich habe aber noch 2 Fragen zu diesem Thema.
Wie kann ich das Opacity (Also dass die Bilder transparent werden im HTML Seite anwenden?)
Und kann man den Close Button unterhalb von der Tabelle platzieren?

Danke noch mal #Frank, dass du mir alles so gut erklärt hast und mir mit Rat und Tat geholfen hast. Smile
DANKE

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Di 11 Okt 2011 - 15:51

Ich habe nun nicht so viel Zeit, aber ich gucke mir das mit der Transparenz später mal an.
Den Button wirst du so nicht unter die Tabelle bekommen.
Morgen Vormittag habe ich noch mal etwas mehr Zeit, so das ich noch mal gucken kann.
Eventuell kommst du aber auch selber drauf, wie du das mit der Transparenz machen kannst, wenn ich dir sage, das du die CSS Befehle oben in deine HTML Seite eintragen musst.
Dann solle es gehen.
Ansonsten morgen mehr.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Erledigt Re: Absolute Positionierung von Elementen auf der Foren Seite

Beitrag von #Frank am Mi 12 Okt 2011 - 11:22

Ich habe mir überlegt, das es am einfachsten ist, weil du auch deine Partner Bilder schon so eingefügt hast, wie sie im Hauptforum in der Fußzeile definiert sind es am besten wäre, wenn du das CSS deines Forums auch für die Tabelle benutzt.
Dazu musst du deiner Tabelle nur mitteilen welches CSS Datei diese benutzen soll.
Dazu machst du bitte volgendes:
Auf der HTML Seite der Tabelle hast du einen "head" Bereich.
Das ist der Bereich ganz oben, der zwischen:
<head>... und </head>
steht.
Nun setzt du bitte den Link zu deiner CSS Datei dort so ein:
Code:
<link rel="stylesheet" type="text/css" href="http://anime-central.all-forum.net/80-ltr.css">
und zwar direkt vor </head>
Nun verwendet deine Tabelle alle Einstellungen deines Hauptforums. Auch die Transparenz der Partnerbilder wird so mit übernommen.
Alle Links und sonstige Formatierungen die du in deinem Forum benutzt, sind so hier anwendbar.

Aber mal ganz unter uns. Bist du nicht inzwischen auch der Meinung, das du mit den Indexmodulen wirklich besser bedient gewesen währst?
Das ganze ist doch schon sehr aufwändig und schwer zu handeln.

Ach, und noch was dazu den Button in deinem Forum unter der Tabelle anzeigen zu lassen.
Es geht doch und zwar ist es ganz einfach.
Du hast ja in deinem Template dieses Teil eingefügt:
<TABLE style="Z-INDEX: 10000; POSITION: absolute; BOTTOM: 0px; LEFT: 0px"; >
<TBODY>
<TR>
<TD>
<IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 400px" id=chatboxpop marginHeight=0 src="http://anipro-testforum.forumieren.net/h1-tabelle" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>
</TD>
<TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>
Das ist eine Tabelle mit zwei Spalten und einer Zeile (in der einen Spalte ist der Verdeckte Iframe und in der anderen ist der Button).
Um das nun in eine Tabelle mit einer Spalte und zwei Zeilen umzustellen brauchst du nur zwei einfache Einträge vorzunehmen (Bitte das Rot Markierte in dein Temlate einsetzen):
<TABLE style="Z-INDEX: 10000; POSITION: absolute; BOTTOM: 0px; LEFT: 0px"; >
<TBODY>
<TR>
<TD>
<IFRAME style="WIDTH: 600px; DISPLAY: none; HEIGHT: 400px" id=chatboxpop marginHeight=0 src="http://anipro-testforum.forumieren.net/h1-tabelle" frameBorder=0 marginWidth=0 scrolling=no></IFRAME>
</TD>
</tr>
<tr>

<TD style="VERTICAL-ALIGN: bottom"><IMG onclick="document.getElementById('chatboxpop').style.display=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'block':'none';this.src=(this.src=='http://www.abload.de/img/chat_open6ygu.png')?'http://www.abload.de/img/chat_closedizhj.png':'http://www.abload.de/img/chat_open6ygu.png';" src="http://www.abload.de/img/chat_open6ygu.png"></TD></TR></TBODY></TABLE>
Das einfach dort an der Stelle einsetzen, absenden und veröffentlichen.
Dann ist der Button auch unter der Tabelle.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Admin a.D.
Admin a.D.

Männlich Beiträge : 34547
Hinweis : Admin außer Dienst
Anmeldedatum : 13.08.08
Firefox

Benutzerprofil anzeigen

Nach oben Nach unten

Seite 1 von 2 1, 2  Weiter

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten