Lexi Help
Die neuesten Themen
» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 19:18

» [Update] Neues Theme der mobilen Version V2
von Tierfreund-97 Gestern um 17:05

» Begriff : "merken"
von Ray Gestern um 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Gestern um 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

Partner
free forum

Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von ItaTschi-Chan am Di 20 Sep 2011 - 15:49

Hallo,
ich habe einen Thread im Forum mit dem Titel "Expressantwort ein/ausklappbar" gefunden, dort gibt Frank einen Code an und meint es sei der richtige.
Nun, ich habe ihn bei mir eingebunden und die Anleitung verfolgt und nun sieht das in der Vorschau so aus:



es wird doppelt angezeigt.

hier ist ein bruchteil des codes in welchen man auch die funktion mit der expressantwort finden sollte. was habe ich falsch gemacht?

Code:
      <td class="row2" valign="top" {COLSPAN_PAGINATION} width="150"><span class="gensmall">{PAGE_NUMBER}</span></td>
      <!-- BEGIN topicpagination -->
      <td class="row1" align="right" valign="top" ><span class="gensmall">{PAGINATION}</span></td>
      <!-- END topicpagination -->
   </tr>
          <!-- BEGIN switch_user_logged_in -->
              <input type="button" value="Expressantwort Öffnen / Schliessen"
    onclick="if(document.getElementById('navi').style.visibility=='collapse')
    document.getElementById('navi').style.visibility='visible';
    else document.getElementById('navi').style.visibility='collapse'">

    <span id="navi" style="visibility: collapse">
            <a name="quickreply"></a>
            {QUICK_REPLY_FORM}
    </span>
            <!-- END switch_user_logged_in -->
   <tr>
      <td class="row2" colspan="2" align="center" style="padding:0px">
         <!-- BEGIN switch_user_logged_in -->
         <a name="quickreply"></a>
         {QUICK_REPLY_FORM}<br />
         <!-- END switch_user_logged_in -->

ItaTschi-Chan
Lehrling
Lehrling

Weiblich Beiträge : 86
Anmeldedatum : 19.09.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von #Frank am Di 20 Sep 2011 - 21:09

Eigentlich solltest du das doch selber sehen...
Du hast den Abschnitt  {QUICK_REPLY_FORM} ja zwei mal drin...



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von ItaTschi-Chan am Mi 21 Sep 2011 - 16:23

Hab eines weg gemacht aber es lässt sich weder ein noch aus klappen ._.

Code:
</tr>
      <!-- BEGIN switch_user_logged_in -->
          <input type="button" value="Expressantwort Öffnen / Schliessen"
 onclick="if(document.getElementById('navi').style.visibility=='collapse')
 document.getElementById('navi').style.visibility='visible';
 else document.getElementById('navi').style.visibility='collapse'">

<span id="navi" style="visibility: collapse">
        <a name="quickreply"></a>
        {QUICK_REPLY_FORM}
</span>
        <!-- END switch_user_logged_in -->
   <tr>

      </td>
   </tr>
   <tr>
      <td style="margin:0; padding: 0;" colspan="2">
         <table border="0" cellpadding="0" width="100%" cellspacing="0" id="info_open" style="display:''">
            <tbody>
      <!-- BEGIN show_permissions -->
      <tr>
         <td class="row2" valign="top" width="25%"><span class="gensmall">{L_TABS_PERMISSIONS}</span></td>
         <td class="row1" valign="top" width="75%"><span class="gensmall">{S_AUTH_LIST}</span></td>
      </tr>
      <!-- END show_permissions -->
      <tr>
         <td class="catBottom" colspan="2" height="28">
            <table width="100%" border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td valign="middle" width="100%"><span class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_SEP}<a class="nav" href="{U_ALBUM}">{L_ALBUM}</a>{NAV_CAT_DESC_SECOND}</span></td>
                  <!-- BEGIN show_permissions -->
                  <td align="right" valign="middle"><span class="gensmall"><a href="javascript:ShowHideLayer('info_open','info_close');"><img src="{TABS_LESS_IMG}" alt="-" align="middle" border="0" /></a></span></td>
                  <!-- END show_permissions -->
               </tr>
            </table>
         </td>
      </tr>
   </tbody>
         </table>
      </td>
   </tr>
   <tr>
      <td style="margin:0; padding: 0;" colspan="2">
         <table border="0" cellpadding="0" cellspacing="0" width="100%" id="info_close" style="display:none;">
            <tbody>
      <tr>

Was ist denn noch falsch?

ItaTschi-Chan
Lehrling
Lehrling

Weiblich Beiträge : 86
Anmeldedatum : 19.09.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von #Frank am Fr 23 Sep 2011 - 10:56

Also noch mal.
Du suchst im Template viewtopic_body diesen Abschnitt:
Code:
         <!-- BEGIN switch_user_logged_in -->
         <a name="quickreply"></a>
         {QUICK_REPLY_FORM}

         <!-- END switch_user_logged_in -->
Und diesen ersetzt du komplett durch diesen:
Code:
         <!-- BEGIN switch_user_logged_in -->
          <input type="button" value="Expressantwort Öffnen / Schliessen"
 onclick="if(document.getElementById('quick_replay').style.visibility=='collapse')
 document.getElementById('quick_replay').style.visibility='visible';
 else document.getElementById('quick_replay').style.visibility='collapse'">

<span id="quick_replay" style="visibility: collapse">
         <a name="quickreply"></a>
         {QUICK_REPLY_FORM}
</span>
         <!-- END switch_user_logged_in -->
Nicht mehr und nicht weniger musst du dort einsetzen.
Bitte versuche deinen Teil mal mit diesem zu ersetzen, weil ich da noch eine kleine Änderung gemacht habe. Hast du auch die Navi auf diese weise ausgeblendet?
Dann kann es sein, das sich beide Scripte nicht vertragen, weil du die gleiche Span Class verwendest.
Mit diesem Code sollte das aber gehen, weil ich das die Span Class geändert habe.

Aber das ist nicht mehr und nicht weniger als wie es hier beschrieben ist:
http://hilfe.forumieren.com/t27510-expressantwort-ein-ausklappbar#173650



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von ItaTschi-Chan am Do 29 Sep 2011 - 21:38

habs ersetz, sie ist zwar nicht mehr doppelt. aber sie lässt sich nicht ein und aus klappen?

ItaTschi-Chan
Lehrling
Lehrling

Weiblich Beiträge : 86
Anmeldedatum : 19.09.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von #Frank am Fr 30 Sep 2011 - 6:45

Das Ist komisch, weil bei kir klappt das einwandfrei.
Kannst du mir einen Testaccount in deinem Forum geben, damit ich mir das mal direkt ansehen kann?
Ich möchte nur erst einmal sehen, ob es bei mir geht.
Sende mir mal die Daten per PN.
Bitte den PN Button benutzen oder in meiner Signatur auf diesen BUtton klicken:



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34500
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Expressantwort ein/ausklappbar sieht nicht aus wie es sollte...

Beitrag von Leonides am Fr 30 Sep 2011 - 12:39

Hallo alle zusammen.

Also vielleicht hilft das irgendwie weiter, aber ich hab an sich das selbe Probleme im Opera und im Internet Explorer wird dieser Button dafür gar nicht angezeigt. Im Firefox funktioniert das ganze ohne Probleme.

Liebe Grüße
Leonides

Leonides
Stammgast
Stammgast

Beiträge : 267
Anmeldedatum : 21.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten