Lexi Help
Die neuesten Themen
» Begriff : "merken"
von inde Heute um 11:56

» Private Nachrichten
von inde Heute um 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde Gestern um 22:24

» Ad Ware im Forum?
von inde Gestern um 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank Gestern um 16:57

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Sa 24 Sep 2016 - 11:29

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

Partner
free forum

Wahlschalter funktioniert nicht richtig

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Wahlschalter funktioniert nicht richtig

Beitrag von Cookie am Di 2 Aug 2011 - 13:31

Hallo liebes Team!
Ich wollte gerne den Style Wechslschalter in mein Forum ein bauen. Da es das erste mal für mcih ist habe ich ein Test Forum erstellt und erst mal irgendwelche Styles von Hitskin genommen und es mit der einfachen Version probiert. (Habe das Tut von Zuckerpuppe befolgt)
Der Wahlschalter ist jetzt zwar eingestellt, aber egal auf was ich drücke es wird immer der Style angezeigt der so oder so im Forum eingestellt war. Ich denke das ich einen Fehler im Script habe, kenne mcih aber leider nicht genug aus um hin zu finden. Ich habe keine Ahnung was ich falsch gemacht habe.

Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Wechsel den Style </option><option value="wert1"> Style1 </option><option value="wert2"> Style2 </option><option value="wert3"> Style3 </option></select>';




if (type == 'wert1')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://dreamstestforum.forumieren.com/133033-itr.css">');
}
else if (type == 'wert2')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://dreamstestforum.forumieren.com/127830-itr.css">');
}
else if (type == 'wert3')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://dreamstestforum.forumieren.com/128729-itr.css">');
}


function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}

und hier der Code um den Wahlschalter zu aktivieren.

Code:
<div id=sugar></div><script type=text/javascript src=http://dreamstestforum.forumieren.com/h1-wahlschalter></script>

Hier auch noch das richtige Forum wo der Wahlschalter wenn alles funktioniert eingebaut werden soll:

http://rpg-dreams.forumieren.com/

Schon mal vielen Dank für die Antwort und auch ein Dank an Zuckerpuppe das sie das Tut erstellt hat Wink

MFG
Cookie

Cookie
Neuling
Neuling

Beiträge : 38
Anmeldedatum : 28.07.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht richtig

Beitrag von *Eagle am Di 2 Aug 2011 - 14:17

Guten Nachmittag, Cookie Wink

Der Fehler in deinem Skript, der mir sofort auffällt ist, dass es (als Beispiel) nicht
sondern
heissen sollte. Etwas anderes fällt sofort nicht auf, ich hoffe, es ist dieser Fehler..

*Eagle
Neuling
Neuling

Weiblich Beiträge : 50
Anmeldedatum : 02.11.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht richtig

Beitrag von Cookie am Di 2 Aug 2011 - 14:30

Hallo!
danke für den Tipp aber leider klappts immer noch nicht... ich habe eine neue HTML Seite erstellt wo ich den Fehler dann behoben habe, und in den Allgemeinen Foren Einstellungen unter Beschreibung das habe ich dann natürlich auch wieder verändert aber leider macht das keinen Unterschied Sad
trotzdem danke!

Cookie
Neuling
Neuling

Beiträge : 38
Anmeldedatum : 28.07.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht richtig

Beitrag von Zuckerpuppe am Do 4 Aug 2011 - 11:28

Hallo Smile

der Fehler liegt aber trotzdem in der Angabe der URL.

Du hast anscheinend einen Tippfehler drin.
Schau mal, bei dir sieht es so aus:


Du hast hier anscheinend ein großes I eingegeben...es muss aber ein kleines L sein - also l

Wenn du das noch änderst, sollte alles klappen.

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht richtig

Beitrag von Cookie am Sa 6 Aug 2011 - 15:25

uuuuhhh Embarassed *peinlich*
natürlich hattest du recht Wink
Jetzt funktionierst! Aber eine Frage hätte ich da noch:
Ich hatte ja einen eigenen Style eingestellt. Jetzt werden wenn ich einen Style auswähle teilweise der ausgewählte Style und teilweise Bilder von dem Style der vorher eingestellt war angezeigt. Wie kann ich einstellen das ganz der Style der im Wechselschalter ausgewählt wurde eingestellt wird?
Danke im vorraus und auch ein Danke an zuckerpuppe!

Cookie
Neuling
Neuling

Beiträge : 38
Anmeldedatum : 28.07.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht richtig

Beitrag von Zuckerpuppe am Sa 6 Aug 2011 - 18:52

hm, ich hab das hier schon ein paar Mal erklärt, wie man das machen muss...das ist ja dann die 2. Methode aus dem Tutorial.
Du musst die Grafiken alle einzeln per CSS benennen, also die Headergrafik, die Navigationsbuttons, etc.

Was wohl nicht austauschbar ist, sind die Icons für "neue Beiträge", "keine neuen Beiträge" und "Forum ist gesperrt", da diese über Php laufen und wir keinen Zugriff darauf haben.

Vielleicht hilft dir dieser Thread schon weiter Smile

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten