Lexi Help
Die neuesten Themen
» Themen fixieren
von inde Heute um 13:50

» [Update] Neues Theme der mobilen Version V2
von inde Heute um 13:34

» Mein altes Forum zurückbekommen
von Bigtuber Gestern um 19:18

» Begriff : "merken"
von Ray Gestern um 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Gestern um 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Mo 26 Sep 2016 - 20:56

» Private Nachrichten
von inde Mo 26 Sep 2016 - 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde So 25 Sep 2016 - 22:24

» Ad Ware im Forum?
von inde So 25 Sep 2016 - 20:38

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

Partner
free forum

[Wechselschalter] Headerproblem - Doppelt?

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

[Wechselschalter] Headerproblem - Doppelt?

Beitrag von *Eagle am Sa 30 Jul 2011 - 8:06

Sow~ Ich komme einmal wieder mit einem Problem.
Für den Threadtitel fiel mir gerade nichts besseres ein, in der SuFu fand ich leider trotz lesen vieler Themen nichts dazu.

Zwar geht es darum, dass wir im Forum vor kurzem einen Wechselschalter eingebaut haben, weil einige User den "alten" Header schöner fanden, andere den "Neuen". Es hat dank dem Tutorial alles super geklappt, wir haben unseren Orginalstyle zwei mal mit den verschiedenen Headern einbauen können. Nun aber, rund.. Vier Wochen später tritt ein Problem auf, das wir zuvor noch nicht hatten. Beim Style "Orginalstyle mit Header 1", sprich unseren eigentlichen Orginalstyle ist plötzlich der Header ein wenig nach links gerutscht und fängt rechts noch einmal an.

Da das vielleicht gerade etwas kompliziert ausgedrückt ist, zu Veranschaulichung noch zwei Screenshots.
Spoiler:
So sollte es eigentlich ausschauen; Screenshot aus dem Testforum:

Spoiler:
So sieht es aber wirklich aus; Screenshot aus dem Orginalforum

Ich hab' schon versucht den CSS Code aus dem Testforum abzuspeichern, auch FlieDen hochzuladen und habe den auch so eingefügt, aber der Header bleibt dummerweise so.. Halb doppelt? Komisch ist ja nur, dass es beim "Orginalstyle mit Header 2" alles paletti funktioniert, kein Verzug des Headers, alles gut =/

Kann mir da irgendjemand helfen?

*Eagle
Neuling
Neuling

Weiblich Beiträge : 50
Anmeldedatum : 02.11.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: [Wechselschalter] Headerproblem - Doppelt?

Beitrag von Rüdiger am Mo 1 Aug 2011 - 2:35

Hallo *Eagle.

Kannst Du beschreiben wo Du folgenden Abschnitt eingefügt hast?

Code:
<body>
<center><header><img src="http://i46.servimg.com/u/f46/16/36/69/72/header19.jpg"></header></center>

</body>

Und ggf. nochmal genau folgende Anleitung überprüfen ob der Vorgang so durchgeführt wurde.
http://hilfe.forumieren.com/t13722-skript-fur-alle-phpbb-versionen-logo-des-forums-wechselt-bei-seitenwechsel

lg. Happy

Rüdiger
Kaiser
Kaiser

Männlich Beiträge : 2160
Hinweis : Habe Internet gelöscht!
Anmeldedatum : 09.08.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: [Wechselschalter] Headerproblem - Doppelt?

Beitrag von *Eagle am Mo 1 Aug 2011 - 23:48

Ich glaube, du hast etwas falsch verstanden wegen dem Headerwechsel. Wir haben es nicht so gemacht, dass der Header bewusst wechselt. Sondern es war so, dass bei einer Abstimmung wegen einem neuen Header einige für und andere dagegen gestimmt haben und wir im Adminteam daraufhin beschlossen haben einen Wechselschalter einzubauen mit zwei Styles, der erste mit dem neuen Header, der zweite mit dem alten. So kann jeder User den Style mit dem Header wählen, den er lieber mag und es gibt keine Streitereien oder Unzufriedenheit, was das Logo angeht.

Nochmals betreffend deinem Code. Eingefügt ist der nur im Code des ersten Styles (der Bilderlink, den du gepostet hast ist derjenige für den 1. Style). Das Problem am Wechselschalter ist ja, wenn man unter Anzeige/Bilderverwaltung/Logo ein Bild drin hat, das dann in allen Styles des Wechselschalters durch angezeigt wird. Das Problem haben wir halt so gelöst, dass die beiden Styles zu einem CSS wurden mit den beiden verschiedenen Headern drin und das Hauptlogo im Adminbereich nun auf "transparent" gestellt wurde.

Vielleicht liegt es daran, dass die beiden Header eine unterschiedliche Grösse haben?
Ich hab' zwar noch weiter versucht, aber das erste Logo will und will einfach nicht korrekt erscheinen..

Edit: Der Thread kann geschlossen werden, das Problem wurde behoben..
der no-repeat beim Logo im Foren-CSS war die Lösung, vielen Dank Wink

*Eagle
Neuling
Neuling

Weiblich Beiträge : 50
Anmeldedatum : 02.11.10

Nutzerprofil anzeigen

Nach oben Nach unten

Re: [Wechselschalter] Headerproblem - Doppelt?

Beitrag von Rüdiger am Di 2 Aug 2011 - 22:14

Sorry das ich mich erst jetzt melde.

Okay, super das der Fehler behoben ist und danke für die Info.. Wink

lg. Happy

Rüdiger
Kaiser
Kaiser

Männlich Beiträge : 2160
Hinweis : Habe Internet gelöscht!
Anmeldedatum : 09.08.10

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten