Lexi Help
Partner
www.forumieren.com

Wechselschalter mit HTML-Code Fehler?

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Wechselschalter mit HTML-Code Fehler?

Beitrag von KURAI-KAGE am Do 9 Jun 2011 - 17:53

Hallo zusammen,

jetzt bräuchte ich leider auch einmal euren Rat. Ich habe nach der super erklärten Anleitung von Zuckerpuppe hier in meinem Forum einen Wechselschalter mit vier möglichen Styles eingebaut.
Er wird aber leider überhaupt nicht im Forum angezeigt. Nachdem ich nun Stunden verzweifelt nach einem Fehler im Script gesucht habe, hoffe ich, dass vielleicht von euch jemand einen Fehler entdeckt.
Hier das Script:

var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Wahl des Style </option><option value="Wert1">ORGINALSTYLE </option><option value="wert2"> Style2 </option><option value="wert3"> Style3 </option><option value="wert4"> Style4 </option></select>';




if (type == 'wert1')
{
document.write('<link rel="stylesheet" type="text/css" href="http://www.j-rock-visualkei.biz/">');
}
else if (type == 'wert2')
{
document.write('<link rel="stylesheet" type="text/css" href="http://URL EURES FORUMS/167965-ltr.css">');
}
else if (type == 'wert3')
{
document.write('<link rel="stylesheet" type="text/css" href="http://URL EURES FORUMS/165065-ltr.css">');
}
else if (type == 'wert4')
{
document.write('<link rel="stylesheet" type="text/css" href="http://URL EURES FORUMS/149517-ltr.css">');
}


function changeskin(change) {
var scheme = change;
var name = 'Vorlage1';
var pathname = location.pathname;
//var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
var ExpDate = new Date ();
ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
var cname = name + "=";
var dc = document·cookie;
if (dc.length > 0) {
begin = dc.indexOf(cname);
if (begin != -1) {
begin += cname.length;
end = dc.indexOf(";", begin);
if (end == -1) end = dc.length;
return unescape(dc.substring(begin, end));
}
}
return null;
}
function setCookie(name, value, expires, path, domain, secure) {
document·cookie = name + "=" + escape(value) +
((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
((path == null) ? "" : "; path=" + path) +
((domain == null) ? "" : "; domain=" + domain) +
((secure == null) ? "" : "; secure");
}



Und hier noch der URL-Code wo bei der "Beschreibung der Website" eingefügt worden ist.
<div id=sugar></div><script type=text/javascript src=http://http://www.j-rock-visualkei.biz/h1-wahlschalter></script>


Dickes Dankeschön schonmal im voraus
Euer
KAGE

KURAI-KAGE
Neuling
Neuling

Männlich Beiträge : 18
Anmeldedatum : 28.11.10

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wechselschalter mit HTML-Code Fehler?

Beitrag von Zuckerpuppe am Do 9 Jun 2011 - 19:01

Hallo,

der Schalter kann zum einen gar nicht angezeigt werden, weil du hier einen Fehler drin hast:
Code:
<div id=sugar></div><script type=text/javascript src=http://http://www.j-rock-visualkei.biz/h1-wahlschalter></script>

richtig müsste es heißen: (also ohne www und doppeltes http:// )
Code:
<div id=sugar></div><script type=text/javascript src=http://j-rock-visualkei.biz/h1-wahlschalter></script>

dann wird der Schalter auch angezeigt Smile

Du wirst dich dann aber wundern, warum die verschiedenen Styles nicht angezeigt werden.
Das hat folgenden Grund - zum einen lautet die Adresse deines Forums nicht:
Code:
http://www.j-rock-visualkei.biz/
sondern
Code:
http://j-rock-visualkei.biz/

zum anderen hast du im Script bei den letzten drei Styles keine Forumsadresse angegeben:
Code:
document.write('<link rel="stylesheet" type="text/css" href="http://URL EURES FORUMS/167965-ltr.css">');
}
die muss da noch rein, dann klappt das auch mit dem Wahlschalter Wink

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wechselschalter mit HTML-Code Fehler?

Beitrag von KURAI-KAGE am Fr 10 Jun 2011 - 14:38

Ganz dickes DANKESCHÖN an dich...hat jetzt super funktioniert. So von Blindheit geschlagen zu sein... Embarassed

Jetzt hätte ich noch eine kleine Frage zum Script. Könnte man darin eine Veränderung so vornehmen, dass die Header (Logo) und der Innenbereich der neu eingefügten Styles auch in meinem Forum beim Wechsel angezeigt werden?
Momentan wechseln zwar die Hintergründe und Schriftfarben. Aber der Header und die Icons sind in jedem der Styles dieselben wie vom Grundstyle. confused

KURAI-KAGE
Neuling
Neuling

Männlich Beiträge : 18
Anmeldedatum : 28.11.10

Benutzerprofil anzeigen

Nach oben Nach unten

Re: Wechselschalter mit HTML-Code Fehler?

Beitrag von Zuckerpuppe am Fr 10 Jun 2011 - 14:49

Wie du das Logo und einige andere Grafiken ja nach Style ändern kannst, habe ich hier schon in verschiedenen Beiträgen erklärt.
Schau mal, ich hab das hier beschrieben und dort findest du auch noch einen weiteren Link, der das noch genauer erklärt Smile

da ja das ursprüngliche Problem behoben ist, mach ich hier jetzt zu

-closed-

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Benutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Befugnisse in diesem Forum
Sie können in diesem Forum nicht antworten