Lexi Help
Die neuesten Themen
» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Heute um 20:56

» Begriff : "merken"
von inde Heute um 19:31

» Private Nachrichten
von inde Heute um 10:05

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde Gestern um 22:24

» Ad Ware im Forum?
von inde Gestern um 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank Gestern um 16:57

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

Partner
free forum

Wahlschalter funktioniert nicht

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Wahlschalter funktioniert nicht

Beitrag von Roxy am Di 26 Apr 2011 - 20:56

Hallo ich habe gerade ein Problem.
Und zwar habe ich mich jetzt gerade mit dem Wechselschalter beschäftigt und es in einem Probeforum von mir versucht. Da ich leider nicht genug Kenntnisse habe um die schwierigere Version zu versuchen musste ich wohl oder übel meinen Style bei Hitskin hochladen, was ich eigentlich nicht wollte.
Nun ja. Jetzt zu meinem Problem. Ich habe jetzt mehrmals alles überprüft und finde leider den Fehler nicht. Ich habe zwar den Wechselschalter, jedoch zeigt er mir immer nur ein und den selben Style an. Also der, der bereits im Forum ist. Denn hatte ich dort direkt erstellt und somit auch nicht dort hochgeladen.

Das hier ist der Code von mir
Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Change your Style </option><option value="Wert1">ORGINALSTYLE </option><option value="wert2"> Wonderful fairyland </option></select>';




if (type == 'wert1')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/forum/">');
}
else if (type == 'wert2')
{
   document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/forum/172027-ltr.css">');
}



function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}

Das die Link URL
Code:
http://isola-rpg.forumieren.com/h1-change-your-style

Und das habe ich bei der Beschreibung der Website zu stehen
Code:
 <div id=sugar></div><script type=text/javascript src=http://isola-rpg.forumieren.com/h1-change-your-style></script>

Könnte mir vielleicht jemand helfen? Ich finde den Fehler einfach nicht Sad

Und wenn ich grad schon hier bin dann noch zwei kurze Fragen dazu. Wenn ich die Kategorieüberschriften selbst als Bilder einfüge, geht das dann für beide Styles getrennt? Ich schätze mal leider nicht oder? Und mit einer Tabelle oben über die Anzeiger geht das sicher auch nicht oder?

Achso und hier noch der Link zu dem Probeforum wo ich das gerade versuche

http://isola-rpg.forumieren.com/forum

Und das hier sollte eigentlich der zweite Style sein zur Probe
http://de.hitskin.com/einen-style-suchen/x-men-suwar-172027.htm

LG Roxy

Roxy
Neuling
Neuling

Weiblich Beiträge : 55
Anmeldedatum : 28.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von #Frank am Di 26 Apr 2011 - 21:20

Du hast den Fehler im Script an dieser Stelle:
else if (type == 'wert2')
{
document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/forum/172027-ltr.css">');
Richtig muss der Link zum zweiten Style lauten:
Code:
else if (type == 'wert2')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/172027-ltr.css">');
Das ist das war mir als erstes auffällt.
Andere das mal entsprechend und dann sehen wir Weiter.

Noch was:
Bitte trage mal an dieser Stelle:
if (type == 'wert1')
{
document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/forum/">');
}
mal bitte das hier ein:
Code:
http://isola-rpg.forumieren.com/170-ltr.css



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von Roxy am Di 26 Apr 2011 - 21:35

hey danke erstmal für die schnelle hilfe. also ich habe jetzt beide sachen geändert

allerdings ist jetzt der originalstyle richtig aber den anderen style vermischt er. also die icons sind vom originalstyle und der header auch?

Code:
var type = getCookie('Vorlage1');
var sugar = document.getElementById('sugar');
sugar.innerHTML ='<select onchange="changeskin(this.options[this.selectedIndex].value);window.location.reload();"><option> Change your Style </option><option value="Wert1">ORGINALSTYLE </option><option value="wert2"> Wonderful fairyland </option></select>';




if (type == 'wert1')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/170-ltr.css">');
}
else if (type == 'wert2')
{
  document.write('<link rel="stylesheet" type="text/css" href="http://isola-rpg.forumieren.com/172027-ltr.css">');
}



function changeskin(change) {
   var scheme = change;
   var name = 'Vorlage1';
   var pathname = location.pathname;
   //var myDomain = pathname.substring(0,pathname.lastIndexOf('/')) +'/';
   var ExpDate = new Date ();
   ExpDate.setTime(ExpDate.getTime() + (180 * 24 * 3600 * 1000));
   setCookie(name,scheme,ExpDate,'/');
}
function getCookie(name){
   var cname = name + "=";
   var dc = document·cookie;
   if (dc.length > 0) {
      begin = dc.indexOf(cname);
      if (begin != -1) {
         begin += cname.length;
         end = dc.indexOf(";", begin);
         if (end == -1) end = dc.length;
         return unescape(dc.substring(begin, end));
      }
   }
   return null;
}
function setCookie(name, value, expires, path, domain, secure) {
   document·cookie = name + "=" + escape(value) +
   ((expires == null) ? "" : "; expires=" + expires.toGMTString()) +
   ((path == null) ? "" : "; path=" + path) +
   ((domain == null) ? "" : "; domain=" + domain) +
   ((secure == null) ? "" : "; secure");
}

Roxy
Neuling
Neuling

Weiblich Beiträge : 55
Anmeldedatum : 28.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von #Frank am Di 26 Apr 2011 - 21:49

Das ist schon klar, das sich das vermischt, und das ist die Antwort auf deine Frage oben.
Und wenn ich grad schon hier bin dann noch zwei kurze Fragen dazu. Wenn ich die Kategorieüberschriften selbst als Bilder einfüge, geht das dann für beide Styles getrennt? Ich schätze mal leider nicht oder? Und mit einer Tabelle oben über die Anzeiger geht das sicher auch nicht oder?
Kennst du nun die Antwort auf deine Frage?

Wenn du das auch noch ändern möchtest, dann musst du das ganz anders angehen und all diese Einstellungen über das CSS einrichten.
Hierfür sind genaue Kenntnisse über das CSS und die Möglichkeiten, ein gutes Werkzeug zum bestimmen der richtigen CSS Einträge und viel Zeit notwendig.
Und dann musst du auch die Zweite Variante benutzen in dem du deine CSS Datei Auf einen Speicherplatz im Netz hoch lädst.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von Roxy am Di 26 Apr 2011 - 21:55

öhm ok.
gut das übersteigt nun wirklich meine kenntnisse. Denn ich wüsste nicht einmal wo ich da ansetzen muss Sad
ich wusste nicht, dass die icons und alles sich da auch vermischen.
Nagut nun bin ich schlauer und muss mich wohl erstmal mit einem style zufrieden geben.

Trotzdem danke für die schnelle hilfe.

LG

Roxy
Neuling
Neuling

Weiblich Beiträge : 55
Anmeldedatum : 28.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von Roxy am Di 26 Apr 2011 - 21:59

Ich habe noch ein anliegen. ich habe meinen style nur wegen dieser funktion hochgeladen und ehrlich gesagt wollte ich das eigentlich nicht und habe es nur gemacht, damit ich das hinkriege. ist es möglich dass ihr den bei hitskin wieder löschen lassen könntet?
Denn das ganze klappt ja nun nicht und dann würde ich den Style auch gerne erstmal weiterhin für mich behalten wollen. Wäre wirklich lieb.

http://demo.nicetheme.com/forum?theme_id=172025

Roxy
Neuling
Neuling

Weiblich Beiträge : 55
Anmeldedatum : 28.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von #Frank am Di 26 Apr 2011 - 22:20

Da muss ich bei der Technik eine Anfrage stellen.
Ich melde mich hier wieder wenn der Style gelöscht ist.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von #Frank am Do 28 Apr 2011 - 18:45

Hallo,
dein Style ist auf Hitskin gelöscht.



Keine Unaufgeforderten PN senden! Unsere Regeln Passwort vergessen ? Info's zu den Gründerdaten
Mein IPad schreibt die tollsten Wörter... Nicht wundern... Einfach geniessen...!

Meine Geduld wird geladen:

Fortschritt: 67%
Never change a running system on Friday!

#Frank
Administrator
Administrator

Männlich Beiträge : 34499
Hinweis : Never change a running system on Friday!
Anmeldedatum : 13.08.08
Firefox

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Wahlschalter funktioniert nicht

Beitrag von Roxy am Do 28 Apr 2011 - 21:37

Danke schön nochmal.

LG

Roxy
Neuling
Neuling

Weiblich Beiträge : 55
Anmeldedatum : 28.01.11

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten