Lexi Help
Die neuesten Themen
» Entfernen von der Popupleiste
von Bigtuber Heute um 20:14

» [phpBB2] Schriftfarbe nicht vollständig
von Fayé Heute um 20:14

» [Wichtige Information] Meine Tätigkeit in diesem Support. Von #Frank
von #Frank Heute um 13:42

» [Update] Neues Theme der mobilen Version V2
von #Frank Heute um 13:03

» Mobile Ansicht leider Fehlerhaft
von Br0adsw0rd Gestern um 19:31

» [phpBB2] Hintergrund festpinnen
von Fayé Gestern um 16:56

» Mein altes Forum zurückbekommen
von Bigtuber Do 29 Sep 2016 - 22:59

» Impressum
von #Frank Mi 28 Sep 2016 - 23:45

» [phpBB2] Im Beitrag Bild und Text nebeneinander anzeigen
von #Frank Mi 28 Sep 2016 - 23:43

» [phpBB2] Unicode Emojis im Forum
von Mariacher J.E. Mi 28 Sep 2016 - 22:07

» Themen-Icons
von Bigtuber Mi 28 Sep 2016 - 20:46

» [phpBB2] Schriftfarbe in der Expressantwort
von Bigtuber Mi 28 Sep 2016 - 20:09

» Themen fixieren
von inde Mi 28 Sep 2016 - 20:05

» Begriff : "merken"
von Ray Di 27 Sep 2016 - 12:14

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Di 27 Sep 2016 - 11:07

» Servamp Forum
von Raine Kamiya Mo 26 Sep 2016 - 22:47

Partner
free forum

Problem mit Anker

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Problem mit Anker

Beitrag von Sk_Pleasant am Do 10 Dez 2009 - 23:03

Hi,

ich habe in meinem Forum ein Beitrag in HTML geschrieben, in dem unter anderem ein Anker vorkam. Jedoch verfärbt sich der Bereich, auf den sich der Anker bezieht, wenn die Maus darüberfährt, rosa.

Mein Skript sieht so aus:
Code:
<a name="anfang" id="anfang">Dieser Bereich färbt sich rosa. </a>

<a href="#anfang">Hier klicken!</a>

Wie kann ich verhindern, dass sich der Text rosa färbt?

mfg
S&P

Sk_Pleasant
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 10.12.09

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Problem mit Anker

Beitrag von steive am Fr 11 Dez 2009 - 0:41

das ist der maus-hover... ist bei mir genau so... muss mal gucken aber wenn ein mod was besseres weiß denn muss ich mir das auch mal ab speichern^^

steive
Kaiser
Kaiser

Männlich Beiträge : 1056
Hinweis : HTML, CSS, PHP
Anmeldedatum : 21.07.09

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Problem mit Anker

Beitrag von Zuckerpuppe am Fr 11 Dez 2009 - 10:08

wie steive schon sagt...das ist die Hoverfunktion, die ja überall in deinem Forum so eingestellt ist.
Wenn du das umgehen möchtest, dass sich der Link dann einfärbt, musst du das übers CSS so definieren.
Es ist möglich, nur die Links in den Beiträgen so einzustellen, dass sie sich farblich nicht verändern, was ich allerdings suboptimal finde, denn dann erkennen die User nicht auf Anhieb, dass es sich um einen Link handelt..

Beitragslinks definierst du im CSS bei bb3 folgendermaßen (nur ein Beispiel, ist nach Belieben veränderbar)

Code:
.postbody a:link {color: #841F11; text-decoration: underline;}
.postbody a:visited {color: #841F11; text-decoration: underline;}
.postbody a:active {color: #6EB5A3; text-decoration: underline;}
.postbody a:hover {color: #6EB5A3; text-decoration: underline;}

Zuckerpuppe
Admin a.D.
Admin a.D.

Weiblich Beiträge : 19541
Anmeldedatum : 24.04.08

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Problem mit Anker

Beitrag von Sk_Pleasant am Fr 11 Dez 2009 - 15:03

Hi Zuckerpuppe,

vielen Dank für deine Hilfe, habe jetzt doch noch eine Möglichkeit gefunden, man kann einfach ein Leerzeichen hinter das Wort, das man ankern will, setzen, und dann das a-Element auf das Leerzeichen anwenden Very Happy Ihr könnt also hier schließen.

mfg
S&P

Sk_Pleasant
Neuling
Neuling

Beiträge : 2
Anmeldedatum : 10.12.09

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten