Lexi Help
Die neuesten Themen
» Private Nachrichten
von inde Gestern um 22:32

» Wie kann man erkennen, welche Forenversion ein anderes Forum hat?
von inde Gestern um 22:24

» Ad Ware im Forum?
von inde Gestern um 20:38

» [Update] Neues Theme der mobilen Version V2
von #Frank Gestern um 16:57

» [phpBB2] Probleme mit der "Postprofil" Anzeige
von Dr.Keks Sa 24 Sep 2016 - 11:29

» [Sammelthread] Unangebrachte Werbung
von inde Fr 23 Sep 2016 - 9:00

» [PunBB] Umzug eines funktionierenden Forums von PunBB auf phpBB?
von inde Do 22 Sep 2016 - 20:30

» [phpBB2] Gruppen in der Wer is Online Anzeige "trennen"
von TheRollyJoger Mi 21 Sep 2016 - 10:49

» Yaruma - Fantasy-RPG Forum
von Alketa Di 20 Sep 2016 - 21:34

» [phpBB3] Links automatisch kursiv
von inde Di 20 Sep 2016 - 17:37

» [Invision] Kompletter Css-Codebaum gesucht !
von inde Di 20 Sep 2016 - 13:12

» Filmforum "Dark Movie Dreams"
von Ray Di 20 Sep 2016 - 11:56

» Forumseite mit Mailware verseucht ?
von inde Mo 19 Sep 2016 - 20:31

» Ich kann keine Hintergrundbilder hochladen
von Serv Mo 19 Sep 2016 - 19:59

» SQL Zugang
von inde Mo 19 Sep 2016 - 18:56

» Design vergrößern. Probleme mit Design.
von Minka02 Mo 19 Sep 2016 - 17:42

Partner
free forum

Hoverbutton in der Navi

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach unten

Hoverbutton in der Navi

Beitrag von Hayamoto am Mo 16 Feb 2009 - 9:16

Hallo.

Habe jetzt nur einen Beitrag darüber gefunden und auf den kam keine Antwort, nur dass man so einen Effekt über das Template einstellen kann.

Kann mir denn jemand sagen, wie der Code für einen Hovereffekt ist und wo ich ihn einbauen muss, damit ich das für jeden Button in der Navileiste haben kann?

Wär echt klasse.

Danke i.V oraus.

Haya

Hayamoto
Lehrling
Lehrling

Weiblich Beiträge : 163
Anmeldedatum : 03.10.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Gast.. am Mo 16 Feb 2009 - 12:24

Link entfernt by ZP, da nicht mehr aufrufbar!




Bitte beachten Sie dieses Reglement für einen vernünftigen Ablauf des Support:

  • Respektiere die Forenregeln.
  • Niemals die Email-Adresse oder die Email-Adresse der Forengründung in einem öffentlichen Beitrag veröffentlichen.
  • Für die Anforderung eines neuen Passwortes (nur Forengründer) bitte einen Beitrag in Verbindungsprobleme eröffnen.
    Nach Aufforderung bitte die Gründermailadresse und URL des Forum als PN an das entsprechende Teammitglied senden.


Zuletzt von Zuckerpuppe am Mi 20 Jun 2012 - 9:44 bearbeitet, insgesamt 1 mal bearbeitet (Grund : Link entfernt!)

Gast..
Gast


Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Hayamoto am Di 17 Feb 2009 - 1:16

Danke für den Link. Hat alles funktioniert bis auf die eigenen Seiten Very Happy

Hayamoto
Lehrling
Lehrling

Weiblich Beiträge : 163
Anmeldedatum : 03.10.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Alex am Di 17 Feb 2009 - 2:27

Hi Smile

wo klemmts denn genau?

Hast du noch eigene Buttons?



LG,
Alex Smile

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Hayamoto am Di 17 Feb 2009 - 11:09

Hi.
Ja.

Einen Impressum Button hatte ich noch.

Hayamoto
Lehrling
Lehrling

Weiblich Beiträge : 163
Anmeldedatum : 03.10.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Alex am Di 17 Feb 2009 - 11:18

Hi Smile

Hast du den schon in 2 bzw. drei Ausführungen + das transparente GIF?

Der lässt sich natürlich auch mit rein baun. Wink









LG,
Alex Smile

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Hayamoto am Di 17 Feb 2009 - 11:40

ja, habe ich

Hayamoto
Lehrling
Lehrling

Weiblich Beiträge : 163
Anmeldedatum : 03.10.07

Nutzerprofil anzeigen

Nach oben Nach unten

Re: Hoverbutton in der Navi

Beitrag von Alex am Di 17 Feb 2009 - 12:59

Jo,

dann funktioniert das genau wie bei den anderen Buttons auch. Allerdings nur mit einem Button, weitere Buttons lassen sich dann nicht mehr zusätzlich einfügen. Da müsstest du dann den Impressum-Link verlegen. Wäre ja bei BB2 in dem Fall auch kein Problem dank den Templates. Wink

1. Die URLs in den CSS-Code setzen, ich nehm mal wieder die gleichen Bezeichnungen wie bei den anderen mit _0 , _1 und _2 hintendran (_2 nur wenn du hast)


Code:
/*** Zusätzlicher Button ***/

a.mainmenu img  {
       background-image: url('http://ZUSATZBUTTON_0.gif');
   }
a.mainmenu img:hover {
       background-image: url('http://ZUSATZBUTTON_1.gif');
   }
a.mainmenu img:active,
a.mainmenu img:focus  {
       background-image: url('http://ZUSATZBUTTON_2.gif');
   }

3. Das transparente Gif einsetzen:

Unter Adminbereich/Anzeige/Startseite/Kopfteil und Navigation und dort in der Zeile deines Impressums auf zahnrad klicken und im folgenden Fenster als Bild-URL eintragen.


3. Den _1 und falls vorhanden _2 -Button auch zu den anderen in das overall_header_new-Template setzen mit dem Code

Code:
<img src="http://ZUSATZBUTTON_1.gif" style="visibility: hidden;" width="1" height="1">

und falls du hast auch:

Code:
<img src="http://ZUSATZBUTTON_2.gif" style="visibility: hidden;" width="1" height="1">

Falls es Probleme gibt werd ich mir das nochmal in deinem Forum anschaun. Mein Acc wurde ja geprunt Cool , aber der Impressum-Button ist ja auch für Gäste sichtbar. Wink




LG,
Alex Smile

Alex
Admin a.D.
Admin a.D.

Männlich Beiträge : 8116
Anmeldedatum : 02.09.07

Nutzerprofil anzeigen

Nach oben Nach unten

Vorheriges Thema anzeigen Nächstes Thema anzeigen Nach oben


 
Forenbefugnisse:
Sie können in diesem Forum nicht antworten